Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Calibre 9.2 fails to build [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1507
Location: Edinburgh, Scotland

PostPosted: Sun Mar 03, 2013 4:14 pm    Post subject: Calibre 9.2 fails to build [solved] Reply with quote

Hi all,

When trying to update calibre to 9.2.0 the build fails. The relevant bits appear to be as follows:

Code:

RuntimeError: the sip module implements API v9.0 to v9.1 but the PyKDE4.kdeui module requires API v8.1
 ^[[31;01m*^[[0m ERROR: app-text/calibre-0.9.20 failed (install phase):
 ^[[31;01m*^[[0m   (no error message)
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m Call stack:
 ^[[31;01m*^[[0m     ebuild.sh, line  93:  Called src_install
 ^[[31;01m*^[[0m   environment, line 4754:  Called die
 ^[[31;01m*^[[0m The specific snippet of code:
 ^[[31;01m*^[[0m       PATH=${T}:${PATH} PYTHONPATH=${S}/src${PYTHONPATH:+:}${PYTHONPATH} python setup.py install --root="${D}" --prefix="${EPREFIX}/usr" --libdir="${EPREFIX}/usr/${libdir}" --staging-root="$
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m If you need support, post the output of `emerge --info '=app-text/calibre-0.9.20'`,
 ^[[31;01m*^[[0m the complete build log and the output of `emerge -pqv '=app-text/calibre-0.9.20'`.
 ^[[31;01m*^[[0m The complete build log is located at '/var/tmp/portage/app-text/calibre-0.9.20/temp/build.log'.
 ^[[31;01m*^[[0m The ebuild environment file is located at '/var/tmp/portage/app-text/calibre-0.9.20/temp/environment'.
 ^[[31;01m*^[[0m Working directory: '/var/tmp/portage/app-text/calibre-0.9.20/work/calibre'
 ^[[31;01m*^[[0m S: '/var/tmp/portage/app-text/calibre-0.9.20/work/calibre'


I tried revdep-rebuild and it finds no problems. I also tried python-updater which found several packages, re-emerged them, though that didn't work, either. However, it always tries to re-emerge those packages for some reason.

Any help would be appreciated.

Best,

Alex


Last edited by evoweiss on Wed Mar 06, 2013 7:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Sun Mar 03, 2013 4:19 pm    Post subject: Reply with quote

evoweiss.

Code:
 ^[[31;01m*^[[0m ERROR: app-text/calibre-0.9.20 failed (install phase)

It built, then failed to install. Disk full ?

What does the build log show /var/tmp/portage/app-text/calibre-0.9.20/temp/build.log ?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1507
Location: Edinburgh, Scotland

PostPosted: Sun Mar 03, 2013 4:27 pm    Post subject: Reply with quote

Hi there,

The disk has around 13 gigs left on it, so I doubt it's that. However, I will try to uninstall and then re-emerge calibre to make sure. If that fails, I'll post the full build.log file. I posted the last bit that shows the error above.

Best

Alex

NeddySeagoon wrote:
evoweiss.

Code:
 ^[[31;01m*^[[0m ERROR: app-text/calibre-0.9.20 failed (install phase)

It built, then failed to install. Disk full ?

What does the build log show /var/tmp/portage/app-text/calibre-0.9.20/temp/build.log ?
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1507
Location: Edinburgh, Scotland

PostPosted: Sun Mar 03, 2013 4:40 pm    Post subject: Reply with quote

That didn't work.

The build.log file is here.

Best,

Alex
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8592

PostPosted: Sun Mar 03, 2013 4:53 pm    Post subject: Re: Calibre 9.2 fails to build Reply with quote

evoweiss wrote:
Code:

RuntimeError: the sip module implements API v9.0 to v9.1 but the PyKDE4.kdeui module requires API v8.1
 ^[[31;01m*^[[0m ERROR: app-text/calibre-0.9.20 failed (install phase):
 ^[[31;01m*^[[0m   (no error message)
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m Call stack:
 ^[[31;01m*^[[0m     ebuild.sh, line  93:  Called src_install
 ^[[31;01m*^[[0m   environment, line 4754:  Called die
 ^[[31;01m*^[[0m The specific snippet of code:
 ^[[31;01m*^[[0m       PATH=${T}:${PATH} PYTHONPATH=${S}/src${PYTHONPATH:+:}${PYTHONPATH} python setup.py install --root="${D}" --prefix="${EPREFIX}/usr" --libdir="${EPREFIX}/usr/${libdir}" --staging-root="$
According to this, and confirmed by the full build log, the src_install phase runs a Python script to do some final processing. That script dies with a Python RuntimeError exception because it is not compatible with the supporting libraries on the system. What version of PyKDE4.kdeui are you using? Does it work if you use a newer one?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Sun Mar 03, 2013 4:56 pm    Post subject: Reply with quote

evoweiss,

Code:
RuntimeError: the sip module implements API v9.0 to v9.1 but the PyKDE4.kdeui module requires API v8.1

I missed that in your first post.

You have API version mismatches but I don't know how to resolve it.

You could try app-text/calibre-0.9.21, which is in ~arch
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1507
Location: Edinburgh, Scotland

PostPosted: Sun Mar 03, 2013 5:03 pm    Post subject: Re: Calibre 9.2 fails to build Reply with quote

Hu wrote:
According to this, and confirmed by the full build log, the src_install phase runs a Python script to do some final processing. That script dies with a Python RuntimeError exception because it is not compatible with the supporting libraries on the system. What version of PyKDE4.kdeui are you using? Does it work if you use a newer one?


The installed version of pykde4 is 4.9.5. I'll see whether upgrading it to ~x86 helps.

Best,

Alex
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1507
Location: Edinburgh, Scotland

PostPosted: Sun Mar 03, 2013 9:22 pm    Post subject: Reply with quote

NeddySeagoon wrote:
evoweiss,

Code:
RuntimeError: the sip module implements API v9.0 to v9.1 but the PyKDE4.kdeui module requires API v8.1

I missed that in your first post.

You have API version mismatches but I don't know how to resolve it.

You could try app-text/calibre-0.9.21, which is in ~arch


Thanks for the suggestion. Unfortunately, that didn't do the trick. I'm not sure how things got to be this way.

Also, am I wrong or is it not normal for python-updater to re-emerge the same set of packages every time you run it?

Best,

Alex
Back to top
View user's profile Send private message
Goverp
Guru
Guru


Joined: 07 Mar 2007
Posts: 325

PostPosted: Mon Mar 04, 2013 9:17 am    Post subject: Reply with quote

FWIW, I hit both situations when I last updated - Calibre fails to build with some API mismatch, and python-updater appears to always decide the same packages need updating - indeed some of them were newly installed, I think as a result of installing Calibre! I just ignored the problem and stayed with the older Calibre.
_________________
Greybeard
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5268

PostPosted: Mon Mar 04, 2013 10:26 am    Post subject: Reply with quote

That runtime error suggests somebody failed to follow the message from dev-python/sip upgrade.
Back to top
View user's profile Send private message
Robelix
l33t
l33t


Joined: 21 Jul 2002
Posts: 760
Location: in a World created by a Flying Spaghetti Monster

PostPosted: Mon Mar 04, 2013 6:52 pm    Post subject: Reply with quote

remerging PyQt4 and pykde4 helped me to solve this.
_________________
mysql> SELECT question FROM life, universe, everything WHERE answer=42;
Empty set (2079460347 sec)
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1507
Location: Edinburgh, Scotland

PostPosted: Mon Mar 04, 2013 9:51 pm    Post subject: Reply with quote

VoidMage wrote:
That runtime error suggests somebody failed to follow the message from dev-python/sip upgrade.


I don't recall receiving such a message, though I could have missed it. However, re-emerging sip doesn't give me any message. I'll re-emerge packages that depend on sip to see if that does the trick.

Best,

Alex
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1507
Location: Edinburgh, Scotland

PostPosted: Wed Mar 06, 2013 7:57 pm    Post subject: Reply with quote

Hi all,

I managed to fix the problem. I searched for the packages that depend on sip and rebuilt those packages. Once that was done, calibre installed no problem. Thanks for your help.

Best,

Alex
Back to top
View user's profile Send private message
Lori
Apprentice
Apprentice


Joined: 30 Mar 2004
Posts: 265
Location: Barcelona, Spain

PostPosted: Tue Mar 12, 2013 10:58 am    Post subject: Reply with quote

Thanks guys, I had the same issue building calibre 0.9.20, and remerging sip deps dev-python/qscintilla-python kde-base/plasma-workspace kde-base/pykde4 solved the problem for me as well.
_________________
"The hunt is sweeter then the kill."
Registered Linux User #176911
Back to top
View user's profile Send private message
Viorel
n00b
n00b


Joined: 13 Feb 2012
Posts: 3

PostPosted: Sat Mar 30, 2013 7:14 pm    Post subject: Reply with quote

Robelix wrote:
remerging PyQt4 and pykde4 helped me to solve this.

Same here, thanks. I also had to add USE=script to PyQt4.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum