Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Apache 2.4.4: CGI files displayed not executed [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
binro
l33t
l33t


Joined: 06 May 2005
Posts: 623
Location: Bangkok, Thailand

PostPosted: Sat Mar 02, 2013 6:34 pm    Post subject: Apache 2.4.4: CGI files displayed not executed [SOLVED] Reply with quote

Apache upgrades are getting to be quite a bore. Having eventually managed 2.2 to 2.4, I casually upgraded from 2.4.3 to 2.4.4-r1 and now most of my PHP apps don't work. I have had the following set up for years:
00_default_vhost.conf
Code:

<IfDefine DEFAULT_VHOST>
Listen 80
<VirtualHost *:80>
   ServerName localhost
   Include /etc/apache2/vhosts.d/default_vhost.include

      # Keep PHP applications separate

      Alias "/phpmyadmin" "/var/www/phpmyadmin"
      <Directory "/var/www/phpmyadmin">
                  Options Indexes FollowSymLinks ExecCGI
        Require all granted
      </Directory>

</VirtualHost>
</IfDefine>

and httpd.conf has
Code:

Options +ExecCGI
AddHandler cgi-script .cgi

included. All the correct new flags and options are set. It all worked this morning! Now when I click the URL for phpmyadmin I see the code! What has suddenly changed?

TIA
_________________
"Ship me somewheres east of Suez, where the best is like the worst,
Where there ain't no Ten Commandments an' a man can raise a thirst"
from "Mandalay" by Rudyard Kipling


Last edited by binro on Sun Mar 03, 2013 1:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
papahuhn
l33t
l33t


Joined: 06 Sep 2004
Posts: 623

PostPosted: Sat Mar 02, 2013 8:58 pm    Post subject: Re: Apache 2.4.4: CGI files displayed not executed Reply with quote

Maybe you should use mod_php then.
_________________
Death by snoo-snoo!
Back to top
View user's profile Send private message
binro
l33t
l33t


Joined: 06 May 2005
Posts: 623
Location: Bangkok, Thailand

PostPosted: Sun Mar 03, 2013 7:13 am    Post subject: Re: Apache 2.4.4: CGI files displayed not executed Reply with quote

papahuhn wrote:
Maybe you should use mod_php then.

That was the problem! During the update the -DPHP5 got removed from /etc/conf.d/apache2 and nobody asked me. Still a problem with Nagios but I don't have time now, more details later. :?

Thanks.
_________________
"Ship me somewheres east of Suez, where the best is like the worst,
Where there ain't no Ten Commandments an' a man can raise a thirst"
from "Mandalay" by Rudyard Kipling
Back to top
View user's profile Send private message
binro
l33t
l33t


Joined: 06 May 2005
Posts: 623
Location: Bangkok, Thailand

PostPosted: Sun Mar 03, 2013 1:46 pm    Post subject: Reply with quote

Same problem, -D NAGIOS was removed. Panic over. :)
_________________
"Ship me somewheres east of Suez, where the best is like the worst,
Where there ain't no Ten Commandments an' a man can raise a thirst"
from "Mandalay" by Rudyard Kipling
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum