Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] NetworkManager suddenly won't stay connected...
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message

Joined: 14 Feb 2013
Posts: 3

PostPosted: Thu Feb 14, 2013 7:41 pm    Post subject: [SOLVED] NetworkManager suddenly won't stay connected... Reply with quote

Just completed a gentoo installation on my laptop. I'm using NetworkManager (which I put in the default rc runlevel) and nm-applet (which I'm starting from my fluxbox startup file). Everything has been working perfectly for 24 hours or so, but now my machine refuses to connect to either of my wireless routers half the time, prompting me over and over for a network key. One is WPA and the other WPA2. Even when it does connect, the connection is only stable for 10 seconds at most, at which point it keels over, dies, then gives me a notification that the network has been disconnected. The most recent change that I made was recompiling my kernel to have crypto support (Blowfish, etc). I can't think of anything else that would be interfering with it. I also can't seem to find any NetworkManager-related logs anywhere in /var/log. Any ideas?

EDIT: SOLVED MY OWN PROBLEM. I realized that I had installed wicd at one point just for S+G, but I had never added it to the default runlevel, so that couldn't be it. I unmerged it for good measure but was still being met with grief. Did a ps -A | grep net to see if anything funky was going on and noticed that there was an instance of net.wlan0 with a lower pid than NetworkManager. Doing a killall net.wlan0 and THEN connecting seemed to work. Did a rc-config list default and saw net.wlan0 on there... somehow it ended up in there even though I had taken it out prior to installing NetworkManager. I postulate that wicd or some similar change did this and because I didn't -v the emerge I wasn't notified. Either way I removed it and all is well again. Moral of the story: I'm a n00b.
"There iz no spoon."

-The Matricks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum