Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sound not working after update intel ich9
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
tuner23
n00b
n00b


Joined: 18 May 2006
Posts: 68

PostPosted: Wed Mar 06, 2013 4:22 pm    Post subject: Sound not working after update intel ich9 Reply with quote

Hello,


i have the problem that my soundcard does not work anymore after a world-update.

Here's my data:

Code:
lspci -v | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)


Code:

lspci -n | grep 00:1b.0


Code:
cat /var/tmp/alsaconf.cards
PCI: 0x8086=0x293e


Code:
eix -I alsa
[I] media-libs/alsa-lib
     Available versions:  1.0.24.1 1.0.25-r1 ~1.0.26 ~1.0.26-r1 {{alisp alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mmap_emul alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol debug doc python python_single_target_python2_6 python_single_target_python2_7 python_targets_python2_6 python_targets_python2_7 static-libs}}
     Installed versions:  1.0.25-r1(09:44:58 14.08.2012)(python -alisp -debug -doc)
     Homepage:            http://www.alsa-project.org/
     Description:         Advanced Linux Sound Architecture Library

[I] media-plugins/alsa-plugins
     Available versions:  1.0.24 ~1.0.25 1.0.25-r1 ~1.0.25-r2 ~1.0.26 {{debug ffmpeg jack libsamplerate pulseaudio speex}}
     Installed versions:  1.0.25-r1(23:22:31 04.03.2013)(ffmpeg pulseaudio -debug -jack -libsamplerate -speex)
     Homepage:            http://www.alsa-project.org/
     Description:         ALSA extra plugins

[I] media-plugins/gst-plugins-alsa
     Available versions:  (0.10) 0.10.36^t
     Installed versions:  0.10.36(0.10)^t(20:32:48 03.03.2013)
     Homepage:            http://gstreamer.freedesktop.org/
     Description:         plugin for gstreamer

[I] media-sound/alsa-headers
     Available versions:  1.0.23^bs 1.0.24^bs 1.0.25^bs **9999^bs
     Installed versions:  1.0.25^bs(21:23:12 13.08.2012)
     Homepage:            http://www.alsa-project.org/
     Description:         Header files for Advanced Linux Sound Architecture kernel modules

[I] media-sound/alsa-utils
     Available versions:  (0.9) 1.0.24.2-r1 1.0.25-r1 ~1.0.26 ~1.0.26-r1 ~1.0.26-r2
        {{doc +libsamplerate minimal +ncurses nls selinux}}
     Installed versions:  1.0.25-r1(0.9)(16:12:47 06.03.2013)(nls -doc -minimal -selinux)
     Homepage:            http://www.alsa-project.org/
     Description:         Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)



Code:
uname -r
3.7.10-gentoo


Code:
cat .config | grep CONFIG_SND | grep -v "is not set"
CONFIG_SND=m
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_HWDEP=m
CONFIG_SND_JACK=y
CONFIG_SND_SEQUENCER=m
CONFIG_SND_SEQ_DUMMY=m
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_HRTIMER=m
CONFIG_SND_SEQ_HRTIMER_DEFAULT=y
CONFIG_SND_DYNAMIC_MINORS=y
CONFIG_SND_SUPPORT_OLD_API=y
CONFIG_SND_VERBOSE_PROCFS=y
CONFIG_SND_VMASTER=y
CONFIG_SND_KCTL_JACK=y
CONFIG_SND_DMA_SGBUF=y
CONFIG_SND_DRIVERS=y
CONFIG_SND_ALOOP=m
CONFIG_SND_PCI=y
CONFIG_SND_HDA_INTEL=m
CONFIG_SND_HDA_PREALLOC_SIZE=64
CONFIG_SND_HDA_HWDEP=y
CONFIG_SND_HDA_RECONFIG=y
CONFIG_SND_HDA_INPUT_JACK=y
CONFIG_SND_HDA_PATCH_LOADER=y
CONFIG_SND_HDA_CODEC_REALTEK=y
CONFIG_SND_HDA_CODEC_ANALOG=y
CONFIG_SND_HDA_CODEC_SIGMATEL=y
CONFIG_SND_HDA_CODEC_VIA=y
CONFIG_SND_HDA_CODEC_HDMI=y
CONFIG_SND_HDA_CODEC_CIRRUS=y
CONFIG_SND_HDA_CODEC_CONEXANT=y
CONFIG_SND_HDA_CODEC_CA0110=y
CONFIG_SND_HDA_CODEC_CA0132=y
CONFIG_SND_HDA_CODEC_CMEDIA=y
CONFIG_SND_HDA_CODEC_SI3054=y
CONFIG_SND_HDA_GENERIC=y
CONFIG_SND_HDA_POWER_SAVE_DEFAULT=0


Code:
lsmod
Module                  Size  Used by
vboxpci                11618  -2
vboxnetadp             17146  -2
vboxnetflt             12866  -2
vboxdrv              1754976  -2
snd_hda_codec_conexant    44391  -2
snd_hda_intel          25534  -2
snd_hda_codec          97698  -2
snd_hwdep               5302  -2
snd_pcm                71875  -2
snd_page_alloc          7097  -2
snd_timer              17304  -2
snd                    58321  -2
soundcore               5563  -2


btw. what means -2 here?

Code:
cat /etc/modprobe.d/alsa.conf
# Alsa kernel modules' configuration file.

# ALSA portion
# OSS/Free portion

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.25 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
# --- END: Generated by ALSACONF, do not edit. ---


I have 2 lenovo laptops and it does not work on both after the update, so "never change a running system" :-)

In the and and after lots of hacking i have no idea where the problem here is..

Maybe it's depending on pulseaudio installed or on udev? don't know..

System seems to be clean in this way, that world-update is done reverse-dependencies are rebuilt and i runned depclean befor rebuild.

When i run alsaconf, it founds no soundcard..


Can someone help me out solving this issue here?

Thanks in advance,
Antonios.
Back to top
View user's profile Send private message
tuner23
n00b
n00b


Joined: 18 May 2006
Posts: 68

PostPosted: Wed Mar 06, 2013 5:19 pm    Post subject: Reply with quote

.. when i boot, it comes up with following messages:

Code:
Mar  6 18:15:11 aaron kernel: [    1.761748] thinkpad_acpi: volume: disabled as there is no ALSA support in this kernel
Mar  6 18:15:25 aaron pulseaudio[3613]: [pulseaudio] pid.c: Daemon already running.
Mar  6 18:15:25 aaron pulseaudio[3619]: [pulseaudio] pid.c: Daemon already running.
Mar  6 18:16:35 aaron /etc/init.d/alsasound[3820]: WARNING: you are stopping a boot service
Mar  6 18:16:35 aaron /etc/init.d/alsasound[3833]: alsasound: unknown function `unload'

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum