Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVEDE] emerge fails w OSError [Errno 22] Invalid argument
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
codecaine21
n00b
n00b


Joined: 15 Mar 2014
Posts: 5

PostPosted: Sat Mar 15, 2014 10:09 pm    Post subject: [SOLVEDE] emerge fails w OSError [Errno 22] Invalid argument Reply with quote

roots context is sysadm_t and can emerge packages with no problem but my regular user fails with OSError [Errno 22] Invalid argument. This happens when i try to emerge any package. I check the id for my regular user and it returns

id -Z
Code:

context=system_u:system_r:kernel_t


When I log in as regular user from a tty, it prompts me to enter a new securty context. I choose to oblige and enter sysadm_t and it gives me this error
Code:

unable to get valid context for codecaine21
No directory, logging in with HOME=/


Any ideas??


Last edited by codecaine21 on Sun Mar 16, 2014 9:03 pm; edited 2 times in total
Back to top
View user's profile Send private message
codecaine21
n00b
n00b


Joined: 15 Mar 2014
Posts: 5

PostPosted: Sun Mar 16, 2014 5:24 am    Post subject: Reply with quote

i just set selinux to disabled in /etc/selinux/config. Not my ideal solution but it works.
Back to top
View user's profile Send private message
escravana
n00b
n00b


Joined: 25 Jan 2014
Posts: 9

PostPosted: Fri Mar 28, 2014 11:11 am    Post subject: Reply with quote

I had the same problem, and when makeing su from regular user to root had to:
Code:
newrole -r sysadm_r


Then it worked fine.
If you disabled selinux, you may need to relabel everything (follow the Gentoo SELinux Installation / Converstion wiki).
Back to top
View user's profile Send private message
codecaine21
n00b
n00b


Joined: 15 Mar 2014
Posts: 5

PostPosted: Sun Mar 30, 2014 8:04 pm    Post subject: Reply with quote

escravana wrote:
I had the same problem, and when makeing su from regular user to root had to:
Code:
newrole -r sysadm_r


Then it worked fine.
If you disabled selinux, you may need to relabel everything (follow the Gentoo SELinux Installation / Converstion wiki).


Yeah I tried setting a newrole from root but it wouldnt let me. I checked my users id with id -Z and the role was set to kernel_t. Which google didnt have any information on. At least that my googlefu was able to find. So i just disabled selinux altogether.

But thank you for the link at the bottom of your post. I havent relabeled anything and everything has been working fine. I even updated world since then and recompiled kernel a few times. No issues "yet" lol Thanks again escravana
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum