Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
systemd puts system to sleep after 30 seconds
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
A08
n00b
n00b


Joined: 26 Oct 2003
Posts: 7
Location: Earth, Europe, Germany, Schöneiche

PostPosted: Tue Sep 22, 2015 8:38 pm    Post subject: systemd puts system to sleep after 30 seconds Reply with quote

Every time NO desktop environment(in my case Plasma 5) is loaded, the system is going to sleep after approximately 30 seconds.

The system worked fine before changing from OpenRC to systemd and I have already checked /etc/systemd/logind.conf: all settings are default and even when I uncomment "IdleAction=ignore' it would still do the same.

As soon as Plasma 5 is running (and with it PowerDevil) the Problem is gone.


Any pointers what I could look for?
_________________
The package said Windows 95 or better - so I've installed Linux
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 950
Location: Montréal

PostPosted: Wed Sep 23, 2015 1:16 am    Post subject: Reply with quote

Hi,

I only allow the Acpi poweroff when I press the Power button. All the rest in power management is disable in /etc/systemd/logind.conf.
Code:
[Login]
#NAutoVTs=6
#ReserveVT=6
KillUserProcesses=yes
#KillOnlyUsers=
KillExcludeUsers=root
InhibitDelayMaxSec=5
HandlePowerKey=poweroff
HandleSuspendKey=ignore
HandleHibernateKey=ignore
HandleLidSwitch=ignore
HandleLidSwitchDocked=ignore
PowerKeyIgnoreInhibited=yes
SuspendKeyIgnoreInhibited=yes
HibernateKeyIgnoreInhibited=yes
LidSwitchIgnoreInhibited=yes
#HoldoffTimeoutSec=30s
IdleAction=ignore
#IdleActionSec=
#RuntimeDirectorySize=10%
#RemoveIPC=yes

_________________
Paul
Back to top
View user's profile Send private message
A08
n00b
n00b


Joined: 26 Oct 2003
Posts: 7
Location: Earth, Europe, Germany, Schöneiche

PostPosted: Wed Jan 13, 2016 10:34 pm    Post subject: Reply with quote

But I am not pushing any buttons and it still goes to sleep after 30 seconds...
...shouldn't "IdleAction=ignore" prevent this from happening?
_________________
The package said Windows 95 or better - so I've installed Linux
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum