Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Why is media-video/libav-10_beta1 blocking VLC?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Vorlon
Apprentice
Apprentice


Joined: 16 May 2003
Posts: 210
Location: West Grove, PA

PostPosted: Sun Feb 08, 2015 4:44 pm    Post subject: Why is media-video/libav-10_beta1 blocking VLC? Reply with quote

Why is media-video/libav-10_beta1 blocking upgrading VLC? I don't have the beta version installed, and it's not on the install list.


I'm doing a general update, which is trying to upgrade to vlc-2.1.5-r1. However, I'm getting the dreaded "block" error. The weird part is that I don't have the offending blocking program installed, and it's not even listed as being one of the packages that will be upgraded.

I've got libav-9.17 installed, and there is nothing that lists it as being upgraded by this general upgrade


Can somebody point me to a solution? This one has me stumped (like that's never happened before! <grin>)


TIA!
_________________
Casey Bralla
Chief Nerd in Residence
The NerdWorld Organisation
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2954
Location: UK

PostPosted: Sun Feb 08, 2015 6:18 pm    Post subject: Reply with quote

Maybe the error message tells you exactly how to fix it?
_________________
runit-init howto | Overlay - gtk2 stuff
Back to top
View user's profile Send private message
Vorlon
Apprentice
Apprentice


Joined: 16 May 2003
Posts: 210
Location: West Grove, PA

PostPosted: Sun Feb 08, 2015 7:57 pm    Post subject: Reply with quote

Well, it wouldn't be the first time that I missed the obvious solution, but I'm still confused where the heck the "beta" version was pulled in.

The instructions tell me to RTFM, which is naturally what I'm trying to avoid doing! <grin>


The system is trying to pull in 2 different versions of vlc (2.0.1 & 2.1.5), but I don't see anything which is calling for libav-10_beta1


So I'm mucking around trying to remove some of the offending multimedia applications, but I was hoping to have someone explain the underlying causes.



BTW, hHere's the whole update sequence:


emerge --deep --newuse --update --with-bdeps=y --keep-going world -v

* IMPORTANT: 12 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] dev-qt/qtchooser-0_p20150102 [0_p20140613] USE="-qt5 {-test}" 31 KiB
[ebuild U ] sys-devel/patch-2.7.4 [2.7.1-r3] USE="-static {-test} -xattr" 698 KiB
[ebuild U ] sys-devel/automake-wrapper-10 [9] 0 KiB
[ebuild U ] media-libs/libdvdcss-1.3.99:1.2 [1.3.0:1.2] USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 369 KiB
[ebuild U ] www-plugins/chrome-binary-plugins-41.0.2272.43_beta1:beta [40.0.2214.45_beta1:beta] USE="flash" 46,491 KiB
[ebuild U ] dev-libs/libltdl-2.4.5 [2.4.4] USE="-static-libs" ABI_X86="(64) -32 (-x32)" 949 KiB
[ebuild U ] dev-libs/vala-common-0.26.2 [0.26.1] 2,620 KiB
[ebuild U ] sys-apps/file-5.22 [5.21] USE="zlib -python -static-libs" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 716 KiB
[ebuild R ] dev-libs/xapian-1.2.19 USE="brass chert inmemory -doc -static-libs (-sse%*) (-sse2%*)" CPU_FLAGS_X86="sse%* sse2%*" 0 KiB
[ebuild U ] app-arch/zip-3.0-r3 [3.0-r2] USE="bzip2 crypt unicode -natspec" 0 KiB
[ebuild U ] media-libs/glm-0.9.6.1 [0.9.5.1] 4,133 KiB
[ebuild R ] media-libs/x264-0.0.20140308:0/142 USE="interlaced threads -10bit -opencl -pic -static-libs (-sse%*)" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse%*" 0 KiB
[ebuild U ] dev-libs/openssl-1.0.2-r1 [1.0.1j] USE="tls-heartbeat zlib -bindist -gmp -kerberos -rfc3779 -sctp% -static-libs {-test} -vanilla (-sse2%*)" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(sse2%*)" 5,143 KiB
[ebuild U ] dev-libs/libevent-2.1.5 [2.0.21-r2] USE="ssl threads -debug -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 950 KiB
[ebuild U ] sys-apps/busybox-1.23.1-r1 [1.23.0] USE="pam static -debug -ipv6 -livecd -make-symlinks -math -mdev -savedconfig (-selinux) -sep-usr -syslog -systemd" 2,200 KiB
[ebuild U ] app-admin/eselect-1.4.4 [1.4.3] USE="-doc -emacs -vim-syntax" 174 KiB
[ebuild U ] app-admin/eselect-opengl-1.3.1-r2 [1.3.1] 0 KiB
[ebuild U ] media-libs/freetype-2.5.5:2 [2.5.4-r1:2] USE="X adobe-cff bzip2 png -auto-hinter -bindist -debug -doc -fontforge -harfbuzz -infinality -static-libs -utils" ABI_X86="(64) -32 (-x32)" 1,675 KiB
[ebuild U ] sys-libs/readline-6.3_p8-r2 [6.3_p8-r1] USE="-static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild U ] net-misc/netifrc-0.3.1 [0.2.4] 68 KiB
[ebuild N ] net-firewall/iptables-1.4.21-r1 USE="-ipv6 -netlink -static-libs" 535 KiB
[ebuild U ] sys-apps/less-474 [471] USE="pcre unicode" 309 KiB
[ebuild NS ] sys-kernel/gentoo-sources-3.18.6:3.18.6 [3.16.3:3.16.3, 3.17.1-r1:3.17.1-r1, 3.17.2:3.17.2, 3.17.3:3.17.3, 3.17.4:3.17.4, 3.18.1:3.18.1] USE="symlink -build -deblob -experimental" 209 KiB
[ebuild U ] dev-libs/libgpg-error-1.18 [1.17] USE="nls -common-lisp -static-libs" ABI_X86="(64) -32 (-x32)" 702 KiB
[ebuild U ] sys-apps/grep-2.21-r1 [2.21] USE="nls pcre -static" 4 KiB
[ebuild U ] media-gfx/exiv2-0.24-r1:0/13 [0.24:0/13] USE="nls xmp zlib -contrib -doc -examples -static-libs" ABI_X86="(64) -32 (-x32)" LINGUAS="-de -es -fi -fr -pl -ru -sk" 0 KiB
[ebuild U ] sys-devel/bison-3.0.4 [3.0.2] USE="nls -static" 1,928 KiB
[ebuild U ] app-cdr/cdrtools-3.01_alpha27 [3.01_alpha25] USE="acl filecaps nls unicode" 2,031 KiB
[ebuild NS ] sys-devel/gcc-4.9.2:4.9 [4.7.3-r1:4.7, 4.8.4:4.8] USE="cxx fortran (multilib) nls nptl openmp sanitize (-altivec) -awt -doc (-fixed-point) -gcj -go -graphite (-hardened) (-libssp) (-multislot) -nopie -nossp -objc -objc++ -objc-gc -regression-test -vanilla" 87,866 KiB
[ebuild N ] sys-apps/iproute2-3.18.0 USE="berkdb iptables -atm -ipv6 -minimal (-selinux)" 438 KiB
[ebuild U ] sys-apps/help2man-1.46.5 [1.46.4] USE="nls" 165 KiB
[ebuild NS ] sys-devel/automake-1.15:1.15 [1.13.4:1.13, 1.14.1:1.14] 1,462 KiB
[ebuild U ] app-shells/bash-4.3_p33-r1 [4.3_p33] USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins -vanilla" 0 KiB
[ebuild U ] sys-devel/libtool-2.4.5:2 [2.4.4:2] USE="-vanilla" 0 KiB
[ebuild U ] x11-proto/xproto-7.0.27 [7.0.26] USE="-doc" ABI_X86="(64) -32 (-x32)" 299 KiB
[ebuild U ] dev-libs/icu-54.1-r1:0/54a [53.1:0/53] USE="-debug -doc -examples -static-libs" ABI_X86="(64) -32 (-x32)" 24,889 KiB
[ebuild U ] x11-libs/libdrm-2.4.59 [2.4.58] USE="-libkms -static-libs" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="radeon (-exynos) (-freedreno) -intel -nouveau (-omap) (-tegra) -vmware" 579 KiB
[ebuild U ] dev-libs/nspr-4.10.8 [4.10.7-r1] USE="-debug" ABI_X86="(64) -32 (-x32)" 1,105 KiB
[ebuild R ] media-libs/flac-1.3.1-r1 USE="cxx ogg (-altivec) -debug -static-libs (-sse%*)" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse%*" 0 KiB
[ebuild R ] x11-libs/pixman-0.32.6 USE="(-altivec) (-iwmmxt) (-loongson2f) (-neon) -static-libs (-mmxext%) (-sse2%*) (-ssse3%*)" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse2%* -mmxext% -ssse3%" 0 KiB
[ebuild U ] media-libs/libdvdread-5.0.2 [5.0.0-r2] USE="css" ABI_X86="(64) -32 (-x32)" 385 KiB
[ebuild R ] media-libs/speex-1.2_rc1-r2 USE="ogg -static-libs (-sse%*)" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse%*" 0 KiB
[ebuild U ] sys-process/psmisc-22.21-r2 [22.21] USE="X nls -ipv6 (-selinux)" 6 KiB
[ebuild U ] app-arch/cpio-2.11-r3 [2.11-r1] USE="nls" 0 KiB
[ebuild U ] dev-db/sqlite-3.8.8.1:3 [3.8.7.4:3] USE="icu readline -debug -doc -secure-delete -static-libs -tcl {-test}" ABI_X86="(64) -32 (-x32)" 1,974 KiB
[ebuild U ] x11-libs/libxshmfence-1.2 [1.1] USE="-static-libs" ABI_X86="(64) -32 (-x32)" 261 KiB
[ebuild U ] media-libs/libdvdnav-5.0.3 [5.0.1] ABI_X86="(64) -32 (-x32)" 364 KiB
[ebuild rR ] dev-libs/boost-1.56.0-r1:0/1.56.0 USE="icu nls threads -context -debug -doc -mpi -python -static-libs -tools" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 0 KiB
[ebuild U ] x11-misc/xkeyboard-config-2.14 [2.13] 932 KiB
[ebuild U ] x11-apps/sessreg-1.1.0 [1.0.8] 132 KiB
[ebuild U ] x11-apps/iceauth-1.0.7 [1.0.6] 133 KiB
[ebuild U ] x11-apps/mkfontscale-1.1.2 [1.1.1] 139 KiB
[ebuild U ] dev-libs/nss-3.17.4 [3.17.3] USE="cacert nss-pem -utils" ABI_X86="(64) -32 (-x32)" 6,763 KiB
[ebuild U ] dev-util/mdds-0.11.2-r1:0/0.11.2 [0.11.2:0/0.11.2] 0 KiB
[ebuild rR ] media-libs/libcdr-0.1.1 USE="-doc -static-libs" 0 KiB
[ebuild U ] app-text/libmspub-0.1.2 [0.1.1] USE="-doc -static-libs" 338 KiB
[ebuild U ] app-text/libodfgen-0.1.3 [0.1.2] USE="-doc" 327 KiB
[ebuild U ] x11-apps/bdftopcf-1.0.5 [1.0.4] 121 KiB
[ebuild U ] media-fonts/font-alias-1.0.3-r1 [1.0.3] 0 KiB
[ebuild U ] dev-lang/python-2.7.9-r2:2.7 [2.7.9-r1:2.7] USE="gdbm ncurses readline sqlite ssl threads (wide-unicode) xml -berkdb -build -doc -examples -hardened -ipv6 -tk -wininst" 13 KiB
[ebuild U ] sys-devel/llvm-3.5.1:0/3.5 [3.5.0:0/3.5] USE="libffi ncurses static-analyzer xml -clang -debug -doc -gold -libedit -multitarget -ocaml -python {-test}" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 -pypy" VIDEO_CARDS="radeon" 11,592 KiB
[ebuild rR ] dev-libs/libxml2-2.9.2:2 USE="icu python readline -debug -examples -ipv6 -lzma -static-libs {-test}" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 0 KiB
[ebuild U ] dev-python/setuptools-12.0.5 [9.1] USE="{-test}" PYTHON_TARGETS="python2_7 python3_3 -pypy -pypy3 -python3_4" 613 KiB
[ebuild U ] media-libs/libvisio-0.1.1 [0.1.0] USE="-doc -static-libs {-test%}" 404 KiB
[ebuild U ] app-text/libmwaw-0.3.4 [0.3.1] USE="-doc -static-libs" 954 KiB
[ebuild U ] app-text/libebook-0.1.2 [0.1.1] USE="-doc {-test}" 456 KiB
[ebuild U ] net-libs/gnutls-3.3.12 [3.3.11] USE="crywrap cxx nls zlib -dane -doc -examples -guile -pkcs11 -static-libs {-test}" ABI_X86="(64) -32 (-x32)" LINGUAS="-cs -de -en -fi -fr -it -ms -nl -pl -sv -uk -vi -zh_CN" 6,041 KiB
[ebuild U ] sys-boot/grub-2.02_beta2-r7:2 [2.02_beta2-r6:2] USE="fonts%* multislot nls sdl themes%* truetype -debug -device-mapper -doc -efiemu -libzfs -mount -static {-test}" GRUB_PLATFORMS="-coreboot -efi-32 -efi-64 -emu -ieee1275 -loongson -multiboot -pc -qemu -qemu-mips -xen" 1,342 KiB
[ebuild U ] sys-apps/util-linux-2.25.2-r2 [2.25.2-r1] USE="cramfs ncurses nls pam suid udev unicode -caps -fdformat -python (-selinux) -slang -static-libs -systemd {-test} -tty-helpers" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 0 KiB
[ebuild U ] sys-apps/hwids-20150129 [20141214] USE="net pci udev usb" 1,668 KiB
[ebuild U ] x11-libs/libpciaccess-0.13.3 [0.13.2] USE="zlib -minimal -static-libs" ABI_X86="(64) -32 (-x32)" 361 KiB
[ebuild U ] x11-apps/bitmap-1.0.8 [1.0.7] 174 KiB
[ebuild rR ] net-nds/openldap-2.4.40-r3 USE="berkdb crypt icu minimal ssl syslog tcpd -cxx -debug -experimental -gnutls -iodbc -ipv6 -kerberos -odbc -overlays -perl -samba -sasl (-selinux) -slp -smbkrb5passwd -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild U ] net-misc/curl-7.40.0 [7.39.0] USE="ldap ssl -adns -idn -ipv6 -kerberos -metalink -rtmp -samba% -ssh -static-libs {-test} -threads" ABI_X86="(64) -32 (-x32)" CURL_SSL="openssl -axtls -gnutls -nss -polarssl (-winssl)" 3,191 KiB
[ebuild rR ] media-libs/raptor-2.0.14:2 USE="curl unicode -debug -json -static-libs" 0 KiB
[ebuild U ] sys-apps/man-pages-3.79 [3.76] USE="nls" LINGUAS="-da -de -fr -it -ja -nl -pl -ro -ru -zh_CN" 1,290 KiB
[ebuild R ] dev-libs/glib-2.42.1:2 USE="dbus%* (mime) -debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild N ] gnome-base/dconf-0.22.0 USE="X {-test}" 385 KiB
[ebuild U ] dev-perl/File-MimeInfo-0.260.0 [0.210.0] USE="{-test}" 32 KiB
[ebuild U ] media-libs/gst-plugins-base-0.10.36-r2:0.10 [0.10.36-r1:0.10] USE="introspection nls orc" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild U ] media-libs/libgphoto2-2.5.7:0/6 [2.5.5.1-r1:0/6] USE="exif jpeg nls -doc -examples -gd -serial -zeroconf" ABI_X86="(64) -32 (-x32)" CAMERAS="ptp2 -adc65 -agfa_cl20 -aox -ax203 -barbie -canon -casio_qv -clicksmart310 -digigr8 -digita -dimagev -dimera3500 -directory -enigma13 -fuji -gsmart300 -hp215 -iclick -jamcam -jd11 -jl2005a -jl2005c -kodak_dc120 -kodak_dc210 -kodak_dc240 -kodak_dc3200 -kodak_ez200 -konica -konica_qm150 -largan -lg_gsm -mars -mustek -panasonic_coolshot -panasonic_dc1000 -panasonic_dc1580 -panasonic_l859 -pccam300 -pccam600 -pentax -polaroid_pdc320 -polaroid_pdc640 -polaroid_pdc700 -ricoh -ricoh_g3 -samsung -sierra -sipix_blink2 -sipix_web2 -smal -sonix -sony_dscf1 -sony_dscf55 -soundvision -spca50x -sq905 -st2205 -stv0674 -stv0680 -sx330z -topfield -toshiba_pdrm11 -tp6801" 6,569 KiB
[ebuild rR ] dev-qt/qtcore-4.8.6-r1:4 USE="exceptions glib iconv icu qt3support ssl (-aqua) -debug -pch" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild U ] dev-util/cmake-3.1.0 [3.0.2] USE="ncurses qt4 -doc -emacs -qt5 {-test}" 5,817 KiB
[ebuild rR ] dev-qt/qtwebkit-4.8.6-r1:4 USE="exceptions gstreamer icu jit (-aqua) -debug -pch" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild R ] media-libs/qimageblitz-0.0.6-r1 USE="(-altivec) -debug (-3dnow%*) (-mmx%*) (-sse%*) (-sse2%*)" CPU_FLAGS_X86="mmx%* sse%* sse2%* -3dnow%" 0 KiB
[ebuild U ] dev-cpp/eigen-3.2.4:3 [3.1.3:3] USE="-debug -doc" 1,122 KiB
[ebuild U ] dev-db/mariadb-10.0.16 [10.0.15-r1] USE="community extraengine pam perl ssl xml -bindist% -cluster -debug -embedded -jemalloc -latin1 -minimal -odbc -oqgraph -profiling (-selinux) -sphinx -static -static-libs -systemtap -tcmalloc {-test} -tokudb (-max-idx-128%)" ABI_X86="(64) -32 (-x32)" 54,353 KiB
[ebuild U ] sys-apps/openrc-0.13.9 [0.13.6] USE="ncurses netifrc pam unicode -debug -newnet (-prefix) (-selinux) -static-libs -tools" 148 KiB
[ebuild U ] sys-apps/accountsservice-0.6.40 [0.6.39] USE="introspection -doc (-selinux) -systemd" 360 KiB
[ebuild U ] net-fs/nfs-utils-1.3.2-r6 [1.3.1-r1] USE="libmount nfsidmap nfsv4 tcpd uuid -caps -ipv6 -kerberos -nfsdcld -nfsv41 (-selinux)" 772 KiB
[ebuild U ] app-crypt/qca-2.1.0.3:2 [2.0.3:2] USE="openssl%* qt4%* -botan% -debug -doc -examples -gcrypt% -gpg% -logger% -nss% -pkcs11% -qt5% -sasl% -softstore% {-test%} (-aqua%)" 670 KiB
[uninstall ] app-crypt/qca-ossl-2.0.0_beta3-r2:2 USE="-debug"
[blocks b ] app-crypt/qca-ossl ("app-crypt/qca-ossl" is blocking app-crypt/qca-2.1.0.3)
[ebuild r U ] app-text/poppler-0.30.0:0/49 [0.29.0:0/48] USE="cairo cxx introspection jpeg jpeg2k lcms png qt4 tiff utils -cjk -curl -debug -doc -qt5" 1,568 KiB
[ebuild rR ] media-libs/harfbuzz-0.9.37:0/0.9.18 USE="cairo glib graphite icu introspection truetype -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild U ] media-libs/glew-1.12.0:0/1.12 [1.11.0:0/1.11] USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 597 KiB
[ebuild U ] media-libs/jasper-1.900.1-r9 [1.900.1-r7] USE="jpeg opengl -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild R ] media-libs/netpbm-10.66.00 USE="X jpeg jpeg2k png tiff xml zlib -doc -jbig -rle -static-libs (-svga) (-sse2%*)" CPU_FLAGS_X86="sse2%*" 0 KiB
[ebuild U ] media-gfx/imagemagick-6.9.0.3:0/6.9.0.3 [6.9.0.0:0/6.9.0.0] USE="X bzip2 cxx jpeg jpeg2k lcms openmp pango png svg tiff truetype xml zlib -autotrace -corefonts -djvu -fftw -fontconfig -fpx -graphviz -hdri -jbig -lqr -lzma -opencl -openexr -perl -postscript -q32 -q64 -q8 -raw -static-libs {-test} -webp -wmf" 7,714 KiB
[ebuild U ] x11-libs/gtk+-3.14.8:3 [3.14.6:3] USE="X cups introspection xinerama (-aqua) -cloudprint -colord -debug -examples {-test} -vim-syntax -wayland" ABI_X86="(64) -32 (-x32)" 15,322 KiB
[ebuild rR ] net-print/cups-filters-1.0.61 USE="dbus foomatic jpeg png tiff -perl -static-libs -zeroconf" 0 KiB
[ebuild rR ] dev-lang/R-3.1.2 USE="X cairo icu jpeg nls openmp png readline tiff -doc -java -lapack -minimal -perl (-prefix) -profile -static-libs -tk" 0 KiB
[ebuild U ] media-sound/pulseaudio-5.0-r7 [5.0-r6] USE="X alsa alsa-plugin asyncns caps dbus gdbm glib gtk orc qt4 ssl tcpd udev webrtc-aec -bluetooth -doc -equalizer -gnome -ipv6 -jack -libsamplerate -lirc (-neon) (-oss) -realtime (-system-wide) -systemd {-test} -xen -zeroconf" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild R ] media-libs/openal-1.15.1-r2 USE="alsa pulseaudio (-coreaudio) -debug (-neon) -oss -portaudio (-sse%*)" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse%*" 0 KiB
[ebuild U ] x11-libs/libva-1.5.0 [1.4.1] USE="X drm opengl vdpau -egl -wayland" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="-dummy -fglrx -intel -nvidia" 757 KiB
[ebuild U ] media-libs/mesa-10.4.3 [10.3.5-r1] USE="classic dri3 egl gallium gbm llvm nptl udev vaapi%* vdpau xvmc -bindist -debug -gles1 -gles2 -opencl -openmax -osmesa -pax_kernel -pic -r600-llvm-compiler (-selinux) -wayland -xa (-openvg%)" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="radeon (-freedreno) -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -r600 -radeonsi -vmware" 7,329 KiB
[ebuild U ] virtual/ffmpeg-9-r2 [9-r1] USE="X encode jpeg2k libav%* mp3 sdl theora truetype vaapi vdpau x264 -gsm -opus -speex -threads" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild R ] dev-libs/DirectFB-1.7.6 USE="X alsa dynload gif jpeg jpeg2k mad mng opengl png sdl svg tiff truetype v4l vdpau vorbis zlib -bmp -cddb -debug -divine -doc -drmkms -egl -fbcon -fusiondale -fusionsound -gles2 -gstreamer -imlib2 -input_hub -mpeg2 -mpeg3 -multicore -oss -pnm -sawman -static-libs (-swfdec) -timidity -tremor -webp -xine (-mmx%*) (-sse%*)" CPU_FLAGS_X86="mmx%* sse%*" INPUT_DEVICES="evdev keyboard mouse -dynapro -elo2300 -joystick -lirc -mutouch -tslib" VIDEO_CARDS="radeon -intel -mach64 -mga -neomagic (-nsc) -nvidia -r128 -s3 -sis -tdfx -via -vmware" 0 KiB
[ebuild N ] media-libs/libpostproc-10.20140517-r1 USE="(-altivec) -pic -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx -3dnow -mmxext" 65 KiB
[ebuild U ] x11-base/xorg-server-1.16.3-r1:0/1.16.1 [1.16.2.901-r1:0/1.16.1] USE="glamor nptl suid udev xorg -dmx -doc -ipv6 -kdrive -minimal (-selinux) -static-libs -systemd -tslib -unwind -wayland -xnest -xvfb" 5,671 KiB
[ebuild R ] kde-base/kdelibs-4.14.3-r1:4/4.14 USE="acl alsa bzip2 crypt fam handbook jpeg2k nls opengl (policykit) spell ssl udev udisks upower (-altivec) (-aqua) -debug -doc -kerberos -lzma -nepomuk -openexr {-test} -zeroconf (-3dnow%*) (-mmx%*) (-sse%*) (-sse2%*)" CPU_FLAGS_X86="mmx%* sse%* sse2%* -3dnow%" 0 KiB
[ebuild N ] media-video/vlc-2.1.5-r1:0/5-7 USE="X a52 alsa avcodec avformat cdda dbus directfb dts dvbpsi dvd encode ffmpeg flac gcrypt kde libav libnotify mp3 mpeg musepack ncurses ogg opengl png postproc pulseaudio qt4 sdl svg swscale theora truetype udev v4l vaapi vdpau vnc vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -avahi -bidi -bluray -cddb -chromaprint -dc1394 -debug -dirac (-directx) -dvb (-dxva2) -egl -faad -fdk -fluidsynth -fontconfig -gme -gnome -gnutls -growl -httpd -ieee1394 (-ios-vout) -jack -kate -libass -libcaca -libsamplerate -libtar -libtiger -linsys -lirc -live -lua (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) -matroska (-media-library) -modplug -mtp (-neon) -omxil -opencv -optimisememory -opus -projectm -rdp -rtsp -run-as-root -samba -schroedinger -sdl-image -sftp -shout -sid -skins -speex -taglib {-test} -tremor -twolame -upnp -vcdx -vlm -wma-fixed -zvbi" CPU_FLAGS_X86="mmx sse" 0 KiB
[ebuild N ] media-libs/phonon-vlc-0.8.2 USE="qt4 -debug -qt5" 0 KiB
[ebuild R ] sys-auth/polkit-kde-agent-0.99.1:4 USE="(-aqua) -debug -minimal%" LINGUAS="-ar -bs -ca -ca@valencia -cs -da -de -el -en_GB -eo -es -et -fi -fr -ga -gl -hr -hu -is -it -ja -kk -km -lt -mai -mr -ms -nb -nds -nl -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -ug -uk -vi -zh_CN -zh_TW" 0 KiB
[ebuild U ] www-client/links-2.9:2 [2.8-r1:2] USE="X bzip2 directfb gpm jpeg ssl tiff unicode zlib -fbcon -ipv6 -livecd -lzma (-suid) (-svga)" 4,028 KiB
[ebuild U ] www-client/chromium-41.0.2272.35 [39.0.2171.42] USE="cups (pic) pulseaudio tcmalloc -bindist -custom-cflags -gnome -gnome-keyring -hidpi% -kerberos (-neon) (-selinux) {-test}" LINGUAS="am ar bg bn ca cs da de el en_GB es es_LA et fa fi fil fr gu he hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt_BR pt_PT ro ru sk sl sr sv sw ta te th tr uk vi zh_CN zh_TW" 232,558 KiB
[ebuild rR ] app-office/libreoffice-4.3.5.2 USE="cups dbus gtk kde opengl (-aqua) -bluetooth -branding -coinmp -collada -debug -eds (-firebird) -gltf -gnome -gstreamer -gtk3 -java -jemalloc -mysql -odk -postgres -telepathy {-test} -vlc" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 0 KiB
[ebuild U ] www-plugins/adobe-flash-11.2.202.442 [11.2.202.425] USE="kde (-debug) (-selinux) (-sse2%*)" ABI_X86="64 -32 (-x32)" CPU_FLAGS_X86="sse2%*" 7,073 KiB
[ebuild R ] kde-base/ksplash-4.11.14:4/4.11 USE="xinerama (-altivec) (-aqua) -debug (-3dnow%*) (-mmx%*) (-sse%*) (-sse2%*)" CPU_FLAGS_X86="mmx%* sse%* sse2%* -3dnow%" 0 KiB
[ebuild U ] kde-base/kwalletd-4.14.3-r1:4/4.14 [4.14.3:4/4.14] USE="(-aqua) -debug -gpg" 0 KiB
[ebuild U ] kde-base/kopete-4.14.3-r1:4/4.14 [4.14.3:4/4.14] USE="addbookmarks autoreplace contactnotes handbook highlight history nowlistening pipes privacy ssl statistics texteffect translator urlpicpreview v4l xmpp (-aqua) -debug -gadu -groupwise -jingle -latex -meanwhile -oscar -otr -skype -sms -testbed -webpresence -winpopup -yahoo -zeroconf" 0 KiB
[ebuild U ] kde-base/kdebase-data-4.14.3-r1:4/4.14 [4.14.3:4/4.14] USE="wallpapers (-aqua)" 0 KiB
[blocks B ] <media-video/libav-10_beta1 ("<media-video/libav-10_beta1" is blocking media-video/vlc-2.1.5-r1)

Total: 120 packages (87 upgrades, 6 new, 3 in new slots, 24 reinstalls, 1 uninstall), Size of downloads: 581,583 KiB
Conflict: 2 blocks (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(media-video/vlc-2.1.5-r1:0/5-7::gentoo, ebuild scheduled for merge) pulled in by
>=media-video/vlc-2.0.1:=[dbus,ogg,vorbis] required by (media-libs/phonon-vlc-0.8.2:0/0::gentoo, ebuild scheduled for merge)

(media-video/libav-9.17:0/9::gentoo, installed) pulled in by
>=media-video/libav-9.12[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?] (>=media-video/libav-9.12[abi_x86_64(-),X,encode,jpeg2k,mp3,sdl,theora,truetype,vaapi,vdpau,x264]) required by (virtual/ffmpeg-9-r2:0/0::gentoo, ebuild scheduled for merge)
media-video/libav:0= required by (media-video/vlc-2.1.5-r1:0/5-7::gentoo, ebuild scheduled for merge)
media-video/libav:0=[vaapi] required by (media-video/vlc-2.1.5-r1:0/5-7::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following packages are causing rebuilds:

(app-text/poppler-0.30.0:0/49::gentoo, ebuild scheduled for merge) causes rebuilds for:
(app-office/libreoffice-4.3.5.2:0/0::gentoo, ebuild scheduled for merge)
(net-print/cups-filters-1.0.61:0/0::gentoo, ebuild scheduled for merge)
(dev-libs/icu-54.1-r1:0/54a::gentoo, ebuild scheduled for merge) causes rebuilds for:
(dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
(media-libs/raptor-2.0.14:2/2::gentoo, ebuild scheduled for merge)
(dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge)
(app-office/libreoffice-4.3.5.2:0/0::gentoo, ebuild scheduled for merge)
(dev-libs/libxml2-2.9.2:2/2::gentoo, ebuild scheduled for merge)
(dev-lang/R-3.1.2:0/0::gentoo, ebuild scheduled for merge)
(media-libs/libcdr-0.1.1:0/0::gentoo, ebuild scheduled for merge)
(net-nds/openldap-2.4.40-r3:0/0::gentoo, ebuild scheduled for merge)
(media-libs/harfbuzz-0.9.37:0/0.9.18::gentoo, ebuild scheduled for merge)
(dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
_________________
Casey Bralla
Chief Nerd in Residence
The NerdWorld Organisation
Back to top
View user's profile Send private message
EmaRsk
Tux's lil' helper
Tux's lil' helper


Joined: 07 Sep 2004
Posts: 101
Location: Italy

PostPosted: Sun Feb 08, 2015 9:35 pm    Post subject: Reply with quote

It seems it's not "media-video/libav-10_beta1" that is blocking, but "<media-video/libav-10_beta1"; that is, any version lower than that.
Back to top
View user's profile Send private message
Vorlon
Apprentice
Apprentice


Joined: 16 May 2003
Posts: 210
Location: West Grove, PA

PostPosted: Sun Feb 08, 2015 9:43 pm    Post subject: Reply with quote

Ahhh.. I still have the problem, but at least now I understand the message.

Thank you EmaRsk!
_________________
Casey Bralla
Chief Nerd in Residence
The NerdWorld Organisation
Back to top
View user's profile Send private message
woodelf
n00b
n00b


Joined: 09 Feb 2015
Posts: 0

PostPosted: Mon Feb 09, 2015 2:17 am    Post subject: Reply with quote

Same issue here when I set USE=libav in make.conf, which causes a lot of mess.

Finally, I have to globally set "USE=ffmpeg -libav" to avoid such conflict.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum