Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No GTK UI in Audacious > 3.2.2-r1 [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
OrangeGreen
n00b
n00b


Joined: 11 Nov 2007
Posts: 3

PostPosted: Mon Jan 21, 2013 1:05 pm    Post subject: No GTK UI in Audacious > 3.2.2-r1 [SOLVED] Reply with quote

I've upgraded to latest version (3.3.3) of Audacious and while able to compile audacious and audacious-plugins with no trouble, executing the application doesn't show the GTK UI:

It seems since 3.2.3 gtk and gtk3 use flags are dropped.

Has anyone seen this?

I think this might have something with my GTK+ libs installed as GTK UI didn't show when compiling 3.2.2-r1 with +gtk -gtk3

I have multiple versions of GTK+ among them is 3.4.4 also seems that audacious is linked to the correct lib:
ldd `which audacious`| grep gtk
libgtk-3.so.0 => /usr/lib64/libgtk-3.so.0 (0x00007fbade16d000)

Code:

 $ grep -i interface audac_debug
dbus.c:96 [audacious_rc_init]: Registering remote D-Bus interfaces.
plugin-init.c:102 [start_single]: Starting selected interface plugin GTK Interface.
interface.c:243 [iface_plugin_set_current]: Loading GTK Interface.
interface.c:250 [iface_plugin_set_current]: Loading visualizers.
interface.c:253 [iface_plugin_set_current]: Loading plugin widgets.
plugin-init.c:199 [stop_plugins]: Shutting down GTK Interface.
interface.c:229 [iface_plugin_set_current]: Unloading plugin widgets.
interface.c:232 [iface_plugin_set_current]: Unloading visualizers.
interface.c:235 [iface_plugin_set_current]: Unloading GTK Interface.
dbus.c:96 [audacious_rc_init]: Registering remote D-Bus interfaces.
plugin-init.c:94 [start_single]: Starting selected interface plugin GTK Interface.
interface.c:241 [iface_plugin_set_current]: Loading GTK Interface.
interface.c:248 [iface_plugin_set_current]: Loading visualizers.
interface.c:251 [iface_plugin_set_current]: Loading plugin widgets.
plugin-init.c:194 [stop_plugins]: Shutting down GTK Interface.
interface.c:227 [iface_plugin_set_current]: Unloading plugin widgets.
interface.c:230 [iface_plugin_set_current]: Unloading visualizers.
interface.c:233 [iface_plugin_set_current]: Unloading GTK Interface.



Full verbose output of audacious -V:
http://pastebin.com/NPy7Gv0V

emerge --info:
http://pastebin.com/sCtWCTqX

eix -I audacious
Code:

[I] media-plugins/audacious-plugins
     Available versions:  2.4.4-r1 2.5.4 3.1 (~)3.1.1 3.2.2-r1 (~)3.2.3 (~)3.2.4 (~)3.3 (~)3.3.2 (~)3.3.3 {aac adplug alsa aqua bs2b cdda cue ffmpeg flac fluidsynth gnome +gtk gtk3 ipv6 jack lame libnotify libsamplerate lirc midi mms mp3 mtp nls oss pulseaudio scrobbler sdl sid sndfile sse2 vorbis wavpack}
     Installed versions:  3.3.3(02:54:35 PM 01/21/2013)(aac alsa bs2b ffmpeg flac libnotify mms mp3 nls vorbis wavpack -adplug -cdda -cue -fluidsynth -gnome -ipv6 -jack -lame -libsamplerate -lirc -midi -pulseaudio -scrobbler -sdl -sid -sndfile)
     Homepage:            http://audacious-media-player.org/
     Description:         Audacious Player - Your music, your way, no exceptions

[I] media-sound/audacious
Available versions: 2.4.4 2.5.4 3.1 (~)3.1.1 3.2.2-r1 (~)3.2.3 (~)3.2.4 (~)3.3 (~)3.3.2 (~)3.3.2[1] (~)3.3.3 {altivec chardet +gtk gtk3 nls session sse2}
Installed versions: 3.3.3(02:52:40 PM 01/21/2013)(nls -chardet)
Homepage: http://audacious-media-player.org/
Description: Audacious Player - Your music, your way, no exceptions
[1] "sabayon" /var/lib/layman/sabayon
[/code]


Last edited by OrangeGreen on Thu Jan 24, 2013 12:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5767

PostPosted: Mon Jan 21, 2013 3:32 pm    Post subject: Reply with quote

Perhaps it's starting minimized to the tray ?
As for the flags, 3.3 dropped gtk2 support.
Back to top
View user's profile Send private message
OrangeGreen
n00b
n00b


Joined: 11 Nov 2007
Posts: 3

PostPosted: Thu Jan 24, 2013 12:51 pm    Post subject: Reply with quote

Thanks for the hint. I deleted ~/config/audacious so it might have been the tray icon or any other plugin I enabled.
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1268

PostPosted: Fri Feb 06, 2015 9:41 pm    Post subject: Reply with quote

I just ran into this annoying problem too, no icons in
after emerging audacious-3.4.1.ebuild

Turns out the gtk and gtk3 use flags are missing or gone
so even though I set
Code:
media-sound/audacious gtk gtk3
in package.use

There is nothing in ebuild that I can see:
Code:
IUSE="chardet nls"

RDEPEND=">=dev-libs/dbus-glib-0.60
        >=dev-libs/glib-2.28
        dev-libs/libxml2
        >=x11-libs/cairo-1.2.6
        >=x11-libs/pango-1.8.0
        x11-libs/gtk+:3"


Thus
Code:
emerge -av x11-themes/gnome-icon-theme
is not a dependency of audacious or x11-libs/gtk+

Probably a bug
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5767

PostPosted: Sat Feb 07, 2015 2:58 pm    Post subject: Reply with quote

audacious has become a f**ing mess in the meanwhile, due to many reasons, not limited to upstream getting pissed at gtk+ upstream (which will result in 3.6 going back to gtk2 as the main gtk+ gui).

While gtk+ upstream has worked hard for that result, it's still quite a bother.
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2928
Location: UK

PostPosted: Sat Feb 07, 2015 6:57 pm    Post subject: Reply with quote

VoidMage wrote:
audacious has become a f**ing mess in the meanwhile, due to many reasons, not limited to upstream getting pissed at gtk+ upstream (which will result in 3.6 going back to gtk2 as the main gtk+ gui).

While gtk+ upstream has worked hard for that result, it's still quite a bother.

Really? Sweet, I can finally reinstall audacious without having the gnome herd dictate unwanted deps to me.
_________________
runit-init howto | Overlay - gtk2 stuff
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5767

PostPosted: Sun Feb 08, 2015 2:42 pm    Post subject: Reply with quote

Ant P. wrote:
VoidMage wrote:
audacious has become a f**ing mess in the meanwhile, due to many reasons, not limited to upstream getting pissed at gtk+ upstream (which will result in 3.6 going back to gtk2 as the main gtk+ gui).

While gtk+ upstream has worked hard for that result, it's still quite a bother.

Really? Sweet, I can finally reinstall audacious without having the gnome herd dictate unwanted deps to me.


:sigh: :roll: ....really, so not my point.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum