Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
package dev-util/ragel-6.7-r1 fails due to automake
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 01 Aug 2011
Posts: 23

PostPosted: Wed Oct 24, 2012 3:33 pm    Post subject: package dev-util/ragel-6.7-r1 fails due to automake Reply with quote


I have a problem with one dependency - dev-util/ragel-6.7-r1 - which fails due to automake when I do a emerge -aeuD world :

 * Messages for package dev-util/ragel-6.7-r1:

 * Failed Running automake !
 * Include in your bugreport the contents of:
 *   /var/tmp/portage/dev-util/ragel-6.7-r1/temp/automake.out
 * ERROR: dev-util/ragel-6.7-r1 failed (prepare phase):
 *   Failed Running automake !
 * Call stack:
 *, line   85:  Called src_prepare
 *   environment, line 2817:  Called eautoreconf
 *   environment, line  803:  Called eautomake
 *   environment, line  756:  Called autotools_run_tool 'automake' '--add-missing' '--copy' '--foreign'
 *   environment, line  569:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 * If you need support, post the output of `emerge --info '=dev-util/ragel-6.7-r1'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/ragel-6.7-r1'`.
 * The complete build log is located at '/var/tmp/portage/dev-util/ragel-6.7-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/ragel-6.7-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-util/ragel-6.7-r1/work/ragel-6.7'
 * S: '/var/tmp/portage/dev-util/ragel-6.7-r1/work/ragel-6.7'

 * Regenerating GNU info directory index...
 * Processed 89 info files.
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.

The errors is due to automake :

$> cat /var/tmp/portage/dev-util/ragel-6.7-r1/temp/automake.out
***** automake *****
***** PWD: /var/tmp/portage/dev-util/ragel-6.7-r1/work/ragel-6.7
***** automake --add-missing --copy --foreign version mismatch.  This is Automake 1.11.6, but the definition used by this AM_INIT_AUTOMAKE comes from Automake 1.11.1.  You should recreate aclocal.m4 with aclocal and run automake again.

At the hand, I tried to go in directory /var/tmp/portage/dev-util/ragel-6.7-r1/work/ragel-6.7 and I called aclocal, then I emerged only ragel (one of my dependency is using it), and it worked.

How could I patch it or ignore that particular error ?

emerge --info give this :

Portage (default/linux/amd64/10.0/server, gcc-4.5.4, glibc-2.15-r3, 3.4.9-gentoo x86_64)
                        System Settings
System uname: Linux-3.4.9-gentoo-x86_64-Intel-R-_Core-TM-_i3-2120_CPU_@_3.30GHz-with-gentoo-2.1
Timestamp of tree: Wed, 24 Oct 2012 09:45:01 +0000
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.1.4-r3, 3.2.3
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
CFLAGS="-march=core2 -O2 -pipe"
CONFIG_PROTECT="/etc /var/lib/redmine/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /var/lib/redmine/config/locales /var/lib/redmine/config/settings.yml"
CXXFLAGS="-march=core2 -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="acl amd64 bash-completion berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gdm gpm iconv ipv6 mmx modules mudflap multilib ncurses nls nptl openmp pam pcre pppd readline session snmp sse sse2 ssl tcpd truetype unicode vim-syntax xml zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

dev-util/ragel-6.7-r1 was built with the following:
USE="(multilib) vim-syntax"
Back to top
View user's profile Send private message

Joined: 27 Feb 2003
Posts: 31
Location: Downingtown, Pennsylvania - USA

PostPosted: Wed Jan 09, 2013 5:01 am    Post subject: Any ideas? Reply with quote


I'm running into the same issue and don't really know where to go with it. I've read this:

But have not found a solution there. I don't see a whole lot else out there on this issue.

I just upgraded to gcc 4.6.3 and re-merged libtool hoping that would do the trick, but to no avail. Oddly enough, when I go an re-merge ragel on it's own (outside of the `emerge -ave world`) it merges fine, so this seems to only crop up when it's part of a larger rebuild.

--- Edit ---
I tried to merge ragel right after posting, and it failed. Not believing my eyes, I tried it again. This time it merged cleanly. I'm completely baffled as to how an error like this could be transient!
--- Edit ---

Any ideas out there, Gentooers? I'm 100% stumped.

Thank you for your time,

Back to top
View user's profile Send private message

Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Wed Jan 09, 2013 5:27 am    Post subject: Reply with quote

There's a confirmed bug written up on that error:

Although the dependency graph shows sys-devel/automake-1.11.6, it's obviously not working.

Give it a day or two and check back :wink:
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message

Joined: 01 Aug 2011
Posts: 23

PostPosted: Sat Feb 09, 2013 5:38 pm    Post subject: Reply with quote

One day or two, well ... it is more one month or more. :/

Not that I can't wait, but I'm left with no options, except for eventually removing any package depending on ragel.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum