Joined: 19 Jul 2007
|Posted: Thu Jan 10, 2013 11:27 am Post subject: [SOLVED] Problem installing ninja-ide because of python...
|Can someone please help me with this:
localhost ~ # emerge -pv ninja-ide
These are the packages that would be merged, in order:
Calculating dependencies... done!
emerge: there are no ebuilds built with USE flags to satisfy "virtual/python-argparse[python_targets_python2_6?,python_targets_python2_7?,-python_single_target_python2_6(-),-python_single_target_python2_7(-)]".
!!! One of the following packages is required to complete your request:
- virtual/python-argparse-0::gentoo (Missing IUSE: python_targets_python2_7 python_targets_python2_6)
(dependency required by "dev-util/ninja-ide-2.1.1-r2" [ebuild])
(dependency required by "ninja-ide" [argument])
localhost ~ # cat /etc/portage/package.use | grep argp
virtual/python-argparse python_targets_python2_7 python_targets_python2_6
localhost ~ # cat /etc/portage/make.conf
PYTHON_TARGETS="python2_7 python3_2 pypy1_9 jython2_5"
From "emerge --info":
PYTHON_ABIS="2.7 3.2" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2 pypy1_9 jython2_5
ninja-ide was already installed but updating didn't worked. The Python stuff normally worked fine and I only need Python 2.7/3.2. I've tried different USE flags for argparse, ninja-ide and installed Python 2.6 again (which I already have had removed some time ago) but I always get the message above.
Update: Bummer... Portage update solved the problem.... Sorry for the noise!