Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Help! libltdl blocked wants older versions ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
codifies
n00b
n00b


Joined: 29 Oct 2014
Posts: 22

PostPosted: Sat Jan 24, 2015 1:41 pm    Post subject: [solved] Help! libltdl blocked wants older versions ? Reply with quote

Code:

localhost chris # emerge --ask --update --deep --with-bdeps=y --newuse @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] sys-devel/libtool-2.4.2-r1 [2.4.4] USE="-static-libs% {-test%}" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] dev-libs/redland-1.0.16  USE="berkdb sqlite xml -iodbc -mysql -odbc -postgres -static-libs"
[ebuild  N     ] media-gfx/imagemagick-6.9.0.3  USE="X bzip2 cxx jpeg lcms openmp pango png svg tiff truetype xml zlib -autotrace -corefonts -djvu -fftw -fontconfig -fpx -graphviz -hdri -jbig -jpeg2k -lqr -lzma (-opencl) -openexr -perl -postscript -q32 -q64 -q8 -raw -static-libs {-test} -webp -wmf"
[blocks B      ] <sys-devel/libtool-2.4.3-r2:2 ("<sys-devel/libtool-2.4.3-r2:2" is blocking dev-libs/libltdl-2.4.4)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/libltdl-2.4.4:0/0::gentoo, installed) pulled in by
    dev-libs/libltdl required by @selected
    dev-libs/libltdl:0 required by (media-gfx/imagemagick-6.9.0.3:0/6.9.0.3::gentoo, ebuild scheduled for merge)
    dev-libs/libltdl:0 required by (dev-libs/redland-1.0.16:0/0::gentoo, ebuild scheduled for merge)

  (sys-devel/libtool-2.4.2-r1:2/2::gentoo, ebuild scheduled for merge) pulled in by

I've looked here
https://wiki.gentoo.org/wiki/Handbook:Parts/Working/Portage#Blocked_packages
but it didn't seem to help...

While a fix for this would be great, I'd really love to understand what's going on, I've tried merging / unmerging various packages to try to fix it, but I just hope I haven't made things worse....!

edit: I snipped a whole load of packages off the above all relying on libtool (various versions 2 2.2 2.4 and so on)


Last edited by codifies on Sun Jan 25, 2015 12:41 am; edited 1 time in total
Back to top
View user's profile Send private message
rapelotus
n00b
n00b


Joined: 12 Sep 2014
Posts: 20
Location: 中国江苏

PostPosted: Sat Jan 24, 2015 1:58 pm    Post subject: Reply with quote

As the https://wiki.gentoo.org/wiki/Handbook:Parts/Working/Portage#Blocked_packages hints
Quote:
Sometimes there are also blocking packages with specific atoms, such as <media-video/mplayer-1.0_rc1-r2. In this case, updating to a more recent version of the blocking package could remove the block.
It may be solved by updating sys-devel/libtool to a more recent version. Did you do it ?
Back to top
View user's profile Send private message
codifies
n00b
n00b


Joined: 29 Oct 2014
Posts: 22

PostPosted: Sat Jan 24, 2015 2:20 pm    Post subject: Reply with quote

that was my first thought too so as you can see its upgraded ([2.4.4])
Quote:
[ebuild UD ] sys-devel/libtool-2.4.2-r1 [2.4.4] USE="-static-libs% {-test%}" ABI_X86="32%* (64%*) (-x32)"

Yet here it seems that its an older version (2.4.3-r2:2) thats blocking ???
Quote:

[blocks B ] <sys-devel/libtool-2.4.3-r2:2 ("<sys-devel/libtool-2.4.3-r2:2" is blocking dev-libs/libltdl-2.4.4)
Back to top
View user's profile Send private message
rapelotus
n00b
n00b


Joined: 12 Sep 2014
Posts: 20
Location: 中国江苏

PostPosted: Sun Jan 25, 2015 12:40 am    Post subject: Reply with quote

Is it possible that you have two slots ?

If this is the case, it means you still have sys-devel/libtool-2.4.2-r1 installed on your system, you can try to unmerge it and then have a try again.
Back to top
View user's profile Send private message
codifies
n00b
n00b


Joined: 29 Oct 2014
Posts: 22

PostPosted: Sun Jan 25, 2015 12:47 am    Post subject: Reply with quote

many thanks to they guys on #gentoo

someone noticed on of the libs had been split into separate 32/64 libs so it was wanting to go for an earlier version to keep the 32bit compatibility

adding
=dev-libs/libltdl-2.4.4 abi_x86_32

to /etc/portage/package.use, allowed portage to fulfil the dependencies and after a few rounds of --update and --depclean all was well

I'd have never spotted the missing 32bit use flag that gave the guy on irc the clue do kudos to iamben
(I guess sometimes you have to look carefully for clues!)
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2950

PostPosted: Sun Jan 25, 2015 12:59 am    Post subject: Reply with quote

rapelotus, codifies ... libtool isn't slotted, the problem here seems to be multilib (see: bug 499390). It seems you have ABI_X86="32%* (64%*)" changed, but dev-libs/libltdl isn't similarly disposed. Please post:

Code:
# emerge --info dev-libs/libltdl

... I'm probably going to sleep shortly (after a long, tiring, day) so I may not be able to help. Hopefully someone else will step up.

EDIT: oh, I see you figured it out ... okidoki

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum