Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot get NetworkManager to work[SOLVED]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message

Joined: 19 Dec 2012
Posts: 71

PostPosted: Mon Jan 07, 2013 7:46 am    Post subject: Cannot get NetworkManager to work[SOLVED] Reply with quote

I'm lost and I don't know where to start. I've read alot in the manuals and I feel like I'm being pulled in several different directions with all the options there are for getting wifi to run. I've chosen to use NetworkManager, and nm-applet.

emerged: networkmanager, dhcpcd, nm-applet, linux-firmware, wireless-tools

I have a ath9k wireless driver that has been enabled in the kernel. I am able to modprobe it successfully.

tux user # ifconfig wlan0 up
tux user # ifconfig wlan0
wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 78:e4:00:42:44:52  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
tux user # iwconfig wlan0
wlan0     IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=14 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on

tux conf.d # rc-update
       NetworkManager |      default                 
             bootmisc | boot                         
           consolekit |      default          sysinit
                 dbus |      default                 
                devfs |                       sysinit
                dmesg |                       sysinit
                 fsck | boot                         
             hostname | boot                         
              hwclock | boot                         
              keymaps | boot                         
            killprocs |              shutdown       
                local |      default                 
           localmount | boot                         
              modules | boot                         
             mount-ro |              shutdown       
                 mtab | boot                         
               net.lo | boot                         
             netmount |      default                 
               procfs | boot                         
                 root | boot                         
            savecache |              shutdown       
                 swap | boot                         
            swapfiles | boot                         
               sysctl | boot                         
                sysfs |                       sysinit
            syslog-ng |      default                 
         termencoding | boot                         
       tmpfiles.setup | boot                         
                 udev |                       sysinit
           udev-mount |                       sysinit
       udev-postmount |      default                 
              urandom | boot                         
           vixie-cron |      default   

tux conf.d # equery hasuse dhcpcd
 * Searching for USE flag dhcpcd ...
[IP-] [  ] net-misc/networkmanager-

tux conf.d # nm-applet
GConf Error: Failed to contact configuration server; the most common cause is a missing or misconfigured D-Bus session bus daemon. See for information. (Details -  1: Failed to get connection to session: The connection is closed)

** (nm-applet:5980): WARNING **: Failed to initialize D-Bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(nm-applet:5980): GConf-WARNING **: Directory `/org/gnome/nm-applet' was not being monitored by GConfClient 0x80ab170


# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /usr/share/doc/openrc*/net.example* and save your configuration
# in /etc/conf.d/net (this file :]!).



# If NetworkManager does not establish a connection within $INACTIVE_TIMEOUT
# seconds after starting, the service will be marked as inactive, and it will
# continue to wait for a connection in background mode.


* EDIT - Working now *

I ran 'trayer' and then nm-applet, was able to add net connections. rebooted and voila, works.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum