Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HELP - since recent update sendmail won't start
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Moriah
Advocate
Advocate


Joined: 27 Mar 2004
Posts: 2118
Location: Kentucky

PostPosted: Mon Dec 31, 2012 5:06 pm    Post subject: HELP - since recent update sendmail won't start Reply with quote

Since a recent update, sendmail will not start after reboot, nor manually. It is complaining:
Code:

Dec 31 11:45:27 eli sendmail[2808]: alias database /etc/mail/aliases rebuilt by root
Dec 31 11:45:27 eli sendmail[2808]: /etc/mail/aliases: 31 aliases, longest 54 bytes, 854 bytes total
Dec 31 11:45:27 eli sm-mta[2811]: NOQUEUE: --- 451 4.0.0 /etc/mail/sendmail.cf: line 1311: Xclamav: local socket name /var/run/clamav/clamav-milter.sock unsafe: Group writable directory
Dec 31 11:45:27 eli sm-mta[2811]: NOQUEUE: SYSERR(root): /etc/mail/sendmail.cf: line 1311: Xclamav: local socket name /var/run/clamav/clamav-milter.sock unsafe: Group writable directory
Dec 31 11:45:27 eli sm-cm[2813]: starting daemon (8.14.4): queueing@00:30:00
Dec 31 11:45:27 eli sm-cm[2816]: qBVD0jOl007930: to=root, delay=03:44:42, xdelay=00:00:00, mailer=relay, pri=931524, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Dec 31 11:45:28 eli sm-cm[2816]: qBV902TY010196: to=root, ctladdr=root (0/0), delay=07:45:26, xdelay=00:00:01, mailer=relay, pri=1740247, relay=[127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Dec 31 11:45:28 eli sm-cm[2816]: qBUH0ZOl002095: to=root, delay=23:44:53, xdelay=00:00:00, mailer=relay, pri=4531532, relay=[127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Dec 31 11:45:28 eli sm-cm[2816]: qBUDQtQo005838: to=root, delay=1+03:18:33, xdelay=00:00:00, mailer=relay, pri=5341532, relay=[127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Dec 31 11:45:28 eli sm-cm[2816]: qBUD0BV1005674: to=root, ctladdr=root (0/0), delay=1+03:45:17, xdelay=00:00:00, mailer=relay, pri=5430255, relay=[127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Dec 31 11:45:28 eli sm-cm[2816]: qBU90B1b004030: to=root, ctladdr=root (0/0), delay=1+07:45:17, xdelay=00:00:00, mailer=relay, pri=6150255, relay=[127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]

I had this problem once before on another mahine, but that was because clamav-milter had not been started. This time, all the clam and spam daemons have been started:
Code:

 2719 ?        SNsl   0:14 /usr/sbin/clamd
 2795 ?        Ss     0:06 /usr/sbin/spamd -d -r /var/run/spamd.pid -m 5 -c -H
 2796 ?        S      0:00 spamd child
 2798 ?        S      0:00 spamd child

Furthermore, their pid files exist:
Code:

-rw-r--r-- 1 root root 5 Dec 31 11:45 /var/run/spamd.pid
-rw-rw-r-- 1 clamav clamav 4 Dec 31 11:43 /var/run/clamav/clamav-milter.pid
-rw-rw-r-- 1 clamav clamav 4 Dec 31 11:43 /var/run/clamav/clamd.pid
-rw-rw---- 1 clamav clamav 4 Dec 31 11:43 /var/run/clamav/freshclam.pid

But note that sendmail is not in this list. :cry:

Here is the directory with the milter socket:
Code:

eli ~ # ls -la /var/run/clamav/
total 12
drwxrwxr-x 2 clamav root   140 Dec 31 11:43 .
drwxr-xr-x 7 root   root   320 Dec 31 11:45 ..
-rw-rw-r-- 1 clamav clamav   4 Dec 31 11:43 clamav-milter.pid
srw-r--r-- 1 clamav clamav   0 Dec 31 11:43 clamav-milter.sock
-rw-rw-r-- 1 clamav clamav   4 Dec 31 11:43 clamd.pid
srw-rw-rw- 1 clamav clamav   0 Dec 31 11:43 clamd.sock
-rw-rw---- 1 clamav clamav   4 Dec 31 11:43 freshclam.pid


This problem only showed up after a reboot several days after a routine weekly update had been performed on this system.

BTW This update also broke my iptables scripts and caused me much grief, as the problem only showed up after a thunderstorm caused a reboot of many amchines while I was away on business for a week. This has been the worst update since the infamous "expat" disaster of several years ago! :evil:

So anyway, does anybody know what sendmail is *REALLY* unhappy about, and more importantly, how to fix it? :?:
_________________
The MyWord KJV Bible tool is at http://www.elilabs.com/~myword

Foghorn Leghorn is a Warner Bros. cartoon character.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14382

PostPosted: Mon Dec 31, 2012 11:53 pm    Post subject: Re: HELP - since recent update sendmail won't start Reply with quote

Moriah wrote:
Code:

Dec 31 11:45:27 eli sm-mta[2811]: NOQUEUE: --- 451 4.0.0 /etc/mail/sendmail.cf: line 1311: Xclamav: local socket name /var/run/clamav/clamav-milter.sock unsafe: Group writable directory
Dec 31 11:45:27 eli sm-mta[2811]: NOQUEUE: SYSERR(root): /etc/mail/sendmail.cf: line 1311: Xclamav: local socket name /var/run/clamav/clamav-milter.sock unsafe: Group writable directory
Code:

eli ~ # ls -la /var/run/clamav/
total 12
drwxrwxr-x 2 clamav root   140 Dec 31 11:43 .
I suspect it is unhappy about the situation reported by its error message, and that the fix is to change the permissions as suggested by that error message.
Back to top
View user's profile Send private message
Moriah
Advocate
Advocate


Joined: 27 Mar 2004
Posts: 2118
Location: Kentucky

PostPosted: Tue Jan 01, 2013 5:09 am    Post subject: Reply with quote

Things are not as they appear. See:

http://lists.freebsd.org/pipermail/freebsd-questions/2004-October/061365.html

For an explanation of what that error message really means. :?
_________________
The MyWord KJV Bible tool is at http://www.elilabs.com/~myword

Foghorn Leghorn is a Warner Bros. cartoon character.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14382

PostPosted: Tue Jan 01, 2013 7:43 pm    Post subject: Reply with quote

Your error message is different from the one cited in the FreeBSD mailing. Your error message specifically complains about a Group writable directory, which your ls output confirms to be the case here. The error message cited in the FreeBSD mailing does not explain what is unsafe, which is why the response you cited explained the error message. Have you tried changing the permissions such that the directory is no longer group writable?
Back to top
View user's profile Send private message
Moriah
Advocate
Advocate


Joined: 27 Mar 2004
Posts: 2118
Location: Kentucky

PostPosted: Wed Jan 02, 2013 3:00 am    Post subject: Reply with quote

Yes, I tried changing perms. It puts them right back the same way. The term "unsafe" *IS* explained in the post I referenced; it says it would be unsafe to send mail to that socket because mail might be lost. It also says that this is sendmail's "convoluted" way of saying that it thinks the milter is not running.
_________________
The MyWord KJV Bible tool is at http://www.elilabs.com/~myword

Foghorn Leghorn is a Warner Bros. cartoon character.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14382

PostPosted: Wed Jan 02, 2013 3:24 am    Post subject: Reply with quote

Yes, it is explained. However, the error message in the post you cited is different from the one you posted at the start of this thread. Hence, barring explicit evidence to the contrary, I consider them to be separate problems, though their ultimate result may be the same.
Back to top
View user's profile Send private message
Moriah
Advocate
Advocate


Joined: 27 Mar 2004
Posts: 2118
Location: Kentucky

PostPosted: Wed Jan 02, 2013 3:30 am    Post subject: Reply with quote

OK, so if my interpretation is wrong, and yours is correct, and changing the perms has no effect since it gets undone, can you make a suggestion that might solve my problem? I have not changed my configuration files from what used to work before my most recent update and reboot. I am about to go look at what version was running of clamav and sendmail, and compare it to what is running now, and if they are different (which I suspect is the case), then I will downgrade back to what worked. I can do this because I have backups on my backup server that runs every night, so I can see what changed. I would prefer to run the latest, but not if I cannot get it to work. Pragmatically, my problem right now is to get my email working again.
_________________
The MyWord KJV Bible tool is at http://www.elilabs.com/~myword

Foghorn Leghorn is a Warner Bros. cartoon character.
Back to top
View user's profile Send private message
Moriah
Advocate
Advocate


Joined: 27 Mar 2004
Posts: 2118
Location: Kentucky

PostPosted: Wed Jan 02, 2013 3:13 pm    Post subject: Reply with quote

Well, you were right about the group writable issue. I must have had multiple problems earlier, but this morning, I stopped sendmail, changed the perms to 755, and restarted sendmail, and the mail started flowing. I am both happy and embarrased. :oops: :D
_________________
The MyWord KJV Bible tool is at http://www.elilabs.com/~myword

Foghorn Leghorn is a Warner Bros. cartoon character.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum