Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] xorg-server-1.13.0-r1 blank screen (again :-/)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2359
Location: Edmonton, AB

PostPosted: Fri Dec 28, 2012 9:12 pm    Post subject: [SOLVED] xorg-server-1.13.0-r1 blank screen (again :-/) Reply with quote

I've upgraded my small box to xorg-server-1.13.0-r1 and get a bank screen. I can only log-in via ssh.

Code:
emerge --info
Portage 2.1.11.31 (default/linux/x86/10.0/desktop, gcc-4.5.4, glibc-2.15-r3, 3.2.12-gentoo i686)
=================================================================
System uname: Linux-3.2.12-gentoo-i686-VIA_Eden_Processor_1200MHz-with-gentoo-2.1
Timestamp of tree: Fri, 28 Dec 2012 03:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/fax /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/src/linux* /var/spool/fax/etc"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ ftp://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://10.0.0.103/gentoo-portage"
USE="X a52 aac acpi alsa bluetooth branding bzip2 cairo cdda cdr cgi cleartype cli consolekit consolkit corefonts cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac foomaticdb fortran gdbm gif gimp gimpprint gpm gtk iconv ipv6 java jpeg kpathsea lcms ldap libnotify lock mad mng modules mp3 mp4 mpeg mudflap mysql ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pppd qt3support readline scanner sdl session spache2 spell ssl startup-notification svg tcpd tetexspell thunar tiff truetype type1 udev udisks unicode upower usb vorbis wxwidgets x264 x86 xcb xml xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" PHP_TARGETS="php5-3 php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="vga vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Yes, I have rebuild the modules: emerge -1av $(qlist -IC x11-drivers)
without any errors, but not display after reboot.

Xorg-log:
Code:
[    26.081] (II) LoadModule: "glx"
[    26.174] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    26.206] (II) Module glx: vendor="X.Org Foundation"
[    26.206]    compiled for 1.13.0, module version = 1.0.0
[    26.206]    ABI class: X.Org Server Extension, version 7.0
[    26.206] (==) AIGLX enabled
[    26.206] Loading extension GLX
[    26.206] (==) Matched openchrome as autoconfigured driver 0
[    26.206] (==) Matched openchrome as autoconfigured driver 1
[    26.206] (==) Matched vesa as autoconfigured driver 2
[    26.206] (==) Matched modesetting as autoconfigured driver 3
[    26.206] (==) Matched fbdev as autoconfigured driver 4
[    26.207] (==) Assigned the driver to the xf86ConfigLayout
[    26.207] (II) LoadModule: "openchrome"
[    26.240] (WW) Warning, couldn't open module openchrome
[    26.240] (II) UnloadModule: "openchrome"
[    26.240] (II) Unloading openchrome
[    26.240] (EE) Failed to load module "openchrome" (module does not exist, 0)
[    26.241] (II) LoadModule: "vesa"
[    26.241] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    26.254] (II) Module vesa: vendor="X.Org Foundation"
[    26.254]    compiled for 1.13.0, module version = 2.3.2
[    26.254]    Module class: X.Org Video Driver
[    26.254]    ABI class: X.Org Video Driver, version 13.0
[    26.254] (II) LoadModule: "modesetting"
[    26.255] (WW) Warning, couldn't open module modesetting
[    26.255] (II) UnloadModule: "modesetting"
[    26.255] (II) Unloading modesetting
[    26.255] (EE) Failed to load module "modesetting" (module does not exist, 0)
[    26.255] (II) LoadModule: "fbdev"
[    26.256] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    26.259] (II) Module fbdev: vendor="X.Org Foundation"
[    26.259]    compiled for 1.13.0, module version = 0.4.3
[    26.259]    Module class: X.Org Video Driver
[    26.259]    ABI class: X.Org Video Driver, version 13.0
[    26.259] (II) VESA: driver for VESA chipsets: vesa
[    26.259] (II) FBDEV: driver for framebuffer: fbdev
[    26.259] (++) using VT number 7

[    26.264] (WW) Falling back to old probe method for fbdev
[    26.264] (II) Loading sub module "fbdevhw"
[    26.264] (II) LoadModule: "fbdevhw"
[    26.265] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    26.283] (II) Module fbdevhw: vendor="X.Org Foundation"
[    26.283]    compiled for 1.13.0, module version = 0.0.2
[    26.283]    ABI class: X.Org Video Driver, version 13.0
[    26.284] (EE) open /dev/fb0: No such file or directory
[    26.284] (II) Loading sub module "vbe"
[    26.284] (II) LoadModule: "vbe"
[    26.284] (II) Loading /usr/lib/xorg/modules/libvbe.so
[    26.292] (II) Module vbe: vendor="X.Org Foundation"
[    26.292]    compiled for 1.13.0, module version = 1.1.0
[    26.292]    ABI class: X.Org Video Driver, version 13.0
[    26.292] (II) Loading sub module "int10"
[    26.292] (II) LoadModule: "int10"
[    26.292] (II) Loading /usr/lib/xorg/modules/libint10.so
[    26.315] (II) Module int10: vendor="X.Org Foundation"
[    26.315]    compiled for 1.13.0, module version = 1.0.0
[    26.315]    ABI class: X.Org Video Driver, version 13.0
[    26.315] (II) VESA(0): initializing int10

_________________
#Joseph


Last edited by Joseph_sys on Sat Dec 29, 2012 12:03 am; edited 1 time in total
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2633
Location: Slovenia

PostPosted: Fri Dec 28, 2012 10:07 pm    Post subject: Reply with quote

Could be this: https://bugs.freedesktop.org/show_bug.cgi?id=53307
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2359
Location: Edmonton, AB

PostPosted: Sat Dec 29, 2012 12:03 am    Post subject: Reply with quote

Gusar wrote:
Could be this: https://bugs.freedesktop.org/show_bug.cgi?id=53307


It could be it.
I added driver "via" to make.conf and emerge it, now it is working.
VIDEO_CARDS="vga vesa fbdev via"
_________________
#Joseph
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum