Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] qemu rejects spice-USE flag ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Thu Dec 27, 2012 10:10 am    Post subject: [solved] qemu rejects spice-USE flag ? Reply with quote

I've set it both globally and package dedicated, but nevertheless emerge seems to ignore it ?

Last edited by toralf on Thu Dec 27, 2012 10:57 pm; edited 2 times in total
Back to top
View user's profile Send private message
lxg
Veteran
Veteran


Joined: 12 Nov 2005
Posts: 1019
Location: Aachen, Germany

PostPosted: Thu Dec 27, 2012 12:50 pm    Post subject: Reply with quote

Do you mean that emerge -pv qemu shows the flag disabled, or do you mean that after emerging the package the functionality is missing?

If it's the first, can you please post the output of

Code:
grep -r spice /etc/portage/* /etc/make.conf

_________________
lxg.de – codebits and tech talk
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Thu Dec 27, 2012 1:38 pm    Post subject: Reply with quote

I mean both :
Code:
$ grep -r spice /etc/portage/* /etc/portage/make.conf
/etc/portage/make.conf:     logrotate mbox mmx mysql mysqli nsplugin ntfs qemu rdesktop sna spice sse
/etc/portage/make.conf.backup:     logrotate mbox mmx mysql mysqli nsplugin ntfs qemu rdesktop sna spice sse
/etc/portage/package.accept_keywords/misc:~app-emulation/spice-0.12.0
/etc/portage/package.accept_keywords/misc:~net-misc/spice-gtk-0.14
/etc/portage/package.use/misc:net-misc/spice-gtk                python
/etc/portage/make.conf:     logrotate mbox mmx mysql mysqli nsplugin ntfs qemu rdesktop sna spice sse

$ sudo emerge -pv qemu

These are the packages that would be merged, in reverse order:

Calculating dependencies  . .... done!
[ebuild   R   ~] app-emulation/qemu-1.2.1  USE="aio alsa caps curl jpeg ncurses opengl png sdl seccomp threads uuid vhost-net vnc -bluetooth -brltty -debug -doc -fdt -mixemu -pulseaudio -python -rbd -sasl -smartcard (-spice) -static -systemtap -tci -tls -usbredir -vde -virtfs -xattr -xen -xfs" QEMU_SOFTMMU_TARGETS="i386 x86_64 -alpha -arm -cris -lm32 -m68k -microblaze -microblazeel -mips -mips64 -mips64el -mipsel -ppc -ppc64 -ppcemb -s390x -sh4 -sh4eb -sparc -sparc64 -xtensa -xtensaeb" QEMU_USER_TARGETS="i386 x86_64 -alpha -arm -armeb -cris -m68k -microblaze -microblazeel -mips -mipsel -ppc -ppc64 -ppc64abi32 -s390x -sh4 -sh4eb -sparc -sparc32plus -sparc64 -unicore32" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

$ qemu-kvm --name tails -m 2047 -cdrom ~/virtual/kvm/tails-i386.iso -boot d -smp 2 -net nic,vlan=0,model=virtio -net tap,vlan=0,ifname=tap3,script=no,downscript=no -spice port=5930,disable-ticketing
qemu-kvm: -spice port=5930,disable-ticketing: There is no option group 'spice'

spice is not supported by this qemu build.


Or do I have to compile spice with static-libs ?
Back to top
View user's profile Send private message
lxg
Veteran
Veteran


Joined: 12 Nov 2005
Posts: 1019
Location: Aachen, Germany

PostPosted: Thu Dec 27, 2012 2:52 pm    Post subject: Reply with quote

In your emerge -pv qemu, the spice USE flag is hardmasked, this means that some precondition is not met. It may indeed be that you need to build app-emulation/spice with static-libs, at least from looking at the qemu ebuild (although I wonder why Portage doesn't say so). Could you give it a try without breaking too much?
_________________
lxg.de – codebits and tech talk
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8597

PostPosted: Thu Dec 27, 2012 10:51 pm    Post subject: Reply with quote

lxg wrote:
In your emerge -pv qemu, the spice USE flag is hardmasked, this means that some precondition is not met. It may indeed be that you need to build app-emulation/spice with static-libs, at least from looking at the qemu ebuild (although I wonder why Portage doesn't say so). Could you give it a try without breaking too much?
You are correct that the flag is masked, but incorrect to suggest that rebuilding app-emulation/spice matters. If that were the problem, Portage would explicitly request the change. The flag has been explicitly disabled on x86, with a comment noting that it only works on 64-bit systems.
Back to top
View user's profile Send private message
lxg
Veteran
Veteran


Joined: 12 Nov 2005
Posts: 1019
Location: Aachen, Germany

PostPosted: Thu Dec 27, 2012 10:56 pm    Post subject: Reply with quote

Hu wrote:
If that were the problem, Portage would explicitly request the change.


Yeah, that's what I thought, too. Thanks for clarifying! However, how did you find this out? I didn't find that note in the spice package.
_________________
lxg.de – codebits and tech talk


Last edited by lxg on Thu Dec 27, 2012 10:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Thu Dec 27, 2012 10:57 pm    Post subject: Reply with quote

solved for my system by :
Code:
$ cat /etc/portage/profile/package.use.mask
#       package.use.mask
#

app-emulation/qemu              -spice
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum