Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]Could not find root block device in .
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 05 Apr 2012
Posts: 200

PostPosted: Sat Jan 19, 2013 1:22 pm    Post subject: [Solved]Could not find root block device in . Reply with quote

>> mounting root device...
>>using mount -t auto -o ro
!! The filesystem mounted at /dev/sda6 does not appear to be valid /, try again
!! Could not find the root block device in .

then i get a command line that asks me to type "root block device() ::"
i can also type shell for a shell and q to skip (which doesn't really do much)
if i type in /dev/sda6 i get the following
mount: /dev/sda6 on /newroot failed: Device or resource busy
!! Could not mount specified ROOT, try again
!! Could not find the root block device in .

Prior to this event gentoo was working fine (but i had a very minimal install i had only just installed kdebase on it and its deps)

1.I decided to upgrade GCC to testing branch so portage could recognize my i7. so its at the current testing branch version now (then emerged libtools aswell)

I upgraded my kdebase-meta also to testing branch version which was the only thing i really wasn't sure whether i'd want to do
I upgraded my nvidia-drivers (which gave me an API error on xorg saying i had mismatching drivers installed or something like that i can probably solve this one myself but if anyone knows the issue i'd love to get a pointer)
I emerged testing branch amarok.
I emerged chromium
I upgraded smplayer 2 to testing branch
i emerged openoffice-bin

I started by upgrading my gcc and libtools according to an official guide aswell as my make.conf then rebooted, everything was working as intended at that point.
then i did a genkernel to remove uvesafb support (cus i'm using vesa, and i didn't change any option but is it possible some options in my kernel may have changed when i did this causing the error?) and finally i emerged all of these things simultaneously different terminals (is it perhaps a bad idea to simultaneously emerge many programs? should i stick to only using one emerge at a time? could it be the cause?).

now when i got back to my computer everything had successfully emerged, i typed in reboot and got an error from bash saying "command not found"
then same deal with shutdown, i ended up rebooting by doing this

echo b > /proc/sysrq-trigger

and thats where i got this error for the first time

here's my fstab

/dev/sda3      /boot      ext2      defaults   1 2
/dev/sda6      /      ext4      defaults,noauto,noatime      0 1
/dev/sda5      none      swap      sw      0 0

#Windows 7
/dev/sdb2      /home/Storage   ntfs-3g      defaults,noatime   0 2
/dev/sdc1      /home/Games   ntfs-3g      defaults,noatime   0 2


default 0
timeout 4

title Windows 7 Ultimate x64
rootnoverify (hd0,0)
chainloader +1

title Gentoo Linux 3.5.7
root (hd0,2)
kernel /boot/kernel-genkernel-x86_64-3.5.7-gentoo root=/dev/ram0 real_root=/dev/sda6 video=vesafb:mtrr:3,ywrap vga=0x34C
initrd /boot/initramfs-genkernel-x86_64-3.5.7-gentoo

So far i've tried adding the line "rootfstype=ext4" to grub which didn't do much at all for me.
i have not yet tried to run from the livecd and chrooting but i have the cd, i haven't tried cus i have no idea what i would do
This picture was my biggest reason for ever trying Gentoo <3

Last edited by rabcor on Sat Jan 19, 2013 5:36 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 05 Jul 2003
Posts: 41956
Location: 56N 3W

PostPosted: Sat Jan 19, 2013 1:47 pm    Post subject: Reply with quote


!! Could not find the root block device in .
tells a lot.

The kernel tried to list all of the block devices it can see before the full stop.
In your case, none.

You have kernel support for your motherboard HDD controller missing.


Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message

Joined: 09 Dec 2006
Posts: 7544
Location: Goose Creek SC

PostPosted: Sat Jan 19, 2013 2:13 pm    Post subject: Reply with quote

boot cd
fsck /dev/sda6
oddly, let's hope for errors and fixes to be reported
mount the gentoo partitions, enter the chroot, nominally
:mount /dev/sda6 /mnt/gentoo
mount /dev/sda3 /mnt/gentoo/boot
cp /etc/resolv.conf /mnt/gentoo/etc/resolv.conf
mount -t proc none /mnt/gentoo/proc
mount --rbind /sys /mnt/gentoo/sys
mount --rbind /dev /mnt/gentoo/dev
chroot /mnt/gentoo /bin/bash
source /etc/profile
export PS1="(chroot) $PS1"
hopefully the mount goes well or gives a useful complaint
repeat the steps of
emerge gcc
gcc-config -l
gcc-config {latest version in list}
env-update && source /etc/profile
emerge --oneshot libtool
emerge -D {all the stuff you recently installed, only one emerge process at a time, emerging many items in a single emerge process is encouraged}
emerge -av --depclean after careful review to ensure you don't remove your active kernel source active gcc active glibc etc
emerge wgetpaste
emerge --info | wgetpaste and post the url returned and/or any errors or warnings in the process
exit chroot and reboot system
Defund the FCC.
Back to top
View user's profile Send private message

Joined: 05 Apr 2012
Posts: 200

PostPosted: Sat Jan 19, 2013 5:32 pm    Post subject: Reply with quote

Thanks for your replies guys :)

I ran fsck /dev/sda6 and it outputs

"/dev/sda6: clean, 353023/3137536 files, 2271423/1259140 blocks"

unfortunately i guess.

myself wrote:
next i tried chrooting successfully.

followed the short version steps and then did emerge gcc like you suggested and confirmed that gcc was configured to use the latest version available.
Then i emerge -D'ed all the stuff i had recently installed and did a depclean and so on, and rebooted finally.

After that i thought i'd see what depclean would give me before i would emerge -D everything
and it gave me something solid to work with "Dependancies could not be completely resolved due to the following required packages not being installed"

this explains something, i had to unmerge sysvinit and glib to be able to re-emerge kdebase-meta and i guess i figured it would reinstall it as a part of the emerge process. i'll try emerging all these things before i go any further and reboot and check if my system will load then.

allright, silly me i'll have to stop assuming things like this. i've got glib-2.34.3 but the depclean says this
<dev-libs/glib-2.33:2 pulled in by:

dev-libs/libxml12:2[-icu] pulled in by:

i have libxml 2.3.3

so i re-emerged QT (4.8.4) and gobject-introspection (1.34) testing branch, i've got no reason to have them in testing branch except that my glib is testing branch which makes gobject have to be aswell, but seems qt 4.8.4 is marked as stable so no worries on that.
i just realized a huge part of my system is now testing branch, more than i had intended i might almost just aswell take it all the way and get the kernel in testing branch instead of stable. (it all depends on if it has features i want/need which 3.6.11 doesn't but i think that doesn't happen until 3.8 or 3.9 features i want will mostly be SSD related stuff i guess. nop... there hardly even seems a reason for me to upgrade from 3.5.7 really... but i will nontheless. since i have such recent hardware i figure its better to have the latest kernel for a few years from now on it.)

i guess my biggest fault was being unaware of the problems with upgrading glib by unmerging and then re-emerging it. so far, and upgrading kdebase-meta to testing branch without carefully looking into what reasons i had for it (kdebase-meta testing branch required a newer vercion of glib).

Its my luck that i'm doing this on the computer that doesn't really "need" to have a functioning linux installation 4 days of the week while i'm at school.

So then, i decided to skip the step of deep emerge of all my recently installed packages at least for now. and doing a depclean.

Nano, Vala-common, nasm, libXvMC eselect-xvmc

i'll clean those and re-emerge nano.

revdep-rebuild: command not found

emerging gentoolkit


*Dynamic linking on your system is consistent... All done.

emerge --info | wgetpaste[/url]

Your paste can be seen here:

rebooting time.

Success!! thanks a lot for your comments guys, and thanks donahue for your easy to follow suggestions! like usual, i learned a lot from asking for help here! :) i wouldn't have done this in such a short amount of time if it wasn't for your input :)
This picture was my biggest reason for ever trying Gentoo <3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum