Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Banshee 1.8 working with iPhone?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
unixj
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2003
Posts: 134

PostPosted: Sun Oct 03, 2010 4:39 pm    Post subject: Banshee 1.8 working with iPhone? Reply with quote

Just curious if anyone has managed to get Banshee 1.8 working with an iphone. My iphone isn't recognized and there's the error on startup:

Code:
[Info  09:24:40.349] Running Banshee 1.8.0: [Gentoo/banshee/1.8.0 (linux-gnu, i686) @ 2010-10-03 00:13:08 PDT]
[Warn  09:24:41.041] Cannot connect to NetworkManager or Wicd - An available, working network connection will be assumed
[Info  09:24:42.685] Updating web proxy from GConf
[Info  09:24:43.466] All services are started 2.700443
[Info  09:24:45.000] nereid Client Started
[Info  09:24:45.276] AppleDeviceSource is ignoring unmounted volume iPhone
[Warn  09:24:45.294] Caught an exception - System.InvalidOperationException: Operation is not valid due to the current state of the object (in `Banshee.Dap.AppleDevice')
  at Banshee.Dap.AppleDevice.AppleDeviceSource.DeviceInitialize (IDevice device) [0x00000] in <filename unknown>:0
  at Banshee.Dap.DapService.FindDeviceSource (IDevice device) [0x00000] in <filename unknown>:0


I've compiled with +iphone. Removed --disable-gio and --disable-gio_hardware from the banshee-1.8.0.ebuild and installed the following (from http://gpo.zugaina.org/dev-dotnet):

Code:
dev-dotnet/gudev-sharp
dev-dotnet/gkeyfile-sharp
dev-dotnet/gio-sharp
dev-dotnet/gtk-sharp-beans


I see that GIO is enabled from the output of the compile:

Code:
    GIO Backend:       yes (glib >= 2.22, gtk-sharp-beans, and gio-sharp)
    GIO Hardware:      yes (gudev-sharp, gkeyfile-sharp)
    HAL Backend:       yes


I've also tried disabling HAL with --disable-hal (and shutting down hal) just in case that was interfering with the GIO backend.
Back to top
View user's profile Send private message
Charruah
n00b
n00b


Joined: 22 Nov 2010
Posts: 3

PostPosted: Mon Jun 13, 2011 8:19 am    Post subject: Same problem Reply with quote

I'm having the same issue. Were you able to solve it?
Back to top
View user's profile Send private message
unixj
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2003
Posts: 134

PostPosted: Mon Jun 13, 2011 4:07 pm    Post subject: Reply with quote

No and I stopped using Banshee a couple months ago. I filed a bug report here:
http://bugzilla.gnome.org/show_bug.cgi?id=643688

Last I checked, your best bet is to use clementine or gtkpod. Neither supports podcatching but you can use gpodder. clementine doesn't transfer the album covers. gtkpod requires you to mount with ifuse.
Back to top
View user's profile Send private message
v1c3
n00b
n00b


Joined: 15 May 2013
Posts: 5

PostPosted: Sun Sep 01, 2013 10:46 pm    Post subject: Reply with quote

SOLVED! Emerged gvfs with all USEFLAGS.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum