Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ksnapshot-4.9.95 and gwenview-4.9.95 fails to merge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 203
Location: Poland

PostPosted: Sat Dec 22, 2012 11:05 am    Post subject: ksnapshot-4.9.95 and gwenview-4.9.95 fails to merge Reply with quote

When kipi flag is enabled and kipi-plugins-3.0.0_beta3 installed both packages refuse to configure properly:

ksnapshot:
>>> Working in BUILD_DIR: "/var/tmp/paludis/kde-base-ksnapshot-4.9.95/work/ksnapshot-4.9.95_build"
cmake --no-warn-unused-cli -C /var/tmp/paludis/kde-base-ksnapshot-4.9.95/work/ksnapshot-4.9.95_build/gentoo_common_config.cmake -G Unix Makefiles -DCMAKE_INSTALL_PREFIX=/usr -DKDE4_BUILD_TESTS=OFF -DCMAKE_INSTALL_PREFIX=/usr -DSYSCONF_INSTALL_DIR=/etc -DWITH_kipi=ON -DWITH_KIPI=ON -DWITH_Kipi=ON -DCMAKE_BUILD_TYPE=Gentoo -DCMAKE_INSTALL_DO_STRIP=OFF -DCMAKE_USER_MAKE_RULES_OVERRIDE=/var/tmp/paludis/kde-base-ksnapshot-4.9.95/work/ksnapshot-4.9.95_build/gentoo_rules.cmake  /var/tmp/paludis/kde-base-ksnapshot-4.9.95/work/ksnapshot-4.9.95
Not searching for unused variables given on the command line.
loading initial cache file /var/tmp/paludis/kde-base-ksnapshot-4.9.95/work/ksnapshot-4.9.95_build/gentoo_common_config.cmake
-- The C compiler identification is GNU 4.7.2
-- The CXX compiler identification is GNU 4.7.2
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found
-- Found Qt-Version 4.8.4 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE 
-- Found OpenSSL: /usr/lib64/libssl.so;/usr/lib64/libcrypto.so (found version "1.0.1c")
-- Looking for _POSIX_TIMERS
-- Looking for _POSIX_TIMERS - found
-- Found Automoc4: /usr/bin/automoc4 
-- Found Perl: /usr/bin/perl (found version "5.16.1")
-- Found Phonon: /usr/include (Required is at least version "4.3.80")
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found KDE 4.10 include dir: /usr/include
-- Found KDE 4.10 library dir: /usr/lib64
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Configuring incomplete, errors occurred!
CMake Error at /usr/share/apps/cmake/modules/FindKipi.cmake:24 (IF):
  if given arguments:

    "STREQUAL" ""

  Unknown arguments specified
Call Stack (most recent call first):
  /usr/share/apps/cmake/modules/MacroOptionalFindPackage.cmake:32 (find_package)
  CMakeLists.txt:8 (macro_optional_find_package)



!!! ERROR in kde-base/ksnapshot-4.9.95::kde:
!!! In enable_cmake-utils_src_configure at line 2520
!!! cmake failed

!!! Call stack:
!!!    * enable_cmake-utils_src_configure (/var/tmp/paludis/kde-base-ksnapshot-4.9.95/temp/loadsaveenv:2520)
!!!    * _execute_optionaly (/var/tmp/paludis/kde-base-ksnapshot-4.9.95/temp/loadsaveenv:734)
!!!    * cmake-utils_src_configure (/var/tmp/paludis/kde-base-ksnapshot-4.9.95/temp/loadsaveenv:1418)
!!!    * kde4-base_src_configure (/var/tmp/paludis/kde-base-ksnapshot-4.9.95/temp/loadsaveenv:4227)
!!!    * src_configure (/var/tmp/paludis/kde-base-ksnapshot-4.9.95/temp/loadsaveenv:5358)
!!!    * ebuild_f_configure (/usr/libexec/paludis/2/src_configure.bash:54)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:668)
!!!    * main (/usr/libexec/paludis/ebuild.bash:691)


gwenview:
>>> Working in BUILD_DIR: "/var/tmp/paludis/kde-base-gwenview-4.9.95/work/gwenview-4.9.95_build"
cmake --no-warn-unused-cli -C /var/tmp/paludis/kde-base-gwenview-4.9.95/work/gwenview-4.9.95_build/gentoo_common_config.cmake -G Unix Makefiles -DCMAKE_INSTALL_PREFIX=/usr -DKDE4_BUILD_TESTS=OFF -DCMAKE_INSTALL_PREFIX=/usr -DSYSCONF_INSTALL_DIR=/etc -DWITH_Soprano=ON -DWITH_kipi=ON -DWITH_KIPI=ON -DWITH_Kipi=ON -DGWENVIEW_SEMANTICINFO_BACKEND=Nepomuk -DCMAKE_BUILD_TYPE=Gentoo -DCMAKE_INSTALL_DO_STRIP=OFF -DCMAKE_USER_MAKE_RULES_OVERRIDE=/var/tmp/paludis/kde-base-gwenview-4.9.95/work/gwenview-4.9.95_build/gentoo_rules.cmake  /var/tmp/paludis/kde-base-gwenview-4.9.95/work/gwenview-4.9.95
Not searching for unused variables given on the command line.
loading initial cache file /var/tmp/paludis/kde-base-gwenview-4.9.95/work/gwenview-4.9.95_build/gentoo_common_config.cmake
-- The C compiler identification is GNU 4.7.2
-- The CXX compiler identification is GNU 4.7.2
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found
-- Found Qt-Version 4.8.4 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE 
-- Found OpenSSL: /usr/lib64/libssl.so;/usr/lib64/libcrypto.so (found version "1.0.1c")
-- Looking for _POSIX_TIMERS
-- Looking for _POSIX_TIMERS - found
-- Found Automoc4: /usr/bin/automoc4 
-- Found Perl: /usr/bin/perl (found version "5.16.1")
-- Found Phonon: /usr/include (Required is at least version "4.3.80")
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found KDE 4.10 include dir: /usr/include
-- Found KDE 4.10 library dir: /usr/lib64
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Found JPEG: /usr/lib64/libjpeg.so 
-- Found ZLIB: /usr/lib64/libz.so (found version "1.2.7")
-- Found PNG: /usr/lib64/libpng.so (found version "1.5.13")
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.27.1")
-- Found Exiv2: /usr/lib64/libexiv2.so (found suitable version "0.23.0", minimum required is "0.19")
-- Configuring incomplete, errors occurred!
CMake Error at /usr/share/apps/cmake/modules/FindKipi.cmake:24 (IF):
  if given arguments:

    "STREQUAL" ""

  Unknown arguments specified
Call Stack (most recent call first):
  /usr/share/apps/cmake/modules/MacroOptionalFindPackage.cmake:32 (find_package)
  CMakeLists.txt:42 (macro_optional_find_package)



!!! ERROR in kde-base/gwenview-4.9.95::kde:
!!! In enable_cmake-utils_src_configure at line 2521
!!! cmake failed

!!! Call stack:
!!!    * enable_cmake-utils_src_configure (/var/tmp/paludis/kde-base-gwenview-4.9.95/temp/loadsaveenv:2521)
!!!    * _execute_optionaly (/var/tmp/paludis/kde-base-gwenview-4.9.95/temp/loadsaveenv:735)
!!!    * cmake-utils_src_configure (/var/tmp/paludis/kde-base-gwenview-4.9.95/temp/loadsaveenv:1419)
!!!    * kde4-base_src_configure (/var/tmp/paludis/kde-base-gwenview-4.9.95/temp/loadsaveenv:4228)
!!!    * src_configure (/var/tmp/paludis/kde-base-gwenview-4.9.95/temp/loadsaveenv:5369)
!!!    * ebuild_f_configure (/usr/libexec/paludis/2/src_configure.bash:54)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:668)
!!!    * main (/usr/libexec/paludis/ebuild.bash:691)


Anybody have any clue? Rest of kde-meta-4.9.95 merged without single problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum