Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Logging into LXDE with GDM brings me into LXDE then razor-qt
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
bedtime
n00b
n00b


Joined: 19 Dec 2012
Posts: 40

PostPosted: Fri Dec 21, 2012 5:38 pm    Post subject: Logging into LXDE with GDM brings me into LXDE then razor-qt Reply with quote

I have razor-qt and LXDE installed. GDM as my login manager. When I
log into LXDE it brings me into LXDE for a couple of seconds then
redirects me into razor-qt again. My ~/.xinitrc file is empty .

~/.bash_profile:
Code:
# /etc/skel/.bash_profile

# This file is sourced by bash for login shells.  The following line
# runs your .bashrc and is recommended by the bash info pages.
[[ -f ~/.bashrc ]] && . ~/.bashrc


//etc/rc.conf:
Code:
# Global OpenRC configuration settings
 DISPLAYMANAGER="gdm"

 # If we need to drop to a shell, you can specify it here.
 # If not specified we use $SHELL, otherwise the one specified in /etc/passwd,
 # otherwise /bin/sh
 # Linux users could specify /sbin/sulogin
 rc_shell=/sbin/sulogin

 # This is the number of tty's used in most of the rc-scripts (like
 # consolefont, numlock, etc ...)
 rc_tty_number=12


~/.bashrc
Code:
# /etc/skel/.bashrc
#
# This file is sourced by all *interactive* bash shells on startup,
# including some apparently interactive shells such as scp and rcp
# that can't tolerate any output.  So make sure this doesn't display
# anything or bad things will happen !


# Test for an interactive shell.  There is no need to set anything
# past this point for scp and rcp, and it's important to refrain from
# outputting anything in those cases.
if [[ $- != *i* ]] ; then # Shell is non-interactive.  Be done now! return fi


# Put your fun stuff here.


/ /etc/conf.d/xdm
Code:
# We always try and start X on a static VT. The various DMs
 normally default
 # to using VT7. If you wish to use the xdm init script, then you should ensure
 # that the VT checked is the same VT your DM wants to use. We do this check to
 # ensure that you haven't accidentally configured something to run on the VT
 # in your /etc/inittab file so that you don't get a dead keyboard.
 CHECKVT=7

 # What display manager do you use ?  [ xdm | gdm | kdm | gpe | entrance ]
 # NOTE: If this is set in /etc/rc.conf, that setting will override this one.
 DISPLAYMANAGER="gdm"
 


* edit - inserted inittab *

Code:
#
# /etc/inittab:  This file describes how the INIT process should set up
#                the system in a certain run-level.
#
# Author:  Miquel van Smoorenburg, <miquels@cistron.nl>
# Modified by:  Patrick J. Volkerding, <volkerdi@ftp.cdrom.com>
# Modified by:  Daniel Robbins, <drobbins@gentoo.org>
# Modified by:  Martin Schlemmer, <azarah@gentoo.org>
# Modified by:  Mike Frysinger, <vapier@gentoo.org>
# Modified by:  Robin H. Johnson, <robbat2@gentoo.org>
#
# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/files/inittab-2.87,v 1.1 2010/01/08 16:55:07 w$

# Default runlevel.
id:3:initdefault:

# System initialization, mount local filesystems, etc.
si::sysinit:/sbin/rc sysinit

# Further system initialization, brings up the boot runlevel.
rc::bootwait:/sbin/rc boot

l0:0:wait:/sbin/rc shutdown
l0s:0:wait:/sbin/halt -dhp
l1:1:wait:/sbin/rc single
l2:2:wait:/sbin/rc nonetwork
l3:3:wait:/sbin/rc default
l4:4:wait:/sbin/rc default
l5:5:wait:/sbin/rc default
l6r:6:wait:/sbin/reboot -dk
#z6:6:respawn:/sbin/sulogin

# new-style single-user
su0:S:wait:/sbin/rc single
su1:S:wait:/sbin/sulogin

# TERMINALS

c1:12345:respawn:/sbin/agetty 38400 tty1 linux
#c1:12345:respawn:/bin/login -f user tty1 </dev/tty1 >/dev/tty1 2>&1

c2:2345:respawn:/sbin/agetty 38400 tty2 linux
c3:2345:respawn:/sbin/agetty 38400 tty3 linux
c4:2345:respawn:/sbin/agetty 38400 tty4 linux
c5:2345:respawn:/sbin/agetty 38400 tty5 linux
c6:2345:respawn:/sbin/agetty 38400 tty6 linux

# SERIAL CONSOLES
#s0:12345:respawn:/sbin/agetty 115200 ttyS0 vt100
#s1:12345:respawn:/sbin/agetty 115200 ttyS1 vt100

# What to do at the "Three Finger Salute".
ca:12345:ctrlaltdel:/sbin/shutdown -r now

# Used by /etc/init.d/xdm to control DM startup.
# Read the comments in /etc/init.d/xdm for more
# info. Do NOT remove, as this will start nothing
# extra at boot if /etc/init.d/xdm is not added
# to the "default" runlevel.
x:a:once:/etc/X11/startDM.sh


Any ideas?
Back to top
View user's profile Send private message
bedtime
n00b
n00b


Joined: 19 Dec 2012
Posts: 40

PostPosted: Fri Dec 21, 2012 8:20 pm    Post subject: Update Reply with quote

I tried making a custom session in gdm:

$HOME/.Xclient
Code:
exec startlxde


Lxde starts but like before razor-qt opens up and takes over.


Also tried installing Lxdm login manager. The login manager works fine but still logs me into Lxde then right back into razor-qt. This is exceedingly frustrating.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum