Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] NetworkManager works, but command line tools don't?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
ultraslinky
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jun 2011
Posts: 80
Location: Milan, Italy

PostPosted: Sun Dec 23, 2012 6:15 pm    Post subject: [SOLVED] NetworkManager works, but command line tools don't? Reply with quote

Hello everyone,

I have been using Gentoo for quite some time on this netbook and i'm very satisfied about it. After using the command line tools and scripts for some time to connect my wireless, I decided to start using NetworkManager, and I've been using that for a while, haven't had any problems with that up to now.

However, just today i wanted to use the command line tools (i wanted to use Aircrack-ng actually) and i find out my "sudo iwconfig" output is empty, although i am connected to a wireless network:
Code:
james@Netbukkolo ~ $ sudo iwconfig
wlan0     no wireless extensions.

lo        no wireless extensions.

The network works fine as i am typing this now. However none of the command line tools will work at all, no matter if i kill NetworkManager or not, and no matter if i start up without it. I've also tried loading and reloading the device driver (ath5k) with no results.

I really don't understand what could make iwconfig's output be empty when everything is working fine. I am using the latest wireless-tools package, 30pre9, but i tried to downgrade to package version 29 and it still shows the problem.

I have a Linux Mint install on this netbook, and it works fine, with also iwconfig showing its correct output.

Emerge --info:
Code:
james@Netbukkolo ~ $ emerge --info
Portage 2.1.11.38 (default/linux/x86/10.0/desktop, gcc-4.7.2, glibc-2.16.0, 3.6.6-gentoo i686)
=================================================================
System uname: Linux-3.6.6-gentoo-i686-Intel-R-_Atom-TM-_CPU_N270_@_1.60GHz-with-gentoo-2.2
Timestamp of tree: Fri, 21 Dec 2012 03:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p39-r1
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="ftp://trumpetti.atm.tut.fi/gentoo/ http://trumpetti.atm.tut.fi/gentoo/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib acpi aio alsa apache2 assistant berkdb bluetooth branding btrfs bzip2 cairo cgi cli color consolekit cracklib crypt cups curl cxx dbus dri dts dvd dvdr egl emboss emotion encode exif faac fam fat ffmpeg fftw firefox flac fontconfig fortran fuse gd gdbm geoip gif glade glamor glib gmp gnuplot gphoto2 graphite graphviz gtk gtk3 hscolour iconv icu id3tag imagemagick introspection ipv6 jemalloc jpeg lame lcms ldap libkms libnotify libsamplerate llvm lm_sensors lua lzma lzo mad midi minizip mkl mmx mmxext mng modules mp3 mp4 mpeg mudflap multimedia mysql ncurses nls nptl ntfs ogg opengl openmp openvg pam pango pcre pdf perl png policykit ppds pppd python qt3support qt4 rar raw readline sdl session smp spell sqlite sse sse2 sse3 ssl ssse3 startup-notification svg tcl tcpd theora threads tiff timidity truetype udev udisks ukit unicode upnp upower usb uxa v4l vala vorbis webkit win32codecs wxwidgets x264 x86 xcb xml xmlpatterns xmp xpm xrandr xv xvid zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="pdfimport presenter-console presenter-minimizer" LINGUAS="en en_GB" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Thanks for the help :)


Last edited by ultraslinky on Sun Dec 23, 2012 7:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2633
Location: Slovenia

PostPosted: Sun Dec 23, 2012 6:42 pm    Post subject: Reply with quote

You don't have wext compatibility (CONFIG_CFG80211_WEXT) in your kernel. Either enable that, or use more modern tools, specifically net-wireless/iw
Back to top
View user's profile Send private message
ultraslinky
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jun 2011
Posts: 80
Location: Milan, Italy

PostPosted: Sun Dec 23, 2012 7:23 pm    Post subject: Reply with quote

Gusar wrote:
You don't have wext compatibility (CONFIG_CFG80211_WEXT) in your kernel. Either enable that, or use more modern tools, specifically net-wireless/iw


Oh yes indeed, i don't have that option set! I had deselected it during the last kernel compile, as the helper text said:
Code:
 CONFIG_CFG80211_WEXT:
  Enable this option if you need old userspace for wireless extensions with cfg80211-based drivers.     


I just didn't think the latest wireless-tools still needed that "old userspace" option, since i was running a full ~x86 system. I should be more careful in the future :) Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum