Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] merge error - emake failed- sys-apps/pciutils-3.1
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 07 Jan 2013
Posts: 8

PostPosted: Mon Jan 07, 2013 1:46 am    Post subject: [SOLVED] merge error - emake failed- sys-apps/pciutils-3.1 Reply with quote

Quit (*)buntu cold turkey, back to GENTOO! I'm doing an emerge of xbmc, the build stops here. Any ideas? I'm also seeing this error trying to compile perl. Thank you for any help in advance.

The moneyshot:
/usr/include/asm/sockios.h:1:33: fatal error: /usr/include/asm-generic/sockios.h: Value too large for defined data type

/usr/include/asm/sockios.h:1:33: fatal error: /usr/include/asm-generic/sockios.h: Value too large for defined data type
compilation terminated.
make[1]: *** [names-net.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/sys-apps/pciutils-3.1.10/work/pciutils-3.1.10/lib'
make: *** [lib/] Error 2
make: *** Waiting for unfinished jobs....
 * ERROR: sys-apps/pciutils-3.1.10 failed (compile phase):
 *   emake failed
 * If you need support, post the output of `emerge --info '=sys-apps/pciutils-3.1.10'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/pciutils-3.1.10'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/pciutils-3.1.10/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/pciutils-3.1.10/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-apps/pciutils-3.1.10/work/pciutils-3.1.10'
 * S: '/var/tmp/portage/sys-apps/pciutils-3.1.10/work/pciutils-3.1.10'

>>> Failed to emerge sys-apps/pciutils-3.1.10, Log file:

>>>  '/var/tmp/portage/sys-apps/pciutils-3.1.10/temp/build.log'

 * Messages for package sys-apps/pciutils-3.1.10:

 * ERROR: sys-apps/pciutils-3.1.10 failed (compile phase):
 *   emake failed

Portage (default/linux/x86/10.0/desktop/gnome, gcc-4.5.4, glibc-2.15-r3, 3.5.7-gentoo i686)
                         System Settings
System uname: Linux-3.5.7-gentoo-i686-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.1
Timestamp of tree: Sun, 06 Jan 2013 22:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
CFLAGS="-O2 -march=i686 -pipe"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa audiofile berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt css cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam ffmpeg firefox flac fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer iconv ipv6 jpeg lcms ldap libnotify mad mng modules mp3 mp4 mpeg mudflap nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd qt3support qt4 readline sdl session smp socialweb sound spell sse3 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upnp upower usb vorbis wxwidgets x264 x86 xcb xml xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Last edited by V1nnyM3 on Mon Jan 07, 2013 7:17 pm; edited 2 times in total
Back to top
View user's profile Send private message

Joined: 29 May 2005
Posts: 7259
Location: Saint Amant, Acadiana

PostPosted: Mon Jan 07, 2013 10:34 am    Post subject: Reply with quote

Not sure why exactly you are getting this error, may have something to do running a 32-bit install with hugefile support disabled. Why 32-bit? If you can do -j9 then your hardware should be capable of 64-bit unless you have some antique monster there.
Please learn how to denote units correctly!
Back to top
View user's profile Send private message

Joined: 07 Jan 2013
Posts: 8

PostPosted: Mon Jan 07, 2013 7:13 pm    Post subject: Reply with quote

Thanks Jag. It's the first gentoo install from minimal for me in a very long time, I did an emerge --update world and have not seen this issue since. Don't believe I have -j set correctly, i7 quad core which I've read I should set to at least 5. I may try the 64 bit version.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum