Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Package Conflict with genkernel/udev when installing xfce4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
contraversy
n00b
n00b


Joined: 28 Apr 2012
Posts: 38

PostPosted: Sat Nov 24, 2012 7:29 am    Post subject: Package Conflict with genkernel/udev when installing xfce4 Reply with quote

Forgive me that I cant copy paste from my machine.

I am following the guide from gentoo.org to install xfce, I set up my use flags and accept keywords but now when I

Code:
emerge -avt xfce4-meta


I get this message:
Code:
Conflict: 4 blocks (1 unsatisfied)

This didn't happen on my x86 machine, this is a multilib install.

Code:
 [blocks B      ] <sys-kernel/genkernel-3.4.25 ("<sys-kernel/genkernel-3.4.25" is blocking sys-fs/udev-195)

I understand genkernel is supposed to setup udev automatically, so what does this mean? I tried --autounmask --newuse --update with no resolve

As this is a fresh install my use file is small so here it is
package.use
Code:

=sys-fs/udev-171-r9 gudev
=sys-fs/udev-195 gudev gwdb
=sys-auth/pambase-20101024-r2 consolekit
=gnome-base/gvfs-1.12.3-r1 udisks
>=sys-auth/consolekit-0.4.5_p20120320-r1 policykit


If it helps >=sys-authconsolekit-0.4.5_p20120320-r1 policykit gave me trouble when I tried to echo it into the file, said no such file or directory, I had to manually add it to the file and I emerged consolekit just incase.

package.accept_keywords
Code:

=sys-apps/kmod-11-r1 ~amd64
=gnome-base/gvfs-1.12.3-r1 ~amd64
=sys-fs/udev-init-scripts-17-r1 ~amd64
=sys-fs/udev-195 ~amd64
=sys-fs/udev-init-scripts-17-r1
(sorry if any typos)

All of those entries were prompted from the emerge -avt xfce4 command (if that helps)

How do I manually fix this so genkernel wont block udev? again this is a fresh install of multi lib

Thanks for any help[/code]
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Sat Nov 24, 2012 1:13 pm    Post subject: Reply with quote

keyword genkernel as well
Code:
echo "sys-kernel/genkernel" >> /etc/portage/package.accept_keywords


using a mixed environment (stable, with some unstable packages) sometimes forces you to keyword some more packages.


V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
contraversy
n00b
n00b


Joined: 28 Apr 2012
Posts: 38

PostPosted: Sat Nov 24, 2012 4:05 pm    Post subject: Reply with quote

Well, thanks for the speedy reply, I am sure that would have helped. But when I booted, it was like half the installation was reversed, so instead of doing another minimal install, i did the full amd64 install, which included KDE desktop with it insead.

I'll get this setup and attempt removing kde for xfce, unless i start liking this kde ;) lol
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum