Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
failed to emerge x11-drivers/nvidia-drivers-310.32 (solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Shimanim
n00b
n00b


Joined: 26 Feb 2013
Posts: 10

PostPosted: Wed Mar 06, 2013 4:45 am    Post subject: failed to emerge x11-drivers/nvidia-drivers-310.32 (solved) Reply with quote

After doing emerge xorg-server and doing all 211 emerges and installs, this came up:

Code:
[32;01m * Package:    x11-drivers/nvidia-drivers-310.32
 * Repository: gentoo
 * Maintainer: jer@gentoo.org xarthisius@gentoo.org
 * USE:        X abi_x86_64 acpi amd64 consolekit elibc_glibc kernel_linux multilib policykit tools userland_GNU
 * FEATURES:   sandbox
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.7.10-gentoo/build
 * Found sources for kernel version:
 *     3.7.10-gentoo
>>> Unpacking source...
>>> Unpacking NVIDIA-Linux-x86_64-310.32.run to /var/tmp/portage/x11-drivers/nvidia-drivers-310.32/work
>>> Source unpacked in /var/tmp/portage/x11-drivers/nvidia-drivers-310.32/work
>>> Preparing source in /var/tmp/portage/x11-drivers/nvidia-drivers-310.32/work ...
 * Converting /kernel/Makefile.kbuild to use M= instead of SUBDIRS= ...
 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-drivers/nvidia-drivers-310.32/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-drivers/nvidia-drivers-310.32/work ...
 * Preparing nvidia module
make -j5 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- 'LDFLAGS=-m elf_x86_64' ARCH=x86_64 IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/3.7.10-gentoo/build CC=x86_64-pc-linux-gnu-gcc clean module
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Error 1
 * ERROR: x11-drivers/nvidia-drivers-310.32 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-310.32'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-310.32'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-310.32/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-310.32/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-310.32/work/kernel'
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-310.32/work/'


I can see this:

Code:
*** Unable to determine the target kernel version. ***


How do I fix this?


Last edited by Shimanim on Wed Mar 06, 2013 5:10 am; edited 1 time in total
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 164
Location: Northern California

PostPosted: Wed Mar 06, 2013 4:59 am    Post subject: Reply with quote

Follow the thread here (and a few others like it.)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum