Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Non US Keyboard in KDM
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
augustin2
Apprentice
Apprentice


Joined: 16 Mar 2012
Posts: 164
Location: France

PostPosted: Wed Nov 21, 2012 1:31 pm    Post subject: [SOLVED] Non US Keyboard in KDM Reply with quote

Hi,
I am new to Gentoo as well as to KDE. I managed to have a KDE system working (with much help from guys here) but I have only one trouble left. I cannot get a non US keyboard at login time in KDM.
I would like to use my French bépo kbd but I cannot even use a classic fr azerty one. I have seen a lot of things on the Internet but not always very fresh and clear enough to make me understand.

Did I miss something obvious in the manual ?


Last edited by augustin2 on Thu Nov 22, 2012 11:04 am; edited 1 time in total
Back to top
View user's profile Send private message
gabrielg
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2012
Posts: 86

PostPosted: Wed Nov 21, 2012 1:39 pm    Post subject: Reply with quote

Does your /etc/conf.d/keymaps have a keymap="[whatever your french keyboard code is]"? (mine is UK, slightly different to US, but works everywhere... only had problems with setting Mac keyboards in the past - no surprises there)
Back to top
View user's profile Send private message
augustin2
Apprentice
Apprentice


Joined: 16 Mar 2012
Posts: 164
Location: France

PostPosted: Wed Nov 21, 2012 2:21 pm    Post subject: Reply with quote

Thank you for helping me.

Yes it has.

Quote:
jaaf-P55A-UD4 jaaf # cat /etc/conf.d/keymaps
# Use keymap to specify the default console keymap. There is a complete tree
# of keymaps in /usr/share/keymaps to choose from.
keymap="fr"
Back to top
View user's profile Send private message
Fitzcarraldo
Guru
Guru


Joined: 30 Aug 2008
Posts: 461
Location: United Kingdom

PostPosted: Wed Nov 21, 2012 9:52 pm    Post subject: Reply with quote

For a French Bépo keyboard, for the console you will need to specify something like keymaps="fr-bepo" (no accent) in /etc/conf.d/keymaps. Check to see you have the keymap, though:

Code:
ls /usr/share/keymaps/i386/qwerty/fr*


And for X Windows you'll need to have something either in /etc/X11/xorg.conf or in /etc/X11/xorg.conf.d/*-keyboard.conf:

Code:
Option "XkbLayout" "fr"
Option "XkbVariant" "bepo"

or via the command line in a Konsole/Terminal window:

Code:
setxkbmap -layout fr -variant bepo

_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
augustin2
Apprentice
Apprentice


Joined: 16 Mar 2012
Posts: 164
Location: France

PostPosted: Thu Nov 22, 2012 4:40 am    Post subject: Reply with quote

Thank you for helping me.

For bépo I did what is explain here http://bepo.fr/wiki/Console_linux (in French, sorry)
That is to say I placed fr-dvorak-bepo.map into /usr/share/keymaps/i386/dvorak/
After that seing that it didn't work, I placed also a gz version. It didn't work any more.

The trouble doesn't seem coming from bépo as I cannot use a standard azerty fr as well.

Here is what is in /etc/xorg.conf.d

Code:
jaaf@jaaf-P55A-UD4 /etc/X11/xorg.conf.d $ ls -a
.  ..  10-evdev.conf  30-keyboard.conf

jaaf@jaaf-P55A-UD4 /etc/X11/xorg.conf.d $ cat 30-keyboard.conf
Section "InputClass"
        Identifier "keyboard-all"
        Driver "evdev"
        Option "XkbLayout" "us,fr"
        Option "XkbRules" "xorg"
        Option "XkbOptions" "grp:alt_shift_toggle,grp:switch,grp_led:scroll,compose:rwin,terminate:ctrl_alt_bksp"
        Option "XkbVariant" ",azerty"
        MatchIsKeyboard "on"
EndSection

jaaf@jaaf-P55A-UD4 /etc/X11/xorg.conf.d $ cat 10-evdev.conf
Section "InputClass"
   Identifier "evdev keyboard catchall"
   MatchIsKeyboard "on"
   MatchDevicePath "/dev/input/event*"
   Driver "evdev"
   Option "XkbLayout" "fr"
   Option "XkbVariant" "oss_latin9"
EndSection
jaaf@jaaf-P55A-UD4 /etc/X11/xorg.conf.d $ ls /usr/share/keymaps/i386/azerty/


At first , following the manual I put only 30-keyboard.conf then following advice here I added 10-evdev.conf

I precise that in the KDE environnement I can use both my fr-azerty and fr-bepo keyboards . The only practical trouble I have is a login (initial login in KDM or after a logout)
Back to top
View user's profile Send private message
augustin2
Apprentice
Apprentice


Joined: 16 Mar 2012
Posts: 164
Location: France

PostPosted: Thu Nov 22, 2012 11:03 am    Post subject: Reply with quote

I eventually managed to find a correct setting in /ect/X11/xorg.conf.d/ I only let 30-keyboard.conf to stay as close as possible to the manuel with this content

Code:
jaaf-P55A-UD4 xorg.conf.d # cat 30-keyboard.conf
Section "InputClass"
        Identifier "keyboard-all"
        Driver "evdev"
        Option "XkbLayout" "fr"
        Option "XkbRules" "xorg"
        Option "XkbOptions" "grp:alt_shift_toggle,grp:switch,grp_led:scroll,compose:rwin,terminate:ctrl_alt_bksp"
        Option "XkbVariant" "bepo"
        Option "XkbModel" "pc105"
        MatchIsKeyboard "on"
EndSection

jaaf-P55A-UD4 xorg.conf.d #


Probably the missing model option caused trouble.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum