Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] X fails to start after upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Tue Nov 20, 2012 8:51 pm    Post subject: [Solved] X fails to start after upgrade Reply with quote

I recently upgraded to kernel 3.6.6 (this is built with genkernel with the arguments "all --menuconfig --splash=natural_gentoo splash-res=1024x768") and Xorg-server 1.13.0-r1 and I switched from the ati fglrx drivers to the open source radeon drivers (my ati chip is an RV710 and as far as I gathered, this is no longer supported by the new drivers).

Ever since my X no longer starts up. Here is some of the Xorg.0.log:

Code:
[  7695.011] (--) using VT number 7

[  7695.042] (II) [KMS] drm report modesetting isn't supported.
[  7695.042] (II) [KMS] drm report modesetting isn't supported.
[  7695.042] (II) [KMS] drm report modesetting isn't supported.
[  7695.042] (II) [KMS] drm report modesetting isn't supported.
[  7695.042] (II) [KMS] drm report modesetting isn't supported.
[  7695.042] (EE) Screen 0 deleted because of no matching config section.
[  7695.042] (II) UnloadModule: "radeon"
[  7695.042] (EE) Screen 0 deleted because of no matching config section.
[  7695.042] (II) UnloadModule: "radeon"
[  7695.042] (EE) Screen 0 deleted because of no matching config section.
[  7695.042] (II) UnloadModule: "radeon"
[  7695.042] (EE) Screen 0 deleted because of no matching config section.
[  7695.042] (II) UnloadModule: "radeon"
[  7695.043] (EE) Device(s) detected, but none match those in the config file.
[  7695.043]
Fatal server error:
[  7695.043] no screens found
[  7695.043] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  7695.043] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  7695.043] (EE)
[  7695.098] Server terminated with error (1). Closing log file.


I understand that KMS needs to be enabled. How do I do that with the genkernel?

Are there other obvious things I'm missing?


Last edited by Q-collective on Wed Nov 21, 2012 9:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Tue Nov 20, 2012 10:38 pm    Post subject: Reply with quote

Q-collective,

A good outline for radeon drivers is located here

Just use make menuconfig to adjust your settings :wink:
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1559
Location: Berlin, Germany

PostPosted: Tue Nov 20, 2012 11:47 pm    Post subject: Reply with quote

If you use genkernel, then you can also use genkernel --menuconfig

If the radeon driver is built as module, you must ensure that it loads before X starts. This is typically done through /etc/conf.d/modules
Back to top
View user's profile Send private message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Wed Nov 21, 2012 9:37 pm    Post subject: Reply with quote

Switching on KMS in the kernel did indeed solve the issue (as well as probably removing the ati-drivers package from the system).

What helped me in particular was this radeon guide on the Gentoo wiki.

Thanks all :)
Back to top
View user's profile Send private message
eurabilis
n00b
n00b


Joined: 22 Jun 2010
Posts: 66
Location: Warwick, Rhode island, USA

PostPosted: Thu Aug 22, 2013 2:29 pm    Post subject: hmm. That link is broken. Reply with quote

That link is broken can someone help me out, I have the same problem, I am in make menuconfig but I cant find what to enable. What package did you remove exactly, I dont see a ati-drivers package installed. Thanks peeps.

*edit.
I found the links source it's in http://wiki.gentoo.org/wiki/Radeon but in make menuconfig they seem to have moved it. Anyone know where/what I need to enable in kernel 3.10.7?

The wiki says enable this.

Code:
<*> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) --->
            <*> ATI Radeon
            [*] Enable modesetting on radeon by default


But all I see is this..


Code:
   --- Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)                          │ │
  │ │                      [ ]   Allow to specify an EDID data set instead of probing for it                            │ │
  │ │                                                                                             

_________________
--
I am my only local user and I cannot be trusted. This is a generally a very bad thing. Thing is, with *nix where there is a shell there is a way.
Back to top
View user's profile Send private message
eurabilis
n00b
n00b


Joined: 22 Jun 2010
Posts: 66
Location: Warwick, Rhode island, USA

PostPosted: Thu Aug 22, 2013 3:21 pm    Post subject: All set Reply with quote

I fixed it by disabling all framebuffer devices and making radeon a module instead of bultin. Thanks anyway.
_________________
--
I am my only local user and I cannot be trusted. This is a generally a very bad thing. Thing is, with *nix where there is a shell there is a way.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum