Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Google's Python ADB + Fastboot implementation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
blopsalot
Apprentice
Apprentice


Joined: 28 Jan 2017
Posts: 231

PostPosted: Mon Mar 26, 2018 7:36 am    Post subject: Google's Python ADB + Fastboot implementation Reply with quote

For anyone who wants adb/fastboot without all the hoops to compile the c++ and dependencies. I dunno if they already in overlays somewhere, but here ya go.
https://github.com/google/python-adb

usage is just pyadb and pyfastboot

python-adb-9999.ebuild
Code:
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python{3_5,3_6} )

inherit distutils-r1 git-r3

DESCRIPTION="Python ADB + Fastboot implementation"
HOMEPAGE="https://github.com/google/python-adb"
EGIT_REPO_URI="https://github.com/google/python-adb.git"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE=""

DEPEND="virtual/libusb:=
   dev-python/setuptools[${PYTHON_USEDEP}]
   =dev-python/m2crypto-0.26.4
   dev-python/libusb1"
   
RDEPEND="${DEPEND}"


libusb1-9999.ebuild
Code:
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python{3_5,3_6} )

inherit distutils-r1 git-r3

DESCRIPTION="Python ctype-based wrapper around libusb1"
HOMEPAGE="https://github.com/vpelletier/python-libusb1"
EGIT_REPO_URI="https://github.com/vpelletier/python-libusb1.git"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE=""

DEPEND="virtual/libusb:=
   dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"


m2crypto-0.26.4.ebuild
Code:
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python{3_5,3_6} )
PYTHON_REQ_USE="threads(+)"

inherit distutils-r1

DESCRIPTION="M2Crypto: A Python crypto and SSL toolkit"
HOMEPAGE="https://gitlab.com/m2crypto/m2crypto"
SRC_URI="https://github.com/mcepl/M2Crypto/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/M2Crypto-${PV}"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"

IUSE="libressl swig"

RESTRICT=test

RDEPEND="
   !libressl? ( dev-libs/openssl[-bindist(-)] )
   libressl? ( dev-libs/libressl )
   dev-python/typing[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
   swig? ( dev-lang/swig )
   dev-python/setuptools[${PYTHON_USEDEP}]
"

python_compile() {
   distutils-r1_python_compile --openssl="${EPREFIX}"/usr
}

python_test() {
   esetup.py test
}
Back to top
View user's profile Send private message
undrwater
Apprentice
Apprentice


Joined: 28 Jan 2003
Posts: 297
Location: Caucasia

PostPosted: Mon Mar 26, 2018 5:00 pm    Post subject: Reply with quote

We have dev-util/android-tools
_________________
Open-mindedness is painful...
Back to top
View user's profile Send private message
blopsalot
Apprentice
Apprentice


Joined: 28 Jan 2017
Posts: 231

PostPosted: Mon Mar 26, 2018 5:20 pm    Post subject: Reply with quote

undrwater wrote:
We have dev-util/android-tools


I actually did this before vapier was kind enough to get rid of the ruby dependent ninja script generation. it has advantages/disadvantages compared to c++ implementation. i do not think it's available anywhere else, so I thought I would post it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum