Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] doesn't work with libgdal, texlive
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 15 Feb 2005
Posts: 47

PostPosted: Thu Nov 15, 2012 4:42 pm    Post subject: [solved] doesn't work with libgdal, texlive Reply with quote


Yesterdays upgrade cause libpoppler to be updated as well to Then revdep-rebuild reported that both pdftex-texlive-core-2012 and depended on, but both failed to recompile. The formaer fails when building the formats, while the latter fails after a while with

pdfdataset.cpp:351:47: error: no matching function for call to 'SplashOutputDev::startDoc(XRef*)'
/usr/include/poppler/SplashOutputDev.h:309:8: note: candidate is: void SplashOutputDev::startDoc(PDFDoc*)
pdfdataset.cpp: In static member function 'static GDALDataset* PDFDataset::Open(GDALOpenInfo*)':
pdfdataset.cpp:539:45: error: 'setErrorFunction' was not declared in this scope
pdfdataset.cpp:565:67: warning: ignoring return value of 'char* fgets(char*, int, FILE*)', declared with attribute warn_unused_result
make[2]: *** [../o/pdfdataset.o] Error 1
make[2]: Leaving directory `/mnt/extra/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/frmts/pdf'
make[1]: *** [pdf-install-obj] Error 2
make[1]: Leaving directory `/mnt/extra/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/frmts'
make: *** [frmts-target] Error 2
emake failed
* ERROR: sci-libs/gdal-1.8.1-r1 failed (compile phase):
* emake failed
* Call stack:
*, line 85: Called src_compile
* environment, line 7948: Called die
* The specific snippet of code:
* emake || die "emake failed";
* If you need support, post the output of `emerge --info '=sci-libs/gdal-1.8.1-r1'`,
* the complete build log and the output of `emerge -pqv '=sci-libs/gdal-1.8.1-r1'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM= CLASSPATH="" JAVA_HOME="/etc/java-config-2/current-system-vm"
and of course, the output of emerge --info
* The complete build log is located at '/mnt/extra/tmp/portage/sci-libs/gdal-1.8.1-r1/temp/build.log'.
* The ebuild environment file is located at '/mnt/extra/tmp/portage/sci-libs/gdal

Any Ideas? I do need TeX urgently. Thanks in advance!

-- Jürgen

Here's the output of `emerge -pqv '=sci-libs/gdal-1.8.1-r1':

Portage (default/linux/x86/10.0/desktop, gcc-4.5.4, glibc-2.15-r3, 3.5.7-gentoo i686)
System Settings
System uname: Linux-3.5.7-gentoo-i686-Intel-R-_Xeon-R-_CPU_E31270_@_3.40GHz-with-gentoo-2.1
Timestamp of tree: Thu, 15 Nov 2012 14:45:01 +0000
app-shells/bash: 4.2_p37
dev-java/java-config: 2.1.11-r3
dev-lang/python: 2.7.3-r2, 3.2.3
dev-util/cmake: 2.8.9
dev-util/pkgconfig: 0.27.1
sys-apps/baselayout: 2.1-r1
sys-apps/sandbox: 2.5
sys-devel/autoconf: 2.13, 2.68
sys-devel/automake: 1.9.6-r3, 1.11.6
sys-devel/binutils: 2.22-r1
sys-devel/gcc: 4.5.4
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc: 2.15-r3
Repositories: gentoo
CFLAGS="-O2 -march=i686 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=i686 -pipe"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa apng berkdb bluetooth branding bzip2 bzlib cairo caps cdda cddb cdparanoia cdr cli consolekit cracklib crypt css cups cxx dbus device-mapper dri dts dvd dvdr dvdread emboss encode exif extras fam firefox flac fortran gd gdbm gdu gif gimp gphoto2 gpm gsl gtk hal iconv icu ieee1394 ipv6 jpeg kpathsea latex lcms ldap libnotify lock mad mmx mng modules mp3 mp4 mpeg mpla mudflap ncurses nls nptl nsplugin ogg opengl openmp oss pam pango pcre pdf pdflib png policykit ppds pppd pulseaudio qt3support qt4 quicktime raw readline sdl session spell sqlite sse sse2 ssl startup-notification svg tcpd theora threads thunar tiff truetype udev udisks unicode upower usb vorbis wavpack wxwidgets x264 x86 xcb xine xml xorg xscreenserver xulrunner xv xvid yr zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Package Settings

sci-libs/gdal-1.8.1-r1 was built with the following:
USE="aux_xml gif jpeg pdf png sqlite threads -curl -debug -doc -ecwj2k -fits -geos -gml -hdf5 -jpeg2k -mysql -netcdf -odbc -ogdi -perl -postgres -python -ruby" RUBY_TARGETS="ruby18"

Last edited by koslowj on Fri Nov 16, 2012 8:22 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 14 Oct 2006
Posts: 6193

PostPosted: Thu Nov 15, 2012 8:43 pm    Post subject: Reply with quote

See Changelog entry for sci-libs/gdal at 10 Aug 2012 and at 25 May 2012 for the other package.
Back to top
View user's profile Send private message

Joined: 15 Feb 2005
Posts: 47

PostPosted: Fri Nov 16, 2012 1:59 am    Post subject: [solved] Reply with quote

VoidMage wrote:
See Changelog entry for sci-libs/gdal at 10 Aug 2012 and at 25 May 2012 for the other package.

Thanks for those pointers. It's now working again.

-- Jürgen
Back to top
View user's profile Send private message

Joined: 20 Aug 2012
Posts: 353

PostPosted: Wed Mar 20, 2013 6:02 am    Post subject: Reply with quote

Actually, since this remains ongoing, see confirmed bug #434316 for more details.

Otherwise, for conciseness and to save others time guessing until the patch is backported, just try building gdal with -pdf as a workaround.
Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum