Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Youtube videos garbled in firefox (works in opera)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Small_Penguin
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2005
Posts: 117

PostPosted: Mon Nov 05, 2012 5:12 pm    Post subject: Youtube videos garbled in firefox (works in opera) Reply with quote

Hi,

I have the following problem (screenshot of youtube video, no other parts of the screen):

http://img100.imageshack.us/img100/3457/firefoxyoutubescreensho.png

But only with all youtube videos in Firefox. It worked before (but I don't know when it stopped working). Opera plays them fine. It's not a problem with the profile.

Does anyone have the same problem or any idea what's wrong?

www-client/firefox-16.0.2 alsa custom-cflags dbus gstreamer ipc jit libnotify minimal startup-notification system-sqlite webm -bindist -custom-optimization -debug -pgo -selinux -wifi
Back to top
View user's profile Send private message
Small_Penguin
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2005
Posts: 117

PostPosted: Mon Nov 05, 2012 5:30 pm    Post subject: Reply with quote

Ok, happens in opera too. But not with all videos. Some work in Opera that do not in Firefox.
Back to top
View user's profile Send private message
dodo3773
n00b
n00b


Joined: 04 Jun 2012
Posts: 7

PostPosted: Mon Nov 05, 2012 6:24 pm    Post subject: Reply with quote

Are you using the proprietary flash for watching videos? If so did you build it with -vdpau or disabling hardware acceleration?
Back to top
View user's profile Send private message
Small_Penguin
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2005
Posts: 117

PostPosted: Mon Nov 05, 2012 6:44 pm    Post subject: Reply with quote

Yes. Recompiling with -vdpau did not help. How can I turn off hw accel? I did not see anything in flash settings.
Back to top
View user's profile Send private message
dodo3773
n00b
n00b


Joined: 04 Jun 2012
Posts: 7

PostPosted: Mon Nov 05, 2012 6:47 pm    Post subject: Reply with quote

Small_Penguin wrote:
Yes. Recompiling with -vdpau did not help. How can I turn off hw accel? I did not see anything in flash settings.


While a video is loaded you can right click the video and there should be a checkbox to disable it. Or you can create a file at "/etc/adobe/mms.cfg" and put your options there ((EnableLinuxHWVideoDecode=0)may be =1 I don't remember). That is where I would start though. May also be an issue with your graphics drivers (I wouldn't rule it out).
Back to top
View user's profile Send private message
Small_Penguin
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2005
Posts: 117

PostPosted: Mon Nov 05, 2012 6:56 pm    Post subject: Reply with quote

Tried with that option and set it to 0, didn't change anything. Changing it to 1 crashes the plugin.
I guess it's the r600g driver then, I updated that recently. Or maybe mesa.
Thanks for your help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum