Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
how to emerge php
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
tobigen
n00b
n00b


Joined: 07 Sep 2012
Posts: 34

PostPosted: Wed Oct 31, 2012 3:43 pm    Post subject: how to emerge php Reply with quote

Hi guys, I am wondering if anyone could assist me in emerging php. I keep getting the below error and I hv got no clue on how to solve it.
This is my /etc/portage/make.conf

ACCEPT_KEYWORDS="~amd64"
CFLAGS="-O2 -pipe"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
MAKEOPTS="-j5"
AUTOCLEAN="yes"
USE_HARDWARE="3dnow 3dnowext acpi -apm lm-sensors mmx mmxext sse sse2 usb udev"
USE_SOUND="alsa -arts -esd -oss gstreamer pulseaudio"
USE_GFX="gimp visualization encode"
USE_BASIC="opengl gtk imap xml bzip2 zlib java X vim-with-x vim-syntax spell tk"
USE_LIBS="gif jpeg png tiff svg a52 aac exif mp3 ogg vorbis theora xpm wmf win32codecs x264 flac postscript"
USE_OUTRAGE="-ipv6 -lirc -samba -gpm -eds -kde -emacs -xemacs -xdm -gdm -osd -xinerama -cups"
GENTOO_MIRRORS="ftp://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://ftp.halifax.rwth-aachen.de/gentoo/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo/"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
LINGUAS="en en_US"
ACCEPT_LICENSE="*"
INPUT_DEVICES="evdev synaptics keyboard mouse"
VIDEO_CARDS="radeon radeonsi vesa"
PORTAGE_NICENESS="3"
PORTDIR_OVERLAY="/usr/local/portage"
PORT_LOGDIR="/var/log/portage"
PORTAGE_ELOG_CLASSES="log warn error info"
PORTAGE_ELOG_SYSTEM="echo:log,warn save:log,warn,error,info syslog:error"



This is the php error

genTooBox# emerge -av php

* IMPORTANT: 5 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies |

!!! Problem resolving dependencies for dev-lang/php
... done!

!!! The ebuild selected to satisfy "php" has unmet requirements.
- dev-lang/php-5.4.8::gentoo USE="berkdb bzip2 cgi cli crypt ctype exif fileinfo filter fpm gdbm hash iconv ipv6 json ldap (multilib) nls phar posix readline session simplexml spell ssl tokenizer truetype unicode xml zlib -apache2 -bcmath -calendar -cdb -cjk -curl -curlwrappers -debug -doc -embed -enchant -firebird -flatfile (-frontbase) -ftp -gd -gmp -imap -inifile -intl -iodbc -kerberos (-kolab) -ldap-sasl -libedit -mhash -mssql -mysql -mysqli -mysqlnd -oci8-instant-client -odbc -pcntl -pdo -pic -postgres -qdbm -recode (-selinux) -sharedmem -snmp -soap -sockets -sqlite3 (-sybase-ct) -sysvipc -threads -tidy -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xsl -zip"

The following REQUIRED_USE flag constraints are unsatisfied:
truetype? ( gd ) exif? ( gd )

The above constraints are a subset of the following complete expression:
truetype? ( gd ) cjk? ( gd ) exif? ( gd ) xpm? ( gd ) gd? ( zlib ) simplexml? ( xml ) soap? ( xml ) wddx? ( xml ) xmlrpc? ( any-of ( xml iconv ) ) xmlreader? ( xml ) xsl? ( xml ) ldap-sasl? ( ldap ) kolab? ( imap ) mhash? ( hash ) phar? ( hash ) mysqlnd? ( any-of ( mysql mysqli pdo ) ) qdbm? ( !gdbm ) readline? ( !libedit ) recode? ( !imap !mysql !mysqli ) sharedmem? ( !threads ) !cli? ( !cgi? ( !fpm? ( !apache2? ( !embed? ( cli ) ) ) ) )
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Wed Oct 31, 2012 6:20 pm    Post subject: Reply with quote

Code:
echo "dev-lang/php gd" >> /etc/portage/package.use
emerge -av php

_________________
Defund the FCC.
Back to top
View user's profile Send private message
piotraf
n00b
n00b


Joined: 01 Apr 2003
Posts: 43
Location: Łódź - Poland

PostPosted: Wed Oct 31, 2012 6:23 pm    Post subject: Re: how to emerge php Reply with quote

tobigen wrote:

The following REQUIRED_USE flag constraints are unsatisfied:
truetype? ( gd ) exif? ( gd )

try to apply the REQUIRED_USE flag? :
Code:
USE="gd" emerge -pv php

if satisfctory, either add it globally to make.conf or locally e.g. by
Code:
echo "=dev-lang/php-5.4.8 gd" >> /etc/portage/package.use

or to all future php by
Code:
echo "dev-lang/php gd" >> /etc/portage/package.use

_________________
best regards/ pozdrawiam
PiotrAF
Back to top
View user's profile Send private message
tobigen
n00b
n00b


Joined: 07 Sep 2012
Posts: 34

PostPosted: Wed Oct 31, 2012 6:34 pm    Post subject: Reply with quote

Thanks guys I love you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum