Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X crashes when launching Kicad's module editor
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Kiesus
n00b
n00b


Joined: 17 Jun 2004
Posts: 12
Location: Finland

PostPosted: Tue Oct 30, 2012 10:28 am    Post subject: X crashes when launching Kicad's module editor Reply with quote

My X crashes every time I try to launch the module editor from the Kicad suite's PCBNew PCB editor.
I have tried recompiling Kicad, xorg-server, libdrm and the xf86-video-intel drivers.
I have an Intel Core-i5 3570K Ivy Bridge CPU and I'm using the integrated Intel HD graphics.
I have Gnome 3.4 as my DE.

I'm using Kicad version 2011-07-08 compiled from sources, with the commands
Code:
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr/local -DKICAD_KEEPCASE=ON -DKICAD_MINIZIP=OFF -DCMAKE_CXX_FLAGS=-m64 -DKICAD_STABLE_VERSION=ON ../
make
sudo make install


This is somewhat of a recent breakage, since I have used the same installation of Kicad sometime this past summer/fall.

Xorg.0.log.old with some backtrace info:
http://pastebin.com/K1da4bn4

emerge --info output:
http://pastebin.com/T6J3GTTN

Can someone read something useful from these? Is it the xorg-server or the intel driver that actually does something strange?
Any help would be much appreciated!
_________________
Assumption is the mother of all fuckups.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum