Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] special device /dev/mapper/home doesnt exist
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
virtguru
Tux's lil' helper
Tux's lil' helper


Joined: 14 Aug 2010
Posts: 130
Location: Eire

PostPosted: Thu Nov 01, 2012 3:15 pm    Post subject: [Solved] special device /dev/mapper/home doesnt exist Reply with quote

Reinstalled a system lately and added my /home drive after the finished installation. Now for some reason during the init process it wont ask for my luks password on /dev/mapper/home when booting its just spits out above error. I can open my home with cryptsetup on the proper disk and then mount it no problem. Can't figure out what Im missing. Here is how I have it setup so far:

/etc/fstab
Code:

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda1               /boot           ext2            noauto,noatime          1 2
/dev/mapper/root        /               ext4            noatime                 0 1
/dev/mapper/swap        none            swap            sw                      0 0
/dev/mapper/home        /home           ext4            noatime                 0 1
/dev/cdrom              /mnt/cdrom      auto            noauto,ro               0 0
proc                    /proc           proc            defaults                0 0
none                    /dev/shm        tmpfs           nodev,nosuid,noexec     0 0


/etc/conf.d/dmcrypt

Code:

swap=swap
source='/dev/sda2'
options='-c blowfish -h sha512 -d /dev/urandom'

## /home with passphrase
target=home
source='/dev/sdc1'


/proc/mounts
Code:

rootfs / rootfs rw 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
udev /dev devtmpfs rw,nosuid,relatime,size=10240k,nr_inodes=1021854,mode=755 0 0
devpts /dev/pts devpts rw,relatime,gid=5,mode=620 0 0
/dev/mapper/root / ext4 rw,noatime,data=ordered 0 0
tmpfs /run tmpfs rw,nosuid,nodev,relatime,mode=755 0 0
rc-svcdir /lib64/rc/init.d tmpfs rw,nosuid,nodev,noexec,relatime,size=1024k,mode=755 0 0
debugfs /sys/kernel/debug debugfs rw,nosuid,nodev,noexec,relatime 0 0
cgroup_root /sys/fs/cgroup tmpfs rw,nosuid,nodev,noexec,relatime,size=10240k,mode=755 0 0
cpuset /sys/fs/cgroup/cpuset cgroup rw,nosuid,nodev,noexec,relatime,cpuset 0 0
cpu /sys/fs/cgroup/cpu cgroup rw,nosuid,nodev,noexec,relatime,cpu 0 0
cpuacct /sys/fs/cgroup/cpuacct cgroup rw,nosuid,nodev,noexec,relatime,cpuacct 0 0
freezer /sys/fs/cgroup/freezer cgroup rw,nosuid,nodev,noexec,relatime,freezer 0 0
fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0
none /dev/shm tmpfs rw,nosuid,nodev,noexec,relatime 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec,relatime 0 0
/dev/mapper/home /home ext4 rw,noatime,data=ordered 0 0


Last edited by virtguru on Thu Nov 01, 2012 3:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
virtguru
Tux's lil' helper
Tux's lil' helper


Joined: 14 Aug 2010
Posts: 130
Location: Eire

PostPosted: Thu Nov 01, 2012 3:41 pm    Post subject: Reply with quote

In haste I forgot to add 'rc-update add dmcrypt boot' , working now , silly me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum