Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Switching to KDE: Some issues.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
alexcortes
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2011
Posts: 112
Location: Rio de Janeiro, Brazil

PostPosted: Tue Oct 30, 2012 1:31 am    Post subject: [SOLVED]Switching to KDE: Some issues. Reply with quote

Hello,

I switched from Gnome 3.4 to KDE 4.9.2 (I have near zero experience with KDE) starting from 'kde-base/kdebase-meta' and it goes almost smoothly, but I found two issues that I can't solve:

1 - Dolphin won't create any thumbnail:

Code:
kde-base/dolphin-4.9.2  USE="semantic-desktop thumbnail (-aqua) -debug -handbook"


They are enabled on Dolphin config, I have 'media-video/kffmpegthumbnailer', 'kde-base/thumbnailers' and 'kde-base/kdebase-kioslaves' installed.

2 - KsCD won't play CDs: :?

Code:
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.


Eventually I found some others d-bus issues but 'automagic' resolved.

Code:
sys-apps/dbus-1.6.8-r1  USE="X -debug -doc (-selinux) -static-libs -systemd {-test}"
x11-libs/qt-dbus-4.8.3  USE="exceptions (-aqua) -c++0x -debug -pch"


Thank you in advance! :)

EDIT: One more thing.
The terminal always start at ~/Documents, where I change that to start at ~/?


Last edited by alexcortes on Wed Oct 31, 2012 3:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
alexcortes
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2011
Posts: 112
Location: Rio de Janeiro, Brazil

PostPosted: Tue Oct 30, 2012 2:58 am    Post subject: Reply with quote

I found a related topic:

https://forums.gentoo.org/viewtopic-t-930602.html
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3839
Location: Irgendwo im Nirgendwo

PostPosted: Tue Oct 30, 2012 7:29 am    Post subject: Reply with quote

kscd seems to work only for a minority of users. Better stick to smplayer/vlc/qmmp/audacious/...
The posted QDbusConnection-warning is sort of annoying and stems from KUniqueApplication - every Unique Application (apps only allowing one instance, like kmail, amarok, ...) does produce that warning, but it won't affect usability.

Your HOME is specified in /etc/passwd. Edit manually using simply
Code:
# vipw

or install kuser and run it with
Code:
kdesu kuser

and specify home for your user.

USE="thumbnail" only will install a thumnailer for videofiles. Do you get absolutely no thumbs, even for images?
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
alexcortes
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2011
Posts: 112
Location: Rio de Janeiro, Brazil

PostPosted: Tue Oct 30, 2012 3:27 pm    Post subject: Reply with quote

Hello franzf,

Thanks for your comment.

I'll give up the Kscd for now. I'll stay with VLC since I'm using phonon-vlc. 8)

My home is /home/$USER, it's correct. I also take a look on passwd and really match. Just on virtual terminals (only when using KDE) it's open at ~/Documents. Konsole, Guake etc.. :evil:

EDIT: paying more attention, the ~/Documents issue only happens on GTK based terminals. Tested: guake, sakura, tilda.

I get no thumbs, for nothing on Dolphin. If I try (i.e.) to add new wallpaper for the list, then I get the images thumbs on the file manager window used for that. But on 'normal' Dolphin none.


Last edited by alexcortes on Tue Oct 30, 2012 11:19 pm; edited 2 times in total
Back to top
View user's profile Send private message
alexcortes
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2011
Posts: 112
Location: Rio de Janeiro, Brazil

PostPosted: Tue Oct 30, 2012 8:29 pm    Post subject: Reply with quote

Here's go a strace of dolphin:

strace_dolphin.txt

ktraderclient --servicetype ThumbCreator

*I disabled 'semantic-desktop' flag at all due to seems I don't need this.

Thank you!
Back to top
View user's profile Send private message
alexcortes
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2011
Posts: 112
Location: Rio de Janeiro, Brazil

PostPosted: Wed Oct 31, 2012 12:24 am    Post subject: Reply with quote

About ~/Documents signed as $HOME on gtk based terminals:

https://bugs.gentoo.org/show_bug.cgi?id=440344
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1265

PostPosted: Wed Oct 31, 2012 12:48 am    Post subject: Reply with quote

I would hazard a guess that this is a feature not a bug. If it really bothers you, you can try renaming Documents to documents like this: mv Documents documents
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
alexcortes
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2011
Posts: 112
Location: Rio de Janeiro, Brazil

PostPosted: Wed Oct 31, 2012 1:14 am    Post subject: Reply with quote

Hello Doctor.

If it's a feature, is a very odd feature IMHO! Since it's only happens on gtk terminals... :(

Thanks!
Back to top
View user's profile Send private message
alexcortes
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2011
Posts: 112
Location: Rio de Janeiro, Brazil

PostPosted: Wed Oct 31, 2012 1:38 am    Post subject: Reply with quote

I found it about the '~/Documents' thing:

https://bugs.kde.org/show_bug.cgi?id=201072

Thanks!

EDIT: as workaround I changed Documents path to $HOME.
Back to top
View user's profile Send private message
baaann
Guru
Guru


Joined: 23 Jan 2006
Posts: 482
Location: uk

PostPosted: Wed Oct 31, 2012 9:55 am    Post subject: Reply with quote

For thumbnails have you tried

Control > Adjust View Properties

and set "show preview"

There is a check box at the bottom of the dialog to make it the default
Back to top
View user's profile Send private message
alexcortes
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2011
Posts: 112
Location: Rio de Janeiro, Brazil

PostPosted: Wed Oct 31, 2012 3:16 pm    Post subject: Reply with quote

baaann wrote:
For thumbnails have you tried

Control > Adjust View Properties

and set "show preview"

There is a check box at the bottom of the dialog to make it the default


Thank you baaann :!:

Now it works! Except the videos, but I saw many issues with videos thumbs. I will investigate better. :D

The ~/Documents issue is fixed on "KDE 4.9.3".
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3839
Location: Irgendwo im Nirgendwo

PostPosted: Wed Oct 31, 2012 4:05 pm    Post subject: Reply with quote

I installed just for testing "kde-base/ffmpegthumbs" and video thumbs immediately showed up.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
alexcortes
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2011
Posts: 112
Location: Rio de Janeiro, Brazil

PostPosted: Wed Oct 31, 2012 4:12 pm    Post subject: Reply with quote

franzf wrote:
I installed just for testing "kde-base/ffmpegthumbs" and video thumbs immediately showed up.


I'm using that. It's working now. I did removed 'kde-base/mplayerthumbs', seems block the thumbnails.

I just don't get the videos thumbnails on folders, that small pictures. But ok.

I will try the inverse, remove ffmpegthumbs and use mplayerthumbs to see what's happen!

Thanks!!
Back to top
View user's profile Send private message
alexcortes
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2011
Posts: 112
Location: Rio de Janeiro, Brazil

PostPosted: Wed Oct 31, 2012 4:24 pm    Post subject: Reply with quote

Using media-video/kffmpegthumbnailer or/and media-video/ffmpegthumbnailer just works. But with kde-base/mplayerthumbs not.

*I'm using testing at all. 8)

Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum