Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Is there any way to block some kernel messages?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
petan
n00b
n00b


Joined: 18 Jan 2016
Posts: 19

PostPosted: Tue Jan 26, 2016 4:20 pm    Post subject: Is there any way to block some kernel messages? Reply with quote

I keep getting lots of this during boot:

cfg80211: Calling CRDA to update world regulatory domain

It's extremely annoying and I don't want to see that. Especially because I need to provide a password to decrypt the boot device and this message keep overwriting the screen while I am typing it, resulting it total garbage on my screen.

I don't care about CRDA, I just don't want to see this text. (But I don't want to disable wi-fi actually).

What came to my mind is recompiling kernel in a way that this wi-fi driver is actually a module that gets loaded after I decrypt my drive in moment I don't really care about kernel messages, but it keeps spamming there even if I use ctrl + alt + fN to switch to terminal and that is also extremely annoying as I basically can't work in there.

Is there any way to tell this module to seriously shut up? I am even thinking of removing the kernel log function calls from the module which spams this just to make it silent, but that's really nasty workaround that would need to be reapplied for every new kernel.
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1349

PostPosted: Tue Jan 26, 2016 5:38 pm    Post subject: Reply with quote

I have created a copy of the related udev.d file for to disable at:
/etc/udev/rules.d/85-regulatory.rules
Code:
# Runs CRDA for kernel wireless regulatory events.
# For more information see:
# http://wireless.kernel.org/en/developers/Regulatory/CRDA

KERNEL=="regulatory*", ACTION=="change", SUBSYSTEM=="platform", RUN+="/bin/true"

_________________
fun2gen2
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 3634

PostPosted: Tue Jan 26, 2016 8:22 pm    Post subject: Reply with quote

ulenrich wrote:
I have created a copy of the related udev.d file for to disable at: /etc/udev/rules.d/85-regulatory.rules

ulenrich ... I wouldn't expect the OP to have udev in their initramfs.

@petan ... it should suffice to add 'quiet' to the kernel boot parameters ... though I can't test this as my cfg80211 is a module.

best ... khay
Back to top
View user's profile Send private message
petan
n00b
n00b


Joined: 18 Jan 2016
Posts: 19

PostPosted: Wed Jan 27, 2016 8:12 am    Post subject: Reply with quote

khayyam wrote:
ulenrich wrote:
I have created a copy of the related udev.d file for to disable at: /etc/udev/rules.d/85-regulatory.rules

ulenrich ... I wouldn't expect the OP to have udev in their initramfs.

@petan ... it should suffice to add 'quiet' to the kernel boot parameters ... though I can't test this as my cfg80211 is a module.

best ... khay


Thanks that should fix that, I will try soonish
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum