Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
boxes for gnome3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Elleni
Apprentice
Apprentice


Joined: 23 May 2006
Posts: 220

PostPosted: Sun Oct 28, 2012 7:05 pm    Post subject: boxes for gnome3 Reply with quote

Hello,

does anyone know how I can get boxes for gnome3? Thannks in advance :)


Last edited by Elleni on Sun Oct 28, 2012 10:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7403
Location: Somewhere over Atlanta, Georgia

PostPosted: Sun Oct 28, 2012 7:17 pm    Post subject: Reply with quote

In the gnome-extras overlay. ;)

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
Elleni
Apprentice
Apprentice


Joined: 23 May 2006
Posts: 220

PostPosted: Sun Oct 28, 2012 10:41 pm    Post subject: Reply with quote

Did not find gnome-extras overlay, so I looked in gnome overlay, and there it was :)

But then...

Code:
emerge gnome-boxes -av

These are the packages that would be merged, in order:

Calculating dependencies                  ... done!

emerge: there are no ebuilds to satisfy "app-emulation/qemu-kvm[spice]".
(dependency required by "gnome-extra/gnome-boxes-9999" [ebuild])
(dependency required by "gnome-boxes" [argument])


Is another overlay needed for qemu-kvm :?:

Well I started thinking of emerge world -uDNav after adding gnome overlay to get newest gnome but..

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.32.4-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/glib-9999::gnome, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-9999:2 required by (dev-util/gdbus-codegen-9999::gnome, ebuild scheduled for merge)
    (and 13 more with the same problem)

x11-libs/gtk+:3

  (x11-libs/gtk+-9999::gnome, ebuild scheduled for merge) pulled in by
    >=x11-libs/gtk+-3.5.13:3 required by (gnome-base/gnome-control-center-3.6.2::gnome, ebuild scheduled for merge)
    (and 7 more with the same problem)

  (x11-libs/gtk+-3.4.4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/atk:0

  (dev-libs/atk-2.6.0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/atk-2.5.3[introspection?] required by (media-libs/clutter-1.12.2::gnome, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (dev-libs/atk-2.4.0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

app-accessibility/at-spi2-core:2

  (app-accessibility/at-spi2-core-9999::gnome, ebuild scheduled for merge) pulled in by
    >=app-accessibility/at-spi2-core-2.6 required by (app-accessibility/at-spi2-atk-9999::gnome, ebuild scheduled for merge)

  (app-accessibility/at-spi2-core-2.4.2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/gobject-introspection:0

  (dev-libs/gobject-introspection-1.32.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gobject-introspection-9999::gnome, ebuild scheduled for merge) pulled in by
    >=dev-libs/gobject-introspection-1.33.10 required by (dev-libs/gjs-9999::gnome, ebuild scheduled for merge)

dev-libs/gobject-introspection-common:0

  (dev-libs/gobject-introspection-common-1.32.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gobject-introspection-common-9999::gnome, ebuild scheduled for merge) pulled in by
    >=dev-libs/gobject-introspection-common-9999 required by (dev-libs/gobject-introspection-9999::gnome, ebuild scheduled for merge)

dev-util/gdbus-codegen:0

  (dev-util/gdbus-codegen-9999::gnome, ebuild scheduled for merge) pulled in by
    >=dev-util/gdbus-codegen-2.33 required by (gnome-base/nautilus-3.6.1::gnome, ebuild scheduled for merge)

  (dev-util/gdbus-codegen-2.32.4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

gnome-base/gvfs:0

  (gnome-base/gvfs-9999::gnome, ebuild scheduled for merge) pulled in by
    >=gnome-base/gvfs-1.14[gtk] required by (gnome-base/nautilus-3.6.1::gnome, ebuild scheduled for merge)

  (gnome-base/gvfs-1.12.3-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

gnome-extra/evolution-data-server:0

  (gnome-extra/evolution-data-server-3.6.1::gnome, ebuild scheduled for merge) pulled in by
    gnome-extra/evolution-data-server[vala] required by (gnome-extra/gnome-contacts-3.6.1::gnome, ebuild scheduled for merge)
    >=gnome-extra/evolution-data-server-3.6.1[gnome-online-accounts?,weather] required by (mail-client/evolution-3.6.1::gnome, ebuild scheduled for merge)
    (and 5 more with the same problems)

  (gnome-extra/evolution-data-server-3.4.4::gentoo, installed) pulled in by
    <gnome-extra/evolution-data-server-3.5.3 required by (app-misc/tracker-0.14.3::gentoo, installed)

mail-client/evolution:2.0

  (mail-client/evolution-3.6.1::gnome, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (mail-client/evolution-3.4.4::gentoo, installed) pulled in by
    <mail-client/evolution-3.5.3 required by (app-misc/tracker-0.14.3::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
#required by dev-libs/gjs-9999, required by gnome-extra/gnome-documents-3.6.1, required by gnome-base/gnome-extra-apps-3.4.1[tracker], required by gnome-base/gnome-3.4.1[extras], required by @selected, required by @world (argument)
=dev-libs/gobject-introspection-9999 **
#required by net-misc/vino-3.6.1, required by gnome-base/gnome-extra-apps-3.4.1, required by gnome-base/gnome-3.4.1[extras], required by @selected, required by @world (argument)
=dev-libs/glib-9999 **
#required by gnome-base/gnome-shell-3.6.1-r1, required by gnome-extra/gnome-tweak-tool-3.6.1, required by gnome-base/gnome-extra-apps-3.4.1, required by gnome-base/gnome-3.4.1[extras], required by @selected, required by @world (argument)
=app-accessibility/at-spi2-atk-9999 **
#required by gnome-base/gnome-shell-3.6.1-r1, required by gnome-extra/gnome-tweak-tool-3.6.1, required by gnome-base/gnome-extra-apps-3.4.1, required by gnome-base/gnome-3.4.1[extras], required by @selected, required by @world (argument)
=dev-libs/gjs-9999 **
#required by app-accessibility/at-spi2-atk-9999, required by x11-libs/gtk+-9999[X], required by gnome-base/nautilus-3.6.1, required by app-arch/file-roller-3.6.1.1[nautilus], required by gnome-base/gnome-extra-apps-3.4.1, required by gnome-base/gnome-3.4.1[extras], required by @selected, required by @world (argument)
=app-accessibility/at-spi2-core-9999 **
#required by dev-libs/gobject-introspection-9999, required by dev-libs/gjs-9999, required by gnome-extra/gnome-documents-3.6.1, required by gnome-base/gnome-extra-apps-3.4.1[tracker], required by gnome-base/gnome-3.4.1[extras], required by @selected, required by @world (argument)
=dev-libs/gobject-introspection-common-9999 **
#required by app-i18n/ibus-1.4.99.20121006[dconf], required by gnome-base/gnome-settings-daemon-3.6.0-r1[i18n], required by gnome-base/gdm-3.6.0-r1, required by gnome-base/gnome-shell-3.6.1-r1, required by gnome-extra/gnome-tweak-tool-3.6.1, required by gnome-base/gnome-extra-apps-3.4.1, required by gnome-base/gnome-3.4.1[extras], required by @selected, required by @world (argument)
=gnome-base/dconf-9999 **
#required by gnome-base/nautilus-3.6.1, required by app-arch/file-roller-3.6.1.1[nautilus], required by gnome-base/gnome-extra-apps-3.4.1, required by gnome-base/gnome-3.4.1[extras], required by @selected, required by @world (argument)
=dev-util/gdbus-codegen-9999 **
#required by gnome-base/nautilus-3.6.1, required by app-arch/file-roller-3.6.1.1[nautilus], required by gnome-base/gnome-extra-apps-3.4.1, required by gnome-base/gnome-3.4.1[extras], required by @selected, required by @world (argument)
=gnome-base/gvfs-9999 **
#required by sys-apps/baobab-3.6.2, required by gnome-base/gnome-extra-apps-3.4.1, required by gnome-base/gnome-3.4.1[extras], required by @selected, required by @world (argument)
=x11-libs/gtk+-9999 **

The following mask changes are necessary to proceed:
#required by gnome-base/gnome-control-center-3.6.2[i18n], required by gnome-base/gnome-shell-3.6.1-r1, required by gnome-extra/gnome-tweak-tool-3.6.1, required by gnome-base/gnome-extra-apps-3.4.1, required by gnome-base/gnome-3.4.1[extras], required by @selected, required by @world (argument)
# /usr/portage/profiles/package.mask:
# Naohiro Aota <naota@gentoo.org> (14 Oct 2012)
# Mask unstable ibus which relies on masked version of dconf.
=app-i18n/ibus-1.4.99.20121006
#required by media-libs/clutter-1.12.2, required by net-im/empathy-3.6.1[map], required by gnome-base/gnome-core-apps-3.4.1, required by gnome-base/gnome-3.4.1, required by @selected, required by @world (argument)
# /usr/portage/profiles/package.mask:
# Alexandre Rostovtsev <tetromino@gentoo.org> (25 Sep 2012)
# GNOME 3.6 mask
# Core libraries to be unmasked first:
=dev-libs/atk-2.6.0

The following USE changes are necessary to proceed:
#required by dev-libs/folks-0.8.0[eds,vala], required by net-im/empathy-3.6.1, required by gnome-base/gnome-core-apps-3.4.1, required by gnome-base/gnome-3.4.1, required by @selected, required by @world (argument)
=gnome-extra/evolution-data-server-3.6.1 vala
#required by gnome-extra/gnome-contacts-3.6.1[-v4l], required by net-im/empathy-3.6.1[gnome], required by gnome-base/gnome-core-apps-3.4.1, required by gnome-base/gnome-3.4.1, required by @selected, required by @world (argument)
=dev-libs/folks-0.8.0 vala
#required by gnome-base/gnome-shell-3.6.1-r1[i18n], required by gnome-extra/gnome-tweak-tool-3.6.1, required by gnome-base/gnome-extra-apps-3.4.1, required by gnome-base/gnome-3.4.1[extras], required by @selected, required by @world (argument)
>=app-i18n/ibus-1.4.99.20121006 dconf

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.


perhaps its to early and I should wait until it gets in main tree?`I mean I see many slot conflicts and 9999 versions... :oops:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum