Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Font size very tiny in urxvt
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
stieizc
n00b
n00b


Joined: 03 Oct 2012
Posts: 29
Location: China, Earth

PostPosted: Sun Oct 28, 2012 7:49 am    Post subject: Font size very tiny in urxvt Reply with quote

This is my first time dealing with x applications.
I emerged urxvt and modified configuration according to some guide and gentoo wiki, and then found the same problem with this thread:
https://forums.gentoo.org/viewtopic-t-783140-start-0-postdays-0-postorder-asc-highlight-urxvt.html
Then I used the solution there and found that I can just see a little tiny point as curser and nothing but little tiny space as I type in.
I figured that's because the font size so I add some line but failed. Then I removed some "pixel" settings which I don't know it's meaning, but still don't work.
How to solve this problem?
My .Xdefaults:
http://bpaste.net/show/54066
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3181

PostPosted: Sun Oct 28, 2012 10:50 am    Post subject: Reply with quote

Are you using rxvt or urxvt? Your .Xdefaults contain only rules for rxvt. The urxvt rules must start as "URxvt". Also, don't break the lines when you are declaring the rules. For instance this is one line, not two lines:
Code:
URxvt.font: xft:Terminus:antialias=false:size=8

_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
stieizc
n00b
n00b


Joined: 03 Oct 2012
Posts: 29
Location: China, Earth

PostPosted: Mon Oct 29, 2012 2:38 am    Post subject: Reply with quote

Thank you! It works.
I thought that Rxvt settings works with urxvt too. But I was wrong.
Also I found that my urxvt was not compiled with xft USE flag. That's interesting, because emerge -av doesn't show me there is a xft USE flag, but only a -xft flag, which I thought it means "build without". Maybe I should have read through the manual.
Back to top
View user's profile Send private message
BitJam
Advocate
Advocate


Joined: 12 Aug 2003
Posts: 2429
Location: Silver City, NM

PostPosted: Mon Oct 29, 2012 6:50 am    Post subject: Reply with quote

BTW: Here is a cool extension for urxvt that will let you change the font size with <Ctrl>-<Shift>-<Up> and <Ctrl>-<Shift>-<Down>.

This one is a little different from the others because the changes you make are persistent.
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3181

PostPosted: Mon Oct 29, 2012 2:45 pm    Post subject: Reply with quote

Well, I have the following keybindings in my Xdefaults Ctrl-7 to Ctrl-0. It's a static list of fonts, but good enough for my purpose. :)
Code:
URxvt.keysym.C-7:               command:\033]710;xft:inconsolata:size=10:antialias=true\007\033]711;xft:inconsolata:size=7:antialias=true\007
URxvt.keysym.C-8:               command:\033]710;xft:inconsolata:size=11:antialias=true\007\033]711;xft:inconsolata:size=8:antialias=true\007
URxvt.keysym.C-9:               command:\033]710;xft:inconsolata:size=12:antialias=true\007\033]711;xft:inconsolata:size=9:antialias=true\007
URxvt.keysym.C-0:               command:\033]710;xft:inconsolata:size=14:antialias=true\007\033]711;xft:inconsolata:size=10:antialias=true\007

_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum