Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
getting blocks trying to update kde
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
monicajae
Guru
Guru


Joined: 03 Sep 2003
Posts: 363
Location: Dorset, VT

PostPosted: Thu Oct 25, 2012 12:51 pm    Post subject: getting blocks trying to update kde Reply with quote

hi all. this is what i get as output of
Code:
emerge -p kdebase-startkde


Code:

VERA kde-base # emerge -p kdebase-startkde

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] kde-base/kde-env-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/oxygen-icons-4.9.2 [4.9.1]
[ebuild     U  ] sys-apps/util-linux-2.22 [2.20.1-r2] USE="udev%*"
[uninstall     ] sys-block/eject-2.1.5-r2
[blocks b      ] sys-block/eject ("sys-block/eject" is blocking sys-apps/util-linux-2.22)
[ebuild     U  ] kde-base/kdelibs-4.9.2 [4.9.1] USE="-zeroconf*"
[ebuild     U  ] kde-base/katepart-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kfmclient-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kdesu-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/khelpcenter-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/knotify-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/libkworkspace-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kephal-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kactivities-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/ksysguard-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kdepimlibs-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kde-wallpapers-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/ksplash-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/solid-runtime-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kcmshell-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/phonon-kde-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kstartupconfig-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kreadconfig-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/liboxygenstyle-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kuiserver-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kfile-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kdebase-menu-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/ktraderclient-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kdebugdialog-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/renamedlg-plugins-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kioclient-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kiconfinder-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/keditfiletype-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kwallet-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/attica-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/knetattach-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kdontchangethehostname-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kpasswdserver-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kdebase-menu-icons-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kwalletd-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kglobalaccel-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/ktimezoned-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kdebase-desktoptheme-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kquitapp-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kmimetypefinder-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kurifilter-plugins-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/knewstuff-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kstart-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kdnssd-4.9.2 [4.9.1] USE="-zeroconf*"
[ebuild     U  ] kde-base/kdialog-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kcheckpass-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/libkonq-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kcminit-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/libplasmagenericshell-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/plasma-runtime-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/plasma-apps-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kwin-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/libplasmaclock-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/libtaskmanager-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/drkonqi-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kdebase-kioslaves-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kdebase-data-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/khotkeys-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/solid-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/systemsettings-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kcontrol-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/ksmserver-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kdebase-runtime-meta-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/plasma-workspace-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/krunner-4.9.2 [4.9.1]
[ebuild     U  ] kde-base/kdebase-startkde-4.9.2 [4.9.1]
[blocks B      ] <sys-apps/sysvinit-2.88-r4 ("<sys-apps/sysvinit-2.88-r4" is blocking sys-apps/util-linux-2.22)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/util-linux-2.22::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/util-linux-2.13 required by (www-plugins/nspluginwrapper-1.4.4-r3::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/udev-171-r6::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (x11-libs/libSM-1.2.1::gentoo, installed)
    >=sys-apps/util-linux-2.13 required by (sys-power/pm-utils-1.4.1-r2::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/e2fsprogs-1.42::gentoo, installed)
    >=sys-apps/util-linux-2.22 required by (virtual/eject-0::gentoo, installed)
    sys-apps/util-linux required by @system
    >=sys-apps/util-linux-2.20.1-r2 required by (sys-fs/udisks-1.0.4-r2::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/lvm2-2.02.88::gentoo, installed)
    sys-apps/util-linux required by (app-text/build-docbook-catalog-1.4::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (dev-libs/apr-1.4.5::gentoo, installed)

  (sys-apps/sysvinit-2.88-r3::gentoo, installed) pulled in by
    >=sys-apps/sysvinit-2.86-r6 required by (virtual/init-0::gentoo, installed)


i'm a little rusty and i'm not comprehending this very well. I've been sleep deprived :(

can someone help out a girl?

tia
MONICA
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6254
Location: Goose Creek SC

PostPosted: Fri Oct 26, 2012 12:37 am    Post subject: Reply with quote

I would
Code:
emerge --unmerge sysvinit  util-linux
emerge -1 =sys-apps/util-linux-2.22
emerge -1 sysvinit
revdep-rebuild

part 2 section 1e of the handbook
_________________
Defund the FCC.
Back to top
View user's profile Send private message
monicajae
Guru
Guru


Joined: 03 Sep 2003
Posts: 363
Location: Dorset, VT

PostPosted: Wed Oct 31, 2012 12:38 pm    Post subject: Reply with quote

DONAHUE wrote:
I would
Code:
emerge --unmerge sysvinit  util-linux
emerge -1 =sys-apps/util-linux-2.22
emerge -1 sysvinit
revdep-rebuild

part 2 section 1e of the handbook


thank you Donahue. i get nervous unmerging things esp system apps. i get a

Code:
emerge --unmerge sysvinit  util-linux
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

 sys-apps/sysvinit
    selected: 2.88-r3
   protected: none
     omitted: none


!!! 'sys-apps/util-linux' is part of your system profile.
!!! Unmerging it may be damaging to your system.

>>> Waiting 10 seconds before starting...
>>> (Control-C to abort)...
Press Ctrl-C to Stop in:  10 9 8 7 6 ^C

and it creates anxiety for me :/
Back to top
View user's profile Send private message
monicajae
Guru
Guru


Joined: 03 Sep 2003
Posts: 363
Location: Dorset, VT

PostPosted: Wed Oct 31, 2012 12:42 pm    Post subject: Reply with quote

DONAHUE wrote:
I would
Code:
emerge --unmerge sysvinit  util-linux
emerge -1 =sys-apps/util-linux-2.22
emerge -1 sysvinit
revdep-rebuild

part 2 section 1e of the handbook


hey, um, could you type in a link? im assuming you are referring to the portage portion of the handbook?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6254
Location: Goose Creek SC

PostPosted: Wed Oct 31, 2012 2:21 pm    Post subject: Reply with quote

http://www.gentoo.org/doc/en/handbook/handbook-amd64.xml?style=printable&full=1#book_part2 Section B.1.e Working with portage: When portage is complaining: Blocked packages
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum