Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing GNOME 3 first time Stuck
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
sethhikari
n00b
n00b


Joined: 30 Jul 2008
Posts: 5

PostPosted: Thu Oct 25, 2012 7:07 am    Post subject: Installing GNOME 3 first time Stuck Reply with quote

This is my first time using Gentoo and have read pretty much all the documentation and instructions but I have got stuck here twice and don't know what to do. I am trying to install GNOME 3. Here is my error.

I have my profile set to desktop GNOME.

Code:
[ebuild  N    ~] gnome-extra/nautilus-tracker-tags-0.14.2  0 kB
[ebuild  N    ~] gnome-extra/gnome-documents-0.4.2  489 kB
[ebuild  N    ~] gnome-base/gnome-extra-apps-3.4.1  USE="shotwell tracker" 0 kB
[ebuild  N    ~] gnome-base/gnome-3.4.1  USE="bluetooth cdr cups extras fallback -accessibility" 0 kB
[blocks B      ] <dev-lang/vala-0.14.2-r2:0.14 ("<dev-lang/vala-0.14.2-r2:0.14" is blocking dev-libs/vala-common-0.18.0)
[blocks B      ] <dev-lang/vala-0.12.1-r1:0.12 ("<dev-lang/vala-0.12.1-r1:0.12" is blocking dev-libs/vala-common-0.18.0)
[blocks B      ] <dev-lang/vala-0.16.1-r2:0.16 ("<dev-lang/vala-0.16.1-r2:0.16" is blocking dev-libs/vala-common-0.18.0)
[blocks B      ] <sys-apps/shadow-4.1.5-r1 ("<sys-apps/shadow-4.1.5-r1" is blocking sys-auth/pambase-20120417-r1)

Total: 377 packages (2 upgrades, 375 new), Size of downloads: 505,783 kB
Conflict: 4 blocks (4 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/vala-common-0.18.0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/vala-common required by (gnome-base/librsvg-2.36.4::gentoo, ebuild scheduled for merge)

  (sys-auth/pambase-20120417-r1::gentoo, ebuild scheduled for merge) pulled in by
    sys-auth/pambase[consolekit] required by (gnome-base/gdm-3.4.1-r3::gentoo, ebuild scheduled for merge)
    >=sys-auth/pambase-20081028 required by (net-misc/openssh-5.9_p1-r4::gentoo, installed)
    sys-auth/pambase required by (sys-auth/polkit-0.107-r1::gentoo, ebuild scheduled for merge)
    sys-auth/pambase required by (sys-apps/openrc-0.9.8.4::gentoo, installed)
    sys-auth/pambase[consolekit] required by (sys-auth/polkit-0.107-r1::gentoo, ebuild scheduled for merge)
    sys-auth/pambase required by (sys-libs/pam-1.1.5::gentoo, installed)
    >=sys-auth/pambase-20080219.1 required by (sys-apps/shadow-4.1.4.3::gentoo, installed)

  (dev-lang/vala-0.14.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-lang/vala-0.13.2:0.14 required by (media-video/cheese-3.4.2::gentoo, ebuild scheduled for merge)

  (dev-lang/vala-0.16.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/vala:0.16[vapigen] required by (sys-libs/libosinfo-0.2.0::gentoo, ebuild scheduled for merge)
    dev-lang/vala:0.16 required by (media-gfx/shotwell-0.12.3::gentoo, ebuild scheduled for merge)
    dev-lang/vala:0.16[vapigen] required by (net-libs/libsocialweb-0.25.21::gentoo, ebuild scheduled for merge)
    >=dev-lang/vala-0.15.1:0.16 required by (gnome-extra/gnome-games-3.4.2::gentoo, ebuild scheduled for merge)
    dev-lang/vala:0.16[vapigen] required by (net-libs/telepathy-glib-0.18.2::gentoo, ebuild scheduled for merge)

  (sys-apps/shadow-4.1.4.3::gentoo, installed) pulled in by
    >=sys-apps/shadow-4.1 required by (virtual/shadow-0::gentoo, installed)

  (dev-lang/vala-0.12.1::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/vala:0.12 required by (net-misc/vinagre-3.4.2::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

Twilight-Ubuntu / # emerge -av --newuse --update gnome
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5829

PostPosted: Thu Oct 25, 2012 10:08 am    Post subject: Reply with quote

There are two problem here - one about pambase/shadow (search for it - it's some old problem, but just about trivial to fix), the other one about vala versions.
As for the second, check which vala versions you've got installed, uninstall any slots <0.14, update the other.
Back to top
View user's profile Send private message
sethhikari
n00b
n00b


Joined: 30 Jul 2008
Posts: 5

PostPosted: Sun Oct 28, 2012 8:14 am    Post subject: Reply with quote

Thank you this fixed it and I am all up and running

Had to unmask both pambase and shadow

installed vala one by one
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum