Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox only crashes after emerge -uaD world
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 189

PostPosted: Tue Oct 23, 2012 10:03 pm    Post subject: Firefox only crashes after emerge -uaD world Reply with quote

Helo and please help!

I'm a little bit desperately.

Today I did a world update updated to:
glibc-2.15-r3
udev-171-r8
polkit-kde-kcmodules-0.98_pre20120917
libproxy-0.4.10

And now firefox-10.0.7 just crashes on startup (segmentation fault)
firefox-bin-10.0.7 chrashes always too, but gives an feetback-dialoge
firefox-16.0.0.1 starts but crashes at the second page...

What has happened?
It did all go fine before upgrade. glibc update was just from r2 to r3.
-mno-avx is now forced for every merge.

Does anyone have these problems too or an solution?
_________________
With nice greetings
Vrenn
Back to top
View user's profile Send private message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 189

PostPosted: Wed Oct 24, 2012 8:16 am    Post subject: Reply with quote

Man, that aint be true:
reemergeing with -mno-avx doesn't wort
kernel-downgrade doesn't work

firefox -safe-mode works...

so it's an addon. (but how the hell did it get now affected as I changed nothing in firefox)
uninstalling adobe flash doesn't work so it's not.
probing now other addons.

(I suggest the oxygen-addon as polkit-kde-kcmodules-0.98_pre20120917 might do something)
_________________
With nice greetings
Vrenn
Back to top
View user's profile Send private message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 189

PostPosted: Wed Oct 24, 2012 8:28 am    Post subject: Reply with quote

I was wrong, oxygen KDE 3.9.1 is the only working...
adblockplus & binnen be gone are crashing. Trying with a clean profile...
_________________
With nice greetings
Vrenn
Back to top
View user's profile Send private message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 189

PostPosted: Wed Oct 24, 2012 9:35 am    Post subject: Reply with quote

got my target.
downgrade to libproxy 0.4.7 solved the firefox-crashes.

does the dependecy spidermonkey fight with firefox? (both mozilla-engines)

I'll test it.
_________________
With nice greetings
Vrenn
Back to top
View user's profile Send private message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 189

PostPosted: Wed Oct 24, 2012 4:57 pm    Post subject: Reply with quote

Yes, target confirmed.

Using libproxy with webkit is no option for a kde/vlc user, as it pulls over webkit-gtk too mutch gnome and gstreamer stuff in.
Only way out is USE="-webkit -pac"

I don't now if use of proxy is a problem in some programs now (missing pac support, as firefox seems to use libproxy in a way)
What do you think about it?
_________________
With nice greetings
Vrenn
Back to top
View user's profile Send private message
ExecutorElassus
l33t
l33t


Joined: 11 Mar 2004
Posts: 733
Location: Stuttgart, Germany

PostPosted: Thu Oct 25, 2012 10:05 pm    Post subject: Reply with quote

According to this bug, it's a problem between libproxy and spidermonkey. No word yet on a workaround besides downgrading libproxy.
Back to top
View user's profile Send private message
passrecord
n00b
n00b


Joined: 30 Oct 2012
Posts: 2

PostPosted: Fri Nov 02, 2012 11:40 am    Post subject: Passrecord Reply with quote

hello

if you fire fox has been crashed you just remove from control panel and then install new fire fix.
_________________
passrecord
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum