Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
guvcview video capture wrong with mjpeg
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message

Joined: 22 Sep 2007
Posts: 44
Location: Poland

PostPosted: Sat Oct 20, 2012 1:35 pm    Post subject: guvcview video capture wrong with mjpeg Reply with quote

Dear Members,

I have problems with video capture in guvcview when I use MJPG video codec. The webcam (Logitech C270), drivers (uvc), audio works perfectly. The preview window, and recording in any other format (YUY2, MPEG, ect) is also OK. However when I record a video using MJPG it is very distorted and mplayer continuously reports:
mjpeg_decode_dc: bad vlc: 0:0
error dc
error y=4 x=44 (here the numbers varies for every frame).

I've tried to download a sample video in mjpg to test mplayer and it plays OK, so I assume that there are problems with encoding and guvcview, but I might be worng.
I'm using guvcview-1.5.1 and mplayer-1.0_rc4_p20110322-r1.
DO You have any idea what should I do to fix it? Is there any more info needed?

Thanks in advance,
Michael Widlok

emerge --info:

    Portage (default/linux/x86/10.0, gcc-4.5.3, glibc-2.13-r4, 3.2.1-gentoo-r2-mw i686)
    System uname: Linux-3.2.1-gentoo-r2-mw-i686-Intel-R-_Xeon-TM-_CPU_3.00GHz-with-gentoo-2.0.3
    Timestamp of tree: Sun, 13 May 2012 19:30:01 +0000
    app-shells/bash: 4.1_p9
    dev-java/java-config: 2.1.11-r3
    dev-lang/python: 2.7.2-r3, 3.1.4-r3
    dev-util/cmake: 2.8.6-r4
    dev-util/pkgconfig: 0.26
    sys-apps/baselayout: 2.0.3
    sys-apps/sandbox: 2.5
    sys-devel/autoconf: 2.13, 2.68
    sys-devel/automake: 1.11.1
    sys-devel/binutils: 2.21.1-r1
    sys-devel/gcc: 4.5.3-r2
    sys-devel/gcc-config: 1.5-r2
    sys-devel/libtool: 2.4-r1
    sys-devel/make: 3.82-r1
    sys-kernel/linux-headers: 3.1 (virtual/os-headers)
    sys-libs/glibc: 2.13-r4
    Repositories: gentoo bitcoin
    CFLAGS="-O2 -mtune=nocona -mmmx -fomit-frame-pointer -Wall -pipe -msse3 -march=nocona"
    CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
    CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
    CPPFLAGS="-O2 -mtune=nocona -mmmx -fomit-frame-pointer -Wall -pipe -msse3 -march=nocona"
    CXXFLAGS="-O2 -mtune=nocona -mmmx -fomit-frame-pointer -Wall -pipe -msse3 -march=nocona"
    FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
    LINGUAS="en pl"
    PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
    USE="X a52 aac acl acpi alsa apng bash-completion blas bzip2 cairo cddb cdparanoia cdr cdrom chroot colordiff consolekit cracklib crypt cups cxx device-mapper dia dmx dri drm dvd dvdr dynamic encode exif ffmpeg fftw firefox flac fontconfig foomaticdb fortran gadu gdbm gif gimp glade glibc-omitfp gs gtk gudev high-ints highlight iconv jabber jpeg jpeg2k lame lapack logrotate mad mmap mmx mmxext modules mp3 mp4 mpeg mplayer mudflap nls nptl nsplugin nut odbc ogg opengl openmp pam pcre pdf png policykit ppds psyco python qt3support rar readline regex reiserfs rtc session sharedmem slang smp sse sse2 sse3 ssl ssse3 startup-notification subtitles subversion svg syslog tcpd theora threads tiff transcode truetype udev unicode unzip usb userlocales uuencode v4l vim vim-pager vim-syntax vorbis wav x264 x86 xcomposite xfs xft xml xorg xpm xrandr xrender xv xvid xvmc zip zlib" ALSA_CARDS="ca0106" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en pl" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Back to top
View user's profile Send private message

Joined: 22 Sep 2007
Posts: 44
Location: Poland

PostPosted: Mon Nov 19, 2012 8:01 am    Post subject: Reply with quote


In my last message I've reported problems with MJPG and guvcview. Form that time I've tried some (or a lot of) combinations: different versions of mplayer, guvcview, ffmpeg, ect, but it did not changed anything. Please tell me what else can I try. It seems that nobody else has such problems, and I can not figure what is wrong on my system. If You have any idea what should I try (maybe use flags?) then please let me know.

Very Best Regards,
Michael Widlok
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum