Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to install free vmware server on gentoo using shell?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
uri2013
n00b
n00b


Joined: 17 Oct 2012
Posts: 4

PostPosted: Wed Oct 17, 2012 2:01 am    Post subject: How to install free vmware server on gentoo using shell? Reply with quote

Hi

I require to install vmware server on a gentoo machine.
The server is already installed with many other packages, and really not looking to mess up anything.


Packages I found installed that I am not sure if they can be used are:


//As I understand Layman can be used for any other builds
so that it doesn't touch the core configuration.

app-portage/layman
Latest version available: 2.0.0_rc3
Latest version installed: 2.0.0_rc3
Size of files: 72 kB
Homepage: http://layman.sourceforge.net/
Description: Tool to manage Gentoo overlays
License: GPL-2


app-emulation/vmware-modules
Latest version available: 264.4
Latest version installed: 1.0.0.15-r1
Size of files: 0 kB
Homepage: http://www.vmware.com/
Description: VMware kernel modules
License: GPL-2

How do I find which virtual machines are installed if there are any, as I am not sure on this.

What will be the procedures to install vmware server, and is building it on layman better?


The configuration for the vmware server are as follows:

Will require to add a ubuntu virtual machine, and
make it that I can ssh into it and not the gentoo physical machine.

also binding it to to active directory will it be done also on the virtual machine or can it be done that it will use the setup from the physical machine.


Will really appreciate any assistance into this.

Thanks,

Uri
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4895

PostPosted: Wed Oct 17, 2012 6:24 am    Post subject: Reply with quote

vmware-server is depreciated, use vmware-player
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
uri2013
n00b
n00b


Joined: 17 Oct 2012
Posts: 4

PostPosted: Wed Oct 17, 2012 7:02 am    Post subject: Reply with quote

thanks for the reply.

You are saying I should go ahead with vmware-player?

The packages that i listed are the ones that I searched for in relation to vmware.
searched for layman as I saw that it is used for ebuilds, which vmware can be put on the ebuild.


What do you recommend I should do?

without layman, and install vmware-player?
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4895

PostPosted: Wed Oct 17, 2012 7:52 am    Post subject: Reply with quote

check this link: http://www.vmware.com/support/policies/lifecycle/general/index.html
under vmware server you can see that version 2 was released on 2008/09/23 and eos ended on 2011/06/30.

in this link: https://my.vmware.com/web/vmware/free#desktop_end_user_computing/vmware_player/5_0 you can see that version 5.0.0-812388 was released on 2012-08-23.

you do the math with what you need. if vmware player doesn't provides you with what you need and vmware server does, either stay with vmware server (I wouldn't recommend it), check kvm or virtualbox or try to find other ways to do what you need without using vmware server.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
b0nafide
Apprentice
Apprentice


Joined: 17 Feb 2008
Posts: 153
Location: ~/

PostPosted: Wed Oct 17, 2012 10:21 pm    Post subject: Reply with quote

Just out of curiosity what is the output of:

Code:
$ emerge -pv vmware-player


On my system it says vmware-player-4.0.4.744019-r1 will pull in 9 new packages, 2 of them slotted.

So in my case, if I wanted to install vmware-player for some strange reason it wouldn't mess anything up already installed.
Back to top
View user's profile Send private message
uri2013
n00b
n00b


Joined: 17 Oct 2012
Posts: 4

PostPosted: Thu Oct 18, 2012 2:25 am    Post subject: Reply with quote

The following is the output of emerge -pv vmware-player:



These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild NS ] media-libs/libpng-1.2.50 [1.4.4] 527 kB
[ebuild N ] app-emulation/vmware-tools-8.8.4.744019 USE="-vmware_guest_fre ebsd -vmware_guest_linux -vmware_guest_netware -vmware_guest_solaris -vmware_gue st_winPre2k -vmware_guest_windows" 0 kB
[ebuild N ] dev-libs/libev-4.11 USE="-static-libs" 474 kB
[ebuild N ] dev-libs/libverto-0.2.4 USE="libev threads -glib -libevent -st atic-libs -tevent" 334 kB
[ebuild N ] dev-cpp/libsexymm-0.1.9 USE="doc -debug" 341 kB
[ebuild N ] app-crypt/mit-krb5-1.10.3 USE="doc keyutils pkinit threads xin etd -openldap {-test}" 11,260 kB
[ebuild NS ] dev-libs/openssl-0.9.8x [1.0.0d] USE="gmp kerberos (sse2) zlib -bindist {-test}" 3,694 kB
[ebuild N ] app-emulation/vmware-player-4.0.4.744019-r1 USE="cups doc vmwa re-tools" 126,670 kB
[ebuild U ] app-emulation/vmware-modules-264.4 [1.0.0.15-r1] USE="-pax_kern el%" 0 kB
[blocks B ] app-crypt/heimdal ("app-crypt/heimdal" is blocking app-crypt/mi t-krb5-1.10.3)
[blocks B ] app-crypt/mit-krb5 ("app-crypt/mit-krb5" is blocking app-crypt/ heimdal-1.4.1_pre20110304)

Total: 9 packages (1 upgrade, 6 new, 2 in new slots), Size of downloads: 143,299 kB
Conflict: 2 blocks (2 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(app-crypt/heimdal-1.4.1_pre20110304::gentoo, installed) pulled in by
app-crypt/heimdal required by (www-apache/mod_auth_kerb-5.4::gentoo, install ed)
app-crypt/heimdal required by (sys-auth/pam_krb5-4.3::gentoo, installed)
app-crypt/heimdal required by (dev-lang/php-5.3.6::gentoo, installed)
app-crypt/heimdal required by (kde-base/kdelibs-4.6.1-r1::gentoo, installed)
app-crypt/heimdal required by (net-misc/curl-7.21.4::gentoo, installed)
app-crypt/heimdal required by (net-libs/neon-0.29.5::gentoo, installed)
app-crypt/heimdal required by (net-analyzer/wireshark-1.2.13::gentoo, instal led)
app-crypt/heimdal required by @selected
app-crypt/heimdal required by (dev-libs/cyrus-sasl-2.1.23-r2::gentoo, instal led)
app-crypt/heimdal required by (dev-db/postgresql-base-9.0.3::gentoo, install ed)
app-crypt/heimdal required by (net-misc/openssh-5.8_p2::gentoo, installed)
app-crypt/heimdal required by (net-mail/dovecot-2.0.13::gentoo, installed)
app-crypt/heimdal required by (net-print/cups-1.4.6::gentoo, installed)
app-crypt/heimdal required by (dev-db/virtuoso-server-6.1.2::gentoo, install ed)
app-crypt/heimdal required by (dev-perl/GSSAPI-0.28::gentoo, installed)
app-crypt/heimdal required by (gnome-base/gnome-vfs-2.24.4-r1::gentoo, insta lled)
app-crypt/heimdal required by (gnome-extra/evolution-data-server-2.32.2::gen too, installed)
app-crypt/heimdal required by (net-fs/samba-3.5.7::gentoo, installed)
app-crypt/heimdal required by (dev-vcs/cvs-1.12.12-r9::gentoo, installed)
app-crypt/heimdal required by (app-editors/emacs-23.2-r2::gentoo, installed)
app-crypt/heimdal required by (net-nds/openldap-2.4.23::gentoo, installed)
app-crypt/heimdal required by (kde-base/kdm-4.6.1::gentoo, installed)

(app-crypt/mit-krb5-1.10.3::gentoo, ebuild scheduled for merge) pulled in by
app-crypt/mit-krb5 required by (dev-libs/openssl-0.9.8x::gentoo, ebuild sche duled for merge)
app-crypt/mit-krb5 required by (mail-client/pine-4.64-r8::gentoo, installed)
app-crypt/mit-krb5 required by (net-fs/nfs-utils-1.2.6::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- dev-php/pecl-mcve-7.0.3-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (16 Sep 2012)
# Fails old-elibtoolize sanity check (#341721), has security
# issues. Removal in a month.

- media-libs/gmyth-0.7::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (16 Sep 2012)
# Dead upstream, fails tests (#315565), wasn't updated
# for recent MythTV versions. Removal in a month.

- media-plugins/gst-plugins-mythtv-0.10.19::gentoo (masked by: package.mask)
- net-libs/libmonetra-5.2::gentoo (masked by: package.mask)
- dev-db/mysql-5.1.52::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Jeremy Olexa <darkside@gentoo.org> (28 Jul 2009)
# On behalf of Robin H. Johnson <robbat2@gentoo.org>.
# These versions are vulnerable to GLSA's and should not be used. They will stay
# in the tree because they are useful to tracking down bugs. You have been
# warned. bug 271686

- sys-devel/gcc-4.7.1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Ryan Hill <dirtyepic@gentoo.org> (02 Apr 2011)
# Masked for testing

- app-pda/libopensync-0.36-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Ryan Hill <dirtyepic@gentoo.org> (30 Mar 2011)
# Masked indefinitely (until 0.40 is released).
# https://bugs.gentoo.org/354423

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
uri2013
n00b
n00b


Joined: 17 Oct 2012
Posts: 4

PostPosted: Thu Oct 18, 2012 2:44 am    Post subject: Reply with quote

Can't seem to install vmware-player.


[blocks B ] app-crypt/heimdal ("app-crypt/heimdal" is blocking app-crypt/mi t-krb5-1.10.3)
[blocks B ] app-crypt/mit-krb5 ("app-crypt/mit-krb5" is blocking app-crypt/ heimdal-1.4.1_pre20110304)


What should I do to fix this?

I guess it's something with heimdal and krb5, would really appreciate any support.

cheers
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4895

PostPosted: Thu Oct 18, 2012 6:20 am    Post subject: Reply with quote

uri2013 wrote:
Can't seem to install vmware-player.


[blocks B ] app-crypt/heimdal ("app-crypt/heimdal" is blocking app-crypt/mi t-krb5-1.10.3)
[blocks B ] app-crypt/mit-krb5 ("app-crypt/mit-krb5" is blocking app-crypt/ heimdal-1.4.1_pre20110304)


What should I do to fix this?

I guess it's something with heimdal and krb5, would really appreciate any support.

cheers


read. http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

this is gentoo, the docs are great, use them.

one thing I don't understand, you don't know what to do with blocks but you've been able to install gcc-4.7.0...
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum