Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
broadcom bcm43228 [14e4:4359] inactive
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Retired Dev
Retired Dev

Joined: 27 Jul 2004
Posts: 34

PostPosted: Mon Sep 24, 2012 11:18 am    Post subject: broadcom bcm43228 [14e4:4359] inactive Reply with quote

hello community,

someone has experience with this wlan chipset?

i am using a lenovo x131 with this wlan chipset. i have tried the opensource driver b43 first but failed. according to the kernel mailing list there are still problems. so i tried the closed source driver broadcom-sta according to

the device is detected as eth1 but when i start it (e.g. with /etc/init.d/net.eth1 start) i get the info that it has started but it is inactive. there is an info in the document above that if authorization fails i should try host ap. when i do this i got a kernel panic (gentoo 3.4.9).

wpa_cli status give me

corellia ~ # wpa_cli status
Selected interface 'eth1'
Supplicant PAE state=DISCONNECTED

i have not seen any helpfull infos in messages or dmesg.

i have tested several entries in my wpa_supplicant.conf. the actual values are:


i am using 2 different apple air port express routers. one using 2.4ghz the other 5.0ghz. both are hiding the ssid. i have tested my notebook on both wlan routers. also i have tested with a not hidden ssid. no success.
the routers are configured to use wpa2.

is my setup wrong?

best regards
Back to top
View user's profile Send private message

Joined: 01 Apr 2003
Posts: 43
Location: Łódź - Poland

PostPosted: Fri Oct 19, 2012 10:47 am    Post subject: Reply with quote

I have:
# lspci|grep 802
03:00.0 Network controller: Broadcom Corporation BCM43225 802.11b/g/n (rev 01

I was also unable to make it work with the inkernel driver, because somehow I missed a step:
emerge -av linux-firmware

plus I missed also the kernel setting of # Broadcom specific AMBA.

A good way of setting up wpa_supplicant
# wpa_passphrase <YOUR_SSID_NAME> >> /etc/wpa_supplicant/wpa_supplicant.conf
<enter your passphrase>

although this won't resolve any problem - it's just easier then editing the file manual.
I hope this helps a bit.
The only problem I encounter with this driver is with dhcpcd i.e. I have both net.eth0 and net.wlan0 created, but not started on boot. Instead I have
# cat /etc/conf.d/net

and rc-update added wpa_supplicant and dhcpcd to default
otherwise e.g. manually starting wlan0 makes the wlan0 connect/disconnect all the time.
best regards/ pozdrawiam
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum