Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome-shell-3.6.0 + gdm = i dont need gdm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
honp
Guru
Guru


Joined: 25 Sep 2006
Posts: 337
Location: Good old Prague, Czech rep.

PostPosted: Tue Oct 09, 2012 10:58 am    Post subject: gnome-shell-3.6.0 + gdm = i dont need gdm Reply with quote

Gentlemen,
i dont like installing more and more packages to my desktop gentoo system (especially packages i dont need) so i would like to know if there is way to not install gdm with the new gnome-shell-3.6.0. I use startx so there is no need for me to have it so i dont want it.

thank you very much
Back to top
View user's profile Send private message
Leo Laursen
n00b
n00b


Joined: 29 Mar 2012
Posts: 38

PostPosted: Tue Oct 09, 2012 12:51 pm    Post subject: Re: gnome-shell-3.6.0 + gdm = i dont need gdm Reply with quote

honp wrote:
way to not install gdm with the new gnome-shell-3.6.0.

Try seeing what pulls it in, if it's already installed.
Code:
equery d gnome-base/gdm

equery is from app-portage/gentoolkit.
In 3.4 it was only the meta file gnome-base/gnome that pulled gdm in.
If that is still the case, you could manage a version of the meta file in a local overlay, with only the dependencies you need.
I've created a gnome set (needs portage-2.2-alpha), and don't have any gnome meta files installed.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3057
Location: Redmond, WA

PostPosted: Fri Dec 28, 2012 11:34 pm    Post subject: Re: gnome-shell-3.6.0 + gdm = i dont need gdm Reply with quote

Leo Laursen wrote:
In 3.4 it was only the meta file gnome-base/gnome that pulled gdm in.
If that is still the case, you could manage a version of the meta file in a local overlay, with only the dependencies you need..
Btw, that's not the case anymore.

Code:
# equery d gnome-base/gdm
 * These packages depend on gnome-base/gdm:
gnome-base/gnome-shell-3.6.2-r1 (>=gnome-base/gdm-3.5[introspection])


Now, I don't understand why it should depend on gdm given that you can run the gnome-shell using xdm with the Gnome XSESSION set...
_________________
My political stance/bias
slycordinator != slycoordinator
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum