Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
{Solved} dansguardian + NTLM = Failed Compile
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 22 Jan 2007
Posts: 693
Location: Billings, MT, USA

PostPosted: Thu Oct 18, 2012 2:53 pm    Post subject: {Solved} dansguardian + NTLM = Failed Compile Reply with quote

Been having issues with USE="ntlm" in dansguardian. Here's what happens:
i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I..  -D__CONFFILE='"/etc/dansguardian/dansguardian.conf"' -D__LOGLOCATION='"/var/log/dansguardian/"' -D__PIDDIR='"/var/run"' -D__PROXYUSER='"clamav"' -D__PROXYGROUP='"clamav"' -D__CONFDIR='"/etc/dansguardian"'      -O2 -march=native -pipe -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -MT dansguardian-ip.o -MD -MP -MF .deps/dansguardian-ip.Tpo -c -o dansguardian-ip.o `test -f 'authplugins/ip.cpp' || echo './'`authplugins/ip.cpp
mv -f .deps/dansguardian-ident.Tpo .deps/dansguardian-ident.Po
i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I..  -D__CONFFILE='"/etc/dansguardian/dansguardian.conf"' -D__LOGLOCATION='"/var/log/dansguardian/"' -D__PIDDIR='"/var/run"' -D__PROXYUSER='"clamav"' -D__PROXYGROUP='"clamav"' -D__CONFDIR='"/etc/dansguardian"'      -O2 -march=native -pipe -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -MT dansguardian-ntlm.o -MD -MP -MF .deps/dansguardian-ntlm.Tpo -c -o dansguardian-ntlm.o `test -f 'authplugins/ntlm.cpp' || echo './'`authplugins/ntlm.cpp
mv -f .deps/dansguardian-fancy.Tpo .deps/dansguardian-fancy.Po
i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I..  -D__CONFFILE='"/etc/dansguardian/dansguardian.conf"' -D__LOGLOCATION='"/var/log/dansguardian/"' -D__PIDDIR='"/var/run"' -D__PROXYUSER='"clamav"' -D__PROXYGROUP='"clamav"' -D__CONFDIR='"/etc/dansguardian"'      -O2 -march=native -pipe -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -MT dansguardian-digest.o -MD -MP -MF .deps/dansguardian-digest.Tpo -c -o dansguardian-digest.o `test -f 'authplugins/digest.cpp' || echo './'`authplugins/digest.cpp
authplugins/ntlm.cpp: In member function 'virtual int ntlminstance::identify(Socket&, Socket&, HTTPHeader&, std::string&)':
authplugins/ntlm.cpp:205:87: error: expected primary-expression before ',' token
authplugins/ntlm.cpp:205:89: error: 'payload' was not declared in this scope
authplugins/ntlm.cpp:205:96: error: 'offsetof' was not declared in this scope
make[2]: *** [dansguardian-ntlm.o] Error 1
make[2]: *** Waiting for unfinished jobs....
mv -f .deps/dansguardian-ip.Tpo .deps/dansguardian-ip.Po
mv -f .deps/dansguardian-digest.Tpo .deps/dansguardian-digest.Po
make[2]: Leaving directory `/var/tmp/portage/net-proxy/dansguardian-'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-proxy/dansguardian-'
make: *** [all] Error 2
emake failed
 * ERROR: net-proxy/dansguardian- failed (compile phase):
 *   emake failed
 * Call stack:
 *, line  93:  Called src_compile
 *   environment, line 2010:  Called die
 * The specific snippet of code:
 *       emake OPTIMISE="${CFLAGS}" || die "emake failed"
 * If you need support, post the output of `emerge --info '=net-proxy/dansguardian-'`,
 * the complete build log and the output of `emerge -pqv '=net-proxy/dansguardian-'`.
 * The complete build log is located at '/var/tmp/portage/net-proxy/dansguardian-'.
 * The ebuild environment file is located at '/var/tmp/portage/net-proxy/dansguardian-'.
 * Working directory: '/var/tmp/portage/net-proxy/dansguardian-'
 * S: '/var/tmp/portage/net-proxy/dansguardian-'

>>> Failed to emerge net-proxy/dansguardian-, Log file:

>>>  '/var/tmp/portage/net-proxy/dansguardian-'

 * Messages for package net-proxy/dansguardian-

It seems there's a fix from Debian. I'll post it here and try it out.

+--- dansguardian-   2008-11-18 06:27:04.000000000 -0500
++++ dansguardian-   2011-08-25 16:37:38.000000000 -0400
+@@ -27,6 +27,8 @@
+ #include "../FDTunnel.hpp"
+ #include "../OptionContainer.hpp"
++#include <cstddef>
+ #include <syslog.h>
+ #include <iconv.h>

EDIT: Yep. That seems to make it compile just fine.
Router(Nokia IP390,2GB RAM,40GB HDD,4xGE/4xFE ports,Gentoo) | MyDT(Xeon X3470@3.4GHz,32GB RAM,6x2TB R5,GTX560Ti,LG BD-RE,Win7)
MyLT(Asus G53SX,32GB RAM,2x2TB HDDs,BD-RE,Intel 6230,Win7) | Wife(PnmIIX3@3.3GHz,8GB RAM,1TB HDD,DVDRW,Win7)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum