Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
net-nds/openldap-2.4.30 fails to emerge [SOLVED (sort of)]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 26 Jan 2005
Posts: 67

PostPosted: Sat Oct 06, 2012 6:12 pm    Post subject: net-nds/openldap-2.4.30 fails to emerge [SOLVED (sort of)] Reply with quote

I'm attempting to install Gentoo in a VM, and am having a bit of an odd problem. net-dna/openldap-2.4.30 doesn't want to build - at the end of the build log, I see:

 * Building contrib-module: samba4
make -j2 CC=i686-pc-linux-gnu-gcc libexecdir=/usr/lib/openldap
../../../libtool --mode=compile i686-pc-linux-gnu-gcc -g -O2 -DSLAPD_OVER_RDNVAL=2 -DSLAPD_OVER_PGUID=2 -DSLAPD_OVER_VERNUM=2 -I../../../include -I../../../se
rvers/slapd -I../../../include -c pguid.c
../../../libtool --mode=compile i686-pc-linux-gnu-gcc -g -O2 -DSLAPD_OVER_RDNVAL=2 -DSLAPD_OVER_PGUID=2 -DSLAPD_OVER_VERNUM=2 -I../../../include -I../../../servers/slapd -I../../../include -c rdnval.c
libtool: compile:  i686-pc-linux-gnu-gcc -g -O2 -DSLAPD_OVER_RDNVAL=2 -DSLAPD_OVER_PGUID=2 -DSLAPD_OVER_VERNUM=2 -I../../../include -I../../../servers/slapd -I../../../include -c rdnval.c  -fPIC -DPIC -o .libs/rdnval.o
libtool: compile:  i686-pc-linux-gnu-gcc -g -O2 -DSLAPD_OVER_RDNVAL=2 -DSLAPD_OVER_PGUID=2 -DSLAPD_OVER_VERNUM=2 -I../../../include -I../../../servers/slapd -I../../../include -c pguid.c  -fPIC -DPIC -o .libs/pguid.o
libtool: compile:  i686-pc-linux-gnu-gcc -g -O2 -DSLAPD_OVER_RDNVAL=2 -DSLAPD_OVER_PGUID=2 -DSLAPD_OVER_VERNUM=2 -I../../../include -I../../../servers/slapd -I../../../include -c pguid.c -o pguid.o >/dev/null 2>&1
libtool: compile:  i686-pc-linux-gnu-gcc -g -O2 -DSLAPD_OVER_RDNVAL=2 -DSLAPD_OVER_PGUID=2 -DSLAPD_OVER_VERNUM=2 -I../../../include -I../../../servers/slapd -I../../../include -c rdnval.c -o rdnval.o >/dev/null 2>&1
../../../libtool --mode=compile i686-pc-linux-gnu-gcc -g -O2 -DSLAPD_OVER_RDNVAL=2 -DSLAPD_OVER_PGUID=2 -DSLAPD_OVER_VERNUM=2 -I../../../include -I../../../servers/slapd -I../../../include -c vernum.c
libtool: compile:  i686-pc-linux-gnu-gcc -g -O2 -DSLAPD_OVER_RDNVAL=2 -DSLAPD_OVER_PGUID=2 -DSLAPD_OVER_VERNUM=2 -I../../../include -I../../../servers/slapd -I../../../include -c vernum.c  -fPIC -DPIC -o .libs/vernum.o
../../../libtool --mode=link i686-pc-linux-gnu-gcc -g -O2 -version-info 0:0:0 \
-rpath /usr/lib/openldap/openldap -module -o pguid.lo -lldap_r -llber
libtool: link: i686-pc-linux-gnu-gcc -shared  -fPIC -DPIC  .libs/pguid.o   -lldap_r -llber  -O2   -Wl,-soname -Wl, -o .libs/
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lldap_r
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -llber
collect2: ld returned 1 exit status
make: *** [] Error 1
make: *** Waiting for unfinished jobs....
libtool: compile:  i686-pc-linux-gnu-gcc -g -O2 -DSLAPD_OVER_RDNVAL=2 -DSLAPD_OVER_PGUID=2 -DSLAPD_OVER_VERNUM=2 -I../../../include -I../../../servers/slapd -I../../../include -c vernum.c -o vernum.o >/dev/null 2>&1
emake failed
 * ERROR: net-nds/openldap-2.4.30 failed (compile phase):
 *   emake samba4 failed
 * Call stack:
 *, line  85:  Called src_compile
 *   environment, line 3713:  Called die
 * The specific snippet of code:
 *               emake CC="${CC}" libexecdir="/usr/$(get_libdir)/openldap" || die "emake samba4 failed";
 * If you need support, post the output of `emerge --info '=net-nds/openldap-2.4.30'`,
 * the complete build log and the output of `emerge -pqv '=net-nds/openldap-2.4.30'`.
 * The complete build log is located at '/var/tmp/portage/net-nds/openldap-2.4.30/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-nds/openldap-2.4.30/temp/environment'.
 * Working directory: '/var/tmp/portage/net-nds/openldap-2.4.30/work/openldap-2.4.30/contrib/slapd-modules/samba4'
 * S: '/var/tmp/portage/net-nds/openldap-2.4.30/work/openldap-2.4.30'

The lines that caught my eye were:
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lldap_r
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -llber

I'll be honest - ld is mostly magic to me, but I think it's looking for libldap_r.a or and liblber.a or - I did:

# cd /var/tmp/portage/net-nds/openldap-2.4.30/work/openldap-2.4.30
# find | grep -E "lib(ldap_r|lber)\.l?a$"

and got:



So I'm not sure why ld isn't finding what it's looking for. The entire build log is kinda long, but I can post it if it'd be useful. Here's emerge --info:


Portage (default/linux/x86/10.0, gcc-4.5.3, glibc-2.15-r2, 3.3.8-gentoo i686)
System uname: Linux-3.3.8-gentoo-i686-Intel-R-_Core-TM-2_Duo_CPU_E8500_@_3.16GHz-with-gentoo-2.1
Timestamp of tree: Wed, 12 Sep 2012 01:00:01 +0000
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo
CFLAGS="-mtune=prescott -O2 -march=i686 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-mtune=prescott -O2 -march=i686 -pipe -fomit-frame-pointer"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --autounmask-write"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X Xaw3d a52 aac aalib acl acpi alsa ao apache2 avahi bash-completion bcmath berkdb bidi bzip2 cairo calendar caps cdb cdda cddb cdparanoia cgi cli consolekit cracklib crypt css ctype curl curlwrappers cxx dbase dbus dga dirac directfb djvu dri dts dv dvb dvd dvdr emacs encode esd exif expat fam fastcgi fbcon ffmpeg flac flatfile fltk fluidsynth fontconfig fortran ftp gcj gd gdbm ggi gif glib gmp gnutls gphoto2 gpm graphviz gs gstreamer gtk guile iconv icu id3tag idn imagemagick imap imlib inifile iodbc ipv6 jack java javascript jbig joystick jpeg jpeg2k kde kerberos ladspa lame lapack lash latex lcms ldap libcaca libnotify libsamplerate lm_sensors lua lzo mad mhash midi mikmod mmx mng modplug modules mono motif mp3 mp4 mpeg mssql mtp mudflap musepack mysql mysqli nas ncurses nis nls nptl nsplugin ocaml odbc ogg openal openexr opengl openldap openmp oss pam pch pcntl pcre pdf php png policykit posix postgres ppds pppd pulseaudio python qt3support qt4 quicktime readline ruby samba sasl sdl semantic-desktop session sharedext simplexml slang slp smp sndfile snmp soap sockets socks5 speex spell sqlite sqlite3 sse ssl startup-notification svg sysvipc tcl tcpd theora threads tidy tiff timidity tk tokenizer truetype tta twolame udev unicode usb v4l v4l2 vde vdpau vhosts vorbis wavpack wddx wma wmf x264 x86 xcb xcomposite xemacs xft xml xmlrpc xosd xpm xscreensaver xsl xv xvid xvmc yaz zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="vesa virtualbox" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Any ideas?

Last edited by jerann on Sun Oct 28, 2012 9:58 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 26 Jan 2005
Posts: 67

PostPosted: Sun Oct 28, 2012 9:58 pm    Post subject: Reply with quote

Well, I made the problem go away... I wouldn't really say I "solved" it though. I just added unmasked the testing branch (added "net-nds/open-ldap ~x86" to /etc/portage/package.keywords), and openldap-2.4.31-r1 compiles just fine. I still don't have any idea what the original problem was, but the rest of the system seems fine. Fortunately, using the testing branch of openldap didn't require a bunch of dependencies that aren't in the stable branch, so it was an easy fix.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum