Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
aufs3: unknown symbols [Solved]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 12 Aug 2003
Posts: 2478
Location: Silver City, NM

PostPosted: Fri Oct 05, 2012 7:03 pm    Post subject: aufs3: unknown symbols [Solved] Reply with quote

I'm trying to emerge aufs3 with the kernel patch on a system using gentoo-sources-3.4.9. The emerge succeeds but there are unknown "symbol errors" reported and these prevent the aufs.ko module from loading:
 * Updating module dependencies for 3.4.9-gentoo ...
WARNING: //lib/modules/3.4.9-gentoo/misc/aufs.ko needs unknown symbol inode_sb_list_lock
WARNING: //lib/modules/3.4.9-gentoo/misc/aufs.ko needs unknown symbol file_sb_list_del
WARNING: //lib/modules/3.4.9-gentoo/misc/aufs.ko needs unknown symbol do_splice_to
WARNING: //lib/modules/3.4.9-gentoo/misc/aufs.ko needs unknown symbol security_inode_permission
WARNING: //lib/modules/3.4.9-gentoo/misc/aufs.ko needs unknown symbol security_file_mmap
WARNING: //lib/modules/3.4.9-gentoo/misc/aufs.ko needs unknown symbol __devcgroup_inode_permission
WARNING: //lib/modules/3.4.9-gentoo/misc/aufs.ko needs unknown symbol lookup_hash
WARNING: //lib/modules/3.4.9-gentoo/misc/aufs.ko needs unknown symbol do_splice_from
WARNING: //lib/modules/3.4.9-gentoo/misc/aufs.ko needs unknown symbol do_truncate
WARNING: //lib/modules/3.4.9-gentoo/misc/aufs.ko needs unknown symbol security_file_permission
WARNING: //lib/modules/3.4.9-gentoo/misc/aufs.ko needs unknown symbol security_inode_readlink            [ ok ]

Here is my emerge --info:
# emerge --info sys-fs/aufs3
Portage (default/linux/amd64/10.0/desktop, gcc-4.5.4, glibc-2.15-r2, 3.4.9-gentoo x86_64)
                        System Settings
System uname: Linux-3.4.9-gentoo-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5200+-with-gentoo-2.1
Timestamp of tree: Fri, 28 Sep 2012 20:30:01 +0000
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.4.6, 2.6.6-r2, 2.7.3-r2, 3.1.5, 3.2.3
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.4.5, 4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo multimedia sunrise local
Installed sets: @system
ACCEPT_LICENSE="* -@EULA dlj-1.1 PUEL googleearth AdobeFlash-10.1 AdobeFlash-10 AdobeFlash-10.3 Oracle-BCLA-JavaSE google-chrome MakeMKV-EULA"
CFLAGS="-march=athlon64 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/multimedia /var/lib/layman/sunrise /usr/local/portage"
USE="3dnow 3dnowext X a52 aac acpi alsa amarok amd64 bash-completion berkdb bluray branding bzip2 cairo cdda cddb cdparanoia cdr cjk cli consolekit cracklib crypt cups cxx dbus djvu dri dts dvd dvdnav dvdr dvdread emboss emovix encode exif fam fbcon ffmpeg firefox flac fortran gdbm gif glitz gmp gpm gtk iconv id3 ieee1394 imagemagick java jpeg kpathsea lcms libnotify libwww lirc lm_sensors logitech-mouse mad mmx mmxext mng modules mp3 mp4 mpeg mplayer mudflap multilib musicbrainz ncurses nls nptl nsplugin objc ogg opengl openmp pam pango pcre pdf plotutils png policykit ppds pppd python qt3support quicktime readline ruby sdl session sockets spell sse sse2 ssl startup-notification svg tcltk tcpd tetex tidy tiff tk truetype udisks unicode upower usb vaapi vdpau vim-pager vim-syntax vorbis wxwidgets x264 xcb xcomposite xetex xine xinerama xml xmp xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" LIRC_DEVICES="mceusb" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="net" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

sys-fs/aufs3-3_p20120813 was built with the following:
USE="kernel-patch (multilib) -debug -doc -fuse -hfs -inotify -nfs -pax_kernel -ramfs"

Last edited by BitJam on Sat Oct 06, 2012 11:03 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Sat Oct 06, 2012 10:27 am    Post subject: Reply with quote

After emerging aufs3 with USE="kernel-patch", you need to build and install the kernel.
Back to top
View user's profile Send private message

Joined: 12 Aug 2003
Posts: 2478
Location: Silver City, NM

PostPosted: Sat Oct 06, 2012 10:47 am    Post subject: Reply with quote

Thanks. I'm trying that now.

Edit: It worked! The missing symbol errors went away. I got a different fatal error when I tried to "modprobe aufs" but that error went away when I emerged aufs3 again after rebuilding and installing the kernel after emerging aufs3 for the first time.

So the recipe is:
  1. Emerge aufs3
  2. Rebuild and re-install the kernel
  3. Emerge aufs3 again

Thanks again for your help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum