Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ati-drivers-12.11_beta: unable to query kernel module
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 25 Nov 2012
Posts: 2

PostPosted: Sun Nov 25, 2012 11:32 am    Post subject: ati-drivers-12.11_beta: unable to query kernel module Reply with quote

I got this message in Xorg.0.log:
"(EE) fglrx(0): unable to query kernel module!(EE) fglrx(0): PreInit failed"
Of course, X doesn't start. Previous stable ati-drivers worked perfectly on the same kernel.
If someone got working ati-drivers-12.11 on 3.6.x kernels and xorg-server 1.13, please, show me your kernel config.
Back to top
View user's profile Send private message

Joined: 20 Aug 2012
Posts: 353

PostPosted: Mon Jan 07, 2013 2:03 am    Post subject: Reply with quote

You need to give more information, starting with the actual GPU hardware you're using and what driver/ebuild you had functional before.

ATI tends to kill off support of older models with every major version bump on their drivers. Determine if your card is still supported via the closed source ati-drivers or you may need to switch to the open source radeon driver.

Your error to me sounds like either your hardware isn't supported or your extra firmware to support it isn't getting into your kernel.

My reference is a newer (as of November) build here on x86_64 multilib profile. System is i5 cpu with an ati 7850 gpu, 3.6.11-gentoo source manually configured kernel. I'm using a Gnome 2 desktop. If you're using similar newer hardware, what I mention below may be applicable to you.

This had been running flawless with xorg-server 1.12.4 to 1.13.1. However, the recent ati-drivers-12.11_beta11 show bug reports of freezes and graphic corruption. I had not noticed corruption issues, but there's definitely a serious quality control problem when energy savings kick on (screen saver) or easily reproducible from just logging out of Gnome to shutdown X (I manually startx instead instead of a login/display manager specifically to help avoid issues like this). Each result in a hard lockup, signal loss to display, Alt-SysRq is completely non-functional, aka dead in the water other than a hard reset.

IMHO, the current ati-drivers-12.11_beta11 should not be released in the 'stable' category. Even though they are literally in the testing/beta ATI deny deny deny category already anyway. ;-)

After several attempts to make sure it wasn't something on my end, including entire make clean kernel rebuilds, I got tired of testing to see if I could corrupt my filesystem in the process so I'd recommend:

Mask out ati-drivers-12.11_beta11
# echo "=x11-drivers/ati-drivers-12.11_beta11" >>/etc/portage/package.mask

Falling back to starting with ati-drivers-12.11_beta (which for me have worked well) and working your way backward as needed from there.

Microcode firmware in my case is from x11-drivers/radeon-ucode-20120320.

With my particular hardware setup, my kernel has these related entries:

CONFIG_EXTRA_FIRMWARE="radeon/PITCAIRN_ce.bin radeon/PITCAIRN_mc.bin radeon/PITCAIRN_me.bin radeon/PITCAIRN_pfp.bin radeon/PITCAIRN_rlc.bin"
# Firmware Drivers
# CONFIG_FB_RADEON is not set
# CONFIG_DRM is not set

In some rare cases you may want FIRMWARE_EDID set.
Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum