Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Stumpwm help [solved]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 14 Sep 2004
Posts: 52
Location: Peru

PostPosted: Thu Sep 27, 2012 5:45 am    Post subject: Stumpwm help [solved] Reply with quote

Hi I'm currently having a problem running stumpwm. After emerging stumpwm with the sbcl flags, much to my surprise after the instalation there was no stumpwm.

It appears to be an issue with asdf and asdf-binaries as when I try the solution proposed in this post: I get the following error:

* (asdf:oos 'asdf:load-op :stumpwm)

debugger invoked on a SIMPLE-ERROR in thread
#<THREAD "initial thread" RUNNING {1002998CE3}>:
  ASDF 2 is not compatible with ASDF-BINARY-LOCATIONS, which you are using.
ASDF 2 now achieves the same purpose with its builtin ASDF-OUTPUT-TRANSLATIONS,
which should be easier to configure. Please stop using ASDF-BINARY-LOCATIONS,
and instead use ASDF-OUTPUT-TRANSLATIONS. See the ASDF manual for details.
In case you insist on preserving your previous A-B-L configuration, but
do not know how to achieve the same effect with A-O-T, you may use function

Any Ideas?

Edit: today I solved both issues by reemerging sbcl with the -asdf flag. Apparently it conflicted with quicklisp. And after that I followed the instructions in the arch wiki* to use quicklisp for deps and compiling from the git sources

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum