Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Semi-Solved]A problem with my GPU or my APU(CPU)
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 05 Apr 2012
Posts: 200

PostPosted: Mon Sep 24, 2012 4:28 pm    Post subject: [Semi-Solved]A problem with my GPU or my APU(CPU) Reply with quote

I'm not sure yet. i'm running a HP Pavilion dv7-6109eo

This APU: 2.1 GHz AMD Dual-Core A4-3400MX APU with Radeon HD 6515G2 Dual Graphics
This GPU: AMD Radeon HD 6515G2 Dual GPU (512 MB DDR5 dedicated)

From the official specs page on hp's website

I've been having this problem on Windows (full, short story)

I updated my graphics drivers from amd's website, and as soon as windows booted up i got a completely black screen (as in screen off) and most of the lights on the computer (for example, around the touchpad) went dark.
I rebooted the computer, went to safe mode, rolled back the drivers (no, i really uninstalled them completely, then reinstalled the outdated ones) everything worked fine
Time passed, i decided to install linux on my laptop (again) and so i get started. I manage to erase the bootmanager forcning me to reinstall windows, i set it all up, set up the drivers aswell all up to date, reboot and get this black screen.
I reinstall windows after that, i tried something different after that. as soon as i had it set up, i installed the drivers from HP's website for my gpu, rebooted, it worked, installed the up-to-date drivers, it worked again. yay, i now had a fully functional installed windows-7 and a barely functional gentoo installed on dual boot (of course i just re-installed the grub after that)
Somehow i managed to mess up my gentoo installation (you surprised?) so, i went on ahead and just reinstalled it (a habit from windows, if i mess something up i have a tendancy to do a fresh reinstall) i did so successfully, however... now heres an interesting part. This time, when i tried to boot back into windows, i got a black screen, but "everything" else was fully functional. (it even booted up properly and started, which it did not do normally when i had my blackscreen problem)

Thinking i could just repeat the same drill again with my windows and reinstall it, then start with my gpu drivers and reboot and everything should work fine... right? no, not this time, this time i just get the error, again, and tried once more, and get it again, then i tried just deleting all partitions, and installing only windows, same story, tried again, same deal, and decided "fuck you windows, i'm going with my linux.

This is extremely weird, considering it was working fine, until i updated the drivers, leading me to believe it was a software issue, then after doing a fresh reinstall... i kindof changed my thinking, into "I don't even know what to think..."

And so i have ragequit on windows.

Heres how it's currently presenting itself on linux and how my troubleshooting goes: (As if it were an overheating problem)
I followed this guide:
After installing the X Windows Server, which got my GPU working, after booting up my screen changes to its native resolution (instead of 800x600), everything works wonderfully.
Until i decide to install kde
Now i'm emerging layman
I run "emerge layman"
its a good 90 packages i think, about 50 packages through, i get the same problem as on windows
I reboot, everything works fine
I decided to make a new kernel with experimenting with different options until i find some that lets my bypass this problem (as my computer had been until i updated the settings to make my gpu work). (Note: Everytime i go try something else, i re-enable whatever it was i had last disabled. Dark Red fonts for option changes that did not fix my problem.)

I tried again without Hybrid GPU Switching support, after 20 or so packages, same problem again

I disabled agp support. -testing (on the roughly 40 remaining layman packages) i got through 5, and then i was down again

I tried disabling the Backlight Control Support (framebuffer) altho i am doubtful it will help. and it didn't seem to.
NEW: (First time this happens)This time my motherboard said it detected my computer had automatically hibernated to prevent overheating. (Hibernating huh... hmm, i'll have to look into this, is it really just hibernating i wonder...) also, after that message, when i tried to boot into my gentoo, i got that same black screen again. If it was just hibernating due to overheating this wouldn't be a problem, but i'm pretty sure thats not the case with my windows.

Now i will try disabling DDC/I2C for ATI Radeon support. Failed.

Now i will try re-enabling Firmware Blobs (as suggested by developer) - Running, Got the problem again, Seems it was really hibernating, when i pressed the power button, it went back on and kept compiling, then after a little while it shutdown (as if i had initiaded a shutdown command) and didn't boot back up (as with every time that i turn it off by holding down the power button) i think this was probably an emergency shutdown cus the system would have detected imminent overheating, and most certianly is it getting hot. however what boggles me is that this is only happening when i've got my GPU running properly.

This time i got my BIOS message again that said i had overheated. so it certainly did nearly overheat, i'll have to clean out my fans... such a troublesome thing to do with laptops, maybe i'll have some company do it for me...

Trying next to run it with my screen closed. but first i'm gonna let it cool down. I shut it down, and completely unplugged it. Now running 32 remaining packages with my screen closed. (I open it from time to time to check if its not hibernating or whatever) It hibernated again, i just had it shutdown.

I will try to disable ATI Radeon Frame Buffer support. and seeing if it really won't overheat anymore when thats off. -Failed

Now i disabled the Direct Rendering for ATI Radeon and the KMS support. Note:my resolution dropped back down to 800x600 when i did this. -running 32 remaining packages. - Confirmed to work, i do not overheat nor hibernate with this on. With this i can now run one kernel capable of fully using my gpu, and running X, and one kernel which i would only use for compiling and such, since when i do that with my GPU fully enabled, i seem to get overheating problems.

Linux: my processor seems to overheat after a while of compiling programs when my GPU is enabled, and if my GPU is enabled, then my processor will heat excessively up to around 80-90°C while mostly idle...
Windows 7: I have switched back to windows. Thanks to my experiences with linux i found out what never occured to me that it was an overheating problem. I reinstalled windows, i installed my GPU driver, rebooted and got this "hibernation" again (even if i had disabled it) so i turned it off and unplugged all power, and waited till it was cold, i updated my drivers again and haven't had this issue since. My laptop is running like it should on windows 7 after that, and the processor is not heating up too much when i'm doing any of my regular tasks (i have yet to check what it says about video games tho) (But i'll still be using gentoo on my main pc)

I Thought it was extremely weird that i was having this problem during an emerge, cus that doesn't have much to do with my gpu right?

This is also, as a fun note, the very first problem i've had on windows, that i've been unable to fully troubleshoot and/or fix. I'm talking both hardware and software here, but usually i work on a PC, which makes it a lot easier to change out parts, which i would be trying right now.... if it wasn't a laptop. And this is where, for an absolute coincidence, Gentoo Linux steps in. with tons and tons and tons more troubleshooting capabilities than Windows ever had.

Currently, after learning that the motherboard said it was hibernating, depending on circumstance, i may re-install windows, and disable hibernation, and see if that will fix my problem on there.

Now.... Does anyone think theres a way to fix this (without KMS i cannot start X Windows-Server without it)

My own ideal next step in all this is to take the computer to a hardware store and ask them to clean out my fans, and replace the thermal paste on my processor also while at it, disconnect, and then re-connect my inverter board because it's not properly connected i believe (screen flickers sometimes, etc) (altho on such a recent laptop model i think its kindof weird if thats needed, but couldn't hurt) if thats too expensive, i'll take it upon myself to do this, even if i hate the idea since i'm bad with laptops.

I'll give an update to this thread after doing so. Until then i'll keep an eye on it for any suggestions.
This picture was my biggest reason for ever trying Gentoo <3

Last edited by rabcor on Thu Aug 15, 2013 5:58 pm; edited 28 times in total
Back to top
View user's profile Send private message

Joined: 05 Aug 2006
Posts: 2151
Location: Berlin, Germany

PostPosted: Mon Sep 24, 2012 4:53 pm    Post subject: Reply with quote

Did you try removing power and battery for a short while, then inserting it again?

Also, for kernel config best follow (especially the firmware part).
Back to top
View user's profile Send private message

Joined: 05 Apr 2012
Posts: 200

PostPosted: Mon Sep 24, 2012 5:10 pm    Post subject: Reply with quote

chithanh wrote:
Did you try removing power and battery for a short while, then inserting it again?

Also, for kernel config best follow (especially the firmware part).

I followed that. but i needed the other guide because i was having problems with that setup, as in... it wasn't working, that guide i followed was specifically made for APUs.

I have no battery installed, but i have rarely tried removing the power, but just tonight i had the power completely off on it.
This picture was my biggest reason for ever trying Gentoo <3
Back to top
View user's profile Send private message

Joined: 05 Apr 2012
Posts: 200

PostPosted: Thu Aug 15, 2013 5:56 pm    Post subject: Reply with quote

Closest thing to a solution i got if someone has the same problem:

The problem seems to be that the APU is overheating, but i might be wrong and it might be the GPU, it could also be both.

Further inspectation showed that it had to do with the hybrid graphics thing.

So, for starters. The radeon module needs to be disabled.

Without the radeon module the computer can't activate the hybrid graphics thing.

There are two ways to make the GPU work without overheating all the time for me, it can still overheat, but it takes longer to do it.


If you get stuck on an installation and can't install because the laptop overheats before you can finish installing, try entering in one of these options in the command line before booting the install CD



you can also, just in case after booting into the liveCD run this command.
modprobe -r radeon

to make sure its definetly disabled. (The command will probably fail if the radeon module was actually enabled. giving you an error about the module being in use or something alike)

Open Source Radeon Driver Solutions:
1) try typing the following in a terminal:
#echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

you can also check if you can find the file on that path and read it with nano,, see if the command went through, or if the file just doesn't exist at all.
2) If this worked, you need to make this command run every time you boot up the computer. You're on your own about how to do it, i think i used systemd-tmpfiles (it's been a while) to do it, but there are many ways to do it.

3) If the .../vgaswitcheroo/switch file did not exist(this did happen to me at some point) i forgot how i made it... appear. But this shouldn't happen though. It may be that the kernel setting for hybrid graphics needs to be enabled for it to work. It also might be that it works to disable that kernel option instead of doing step 1 and 2, but this is how i did it.

Proprietary Catalyst Driver Solution:
Just install the catalyst drivers and configure it so it doesn't use switchable/hybrid graphics, it should be pretty self explanatory and doable within a GUI environment.
note: To properly use the catalyst driver one must disable the radeon drivers first. I blacklisted them to do this.

Solutions that should work that i didn't try: (sorry for being lazy)
1: Blow out the fans of the laptop with pressurized air to clean out the dust inside
2: Replace (or have replaced) the thermal grease for the APU and/or the GPU depending on which is really overheating.

I noticed re-reading my old post here that my laptop was crashing while i was emerging programs, so it may in fact be that the APU was overheating during compilations. Hope this isn't the case if you're using gentoo, but if you find that it is i recommend you turn to archlinux instead. (thats what i did)
This picture was my biggest reason for ever trying Gentoo <3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum