Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
slim + fluxbox normal user session opened and closed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
donqui
n00b
n00b


Joined: 06 Aug 2010
Posts: 15
Location: BE

PostPosted: Sun Sep 09, 2012 8:15 pm    Post subject: slim + fluxbox normal user session opened and closed Reply with quote

Today, I was installing my pxe fat-client gentoo with slim as login manager + fluxbox as window manager.

After just following the pages here: http://www.gentoo.org/doc/en/fluxbox-config.xml?style=printable it was working for root and normal users as well.
Now, after some emerges of vlc and other packages, the login is not working for normal users anymore. (using the same user as before)

I don't get the failed to execute login script error but just drop back to slim. (with strange effect on desktop: the leftside of the desktop is in half of my screen and it wraps around the right edge but hey..)

Now, all I see is in the messages logs is:
...
Sep 9 21:59:15 pxe-gentoo slim: pam_unix(slim:session): session opened for user lieven by (uid=0)
Sep 9 21:59:15 pxe-gentoo slim: pam_unix(slim:session): session closed for user lieven
Sep 9 21:59:15 pxe-gentoo kernel: [ 169.218166] mtrr: no MTRR for c0000000,10000000 found

and I go back to the login screen of slim.
In my ~/.fluxbox/startup, I added a line "logger startingfluxbox" but that does not even appear in the messages.
I tried to use exec fluxbox -log "/home/lieven/.fluxbox/log" from the startup but no log gets created.

following services are running:
pxe-gentoo ~ # rc-config list default
Init scripts to be started by runlevel default
consolekit
dbus
local
netmount
sshd
syslog-ng
udev-postmount
xdm

I do not use the .xinitrc or .xsession files per user as I have the systemwide config (at least I think so)

this is in /etc/conf.d/xdm:
DISPLAYMANAGER="slim"

nothing in /etc/rc.conf to override:
pxe-gentoo ~ # cat /etc/rc.conf | grep -i session
pxe-gentoo ~ # cat /etc/rc.conf | grep -i display

the fluxbox is in my user path:
lieven@pxe-gentoo ~ $ echo $PATH
/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.4
lieven@pxe-gentoo ~ $ whereis fluxbox
fluxbox: /usr/bin/fluxbox /usr/share/fluxbox /usr/share/man/man1/fluxbox.1.bz2

and it seems to be ok concerning user rights:
lieven@pxe-gentoo ~ $ ls -l /usr/bin/fluxbox
-rwxr-xr-x 1 root root 1561832 Sep 5 21:21 /usr/bin/fluxbox

login to slim as root gives this in messages:
Sep 9 22:13:51 pxe-gentoo slim: pam_unix(slim:session): session opened for user root by (uid=0)

Anybody has any clues as to what is going wrong here? I'm totally desperate after a day of troubleshooting on this previously working thing

In the meantime, I have installed the consolekit, dbus etc.

thanks for your help.
Back to top
View user's profile Send private message
donqui
n00b
n00b


Joined: 06 Aug 2010
Posts: 15
Location: BE

PostPosted: Mon Sep 10, 2012 8:23 am    Post subject: Reply with quote

Hi, I tried to use the .xinitrc script to autostart fluxbox with the "exec startfluxbox" command to no avail. I know I cannot use the ck-launch-session in that script because slim always does that automatically and we don't need 2 sessions.

Also tried with creating a new user.

Really, I don't see any differences between the normal users and root concerning the slim-fluxbox login as those are general settings in slim.conf and xdm

Except maybe rights for the users? But I have no clue where to look. Is there a way to increase the logging for slim/fluxbox?

Is it possible that the local ~/.fluxbox/* files are not called if you do not use a local .xsession or .xinitrc file? Then the settings in /usr/share/fluxbox should do but I cannot see any problem there either.

All advice welcome.

thanks.
Back to top
View user's profile Send private message
donqui
n00b
n00b


Joined: 06 Aug 2010
Posts: 15
Location: BE

PostPosted: Mon Sep 10, 2012 9:03 pm    Post subject: [SOLVED] issue with xsession variable on openrc baselayout 2 Reply with quote

My own stupidity prevented me from solving this issue.

facts:
this system was installed from a new gentoo cd with stage 3 tarbal on an nfs share.
emerged slim & fluxbox => normal user could login to slim without ~/.xinitrc or ~/.xsession files.
I used this "echo "XSESSION=fluxbox" > /etc/env.d/90xsession" to get normal user login to work.

what happened? (I think)
At one point, I did an emerge --update --deep --newuse --ask world system and all of a sudden the normal users couldn't login anymore. "failed to execute command"
Maybe the system was not using openrc / baselayout2 ??? Which seems odd because it's a very recent stage2 + small boot iso from the gentoo site. (begin august 2012)
Anywayz: the xsession variable was not read I guess and the normal user could not login anymore. I'm just guessing, really.

What did I do to get it working again:
followed an ancient thread:
- changed XSESSION=fluxbox to startfluxbox
- created ~/.xinitrc (exec startfluxbox)
- changed login_cmd in /etc/slim.conf:
#login_cmd exec /bin/bash -login /usr/share/slim/Xsession %session < old
login_cmd exec /bin/bash -login ~/.xinitrc %session < new
- changed sessions/sessiondir in slim.conf:
#sessiondir /etc/X11/Sessions < old, commented out now
sessions fluxbox < new
the last thing, I don't know if it's needed, I have this directory:
lieven@pxe-gentoo ~ $ ls -l /etc/X11/Sessions/
total 8
-rwxr-xr-x 1 root root 2187 Sep 3 21:49 Xsession
-rwxr-xr-x 1 root root 2078 Sep 10 20:18 fluxbox

but anyway, after a reboot, (re-added xdm to default runlevel) it worked to login with the normal user.


Now, I have some other issues which may or may not be related:
- when doing ctrl-alt-f1 or alt-f1 or so, I can't get a console...
- when ctrl-alt-delete I get back to login screen but half of the screen is wrapped around the edge to the other edge.
=> probl. driver issues for my radeon something which is from a brazos amd e450 platform. (it is a netboot diskless htpc)
This issues should be addressed in another thread I guess.

thanks for reading.

cheers.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum