Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
fonts in KDE appear too small
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Daemon
n00b
n00b


Joined: 18 Apr 2002
Posts: 65

PostPosted: Thu Apr 25, 2002 5:21 am    Post subject: fonts in KDE appear too small Reply with quote

size 12 and 14 fonts appear way smaller than they should be... very.. tiny small fonts. i have to set them to size 39 in the control panel to make them readable. but even after i set all the fonts to size 39 in the control panel, the file manager and some other KDE apps still display those tiny fonts. why is this problem with the scale?
Back to top
View user's profile Send private message
justus
n00b
n00b


Joined: 16 Apr 2002
Posts: 48

PostPosted: Thu Apr 25, 2002 12:48 pm    Post subject: Hmmm... Try this... might work Reply with quote

I also had problems with small fonts (using Nvidia drivers and 1600x1200 resolution) an decided to set the dpi of the xserver.

You can try editing the /etc/X11/xdm/Xservers file (I believe that is the correct file... not at my computer right now...) to change the init string for X.

It should look something like:
Code:
:0 local /usr/X11R6/bin/X -deferglyphs 16

Change it to look like:
Code:
:0 local /usr/X11R6/bin/X -deferglyphs 16 -dpi 110

The dpi itself you can change to find something suitable for you, but that generally works good for me.

Hope that helps... Oh and with kde3 you can do the set all fonts option when you change the font. I believe it might not always work correctly, so try to change the font, size and type seperately... that might also help :)

Justin T[/code]
Back to top
View user's profile Send private message
Daemon
n00b
n00b


Joined: 18 Apr 2002
Posts: 65

PostPosted: Thu Apr 25, 2002 2:02 pm    Post subject: Reply with quote

Thanks for the help but that didn't solve it. i tried with dpi=80-160 with no effect at all.. im afraid that's not it.

here is what's happening... look at the font of the file names.

[img:801ec3ee56]http://duraid.netfirms.com/snapshot1.png[/img:801ec3ee56]
Back to top
View user's profile Send private message
Malakin
Veteran
Veteran


Joined: 14 Apr 2002
Posts: 1692
Location: Victoria BC Canada

PostPosted: Thu Apr 25, 2002 8:04 pm    Post subject: Reply with quote

Use a different font.
Back to top
View user's profile Send private message
Daemon
n00b
n00b


Joined: 18 Apr 2002
Posts: 65

PostPosted: Thu Apr 25, 2002 9:14 pm    Post subject: Reply with quote

Malakin wrote:
Use a different font.


i tried but still size 10 - 12 are awfully small.
Back to top
View user's profile Send private message
Malakin
Veteran
Veteran


Joined: 14 Apr 2002
Posts: 1692
Location: Victoria BC Canada

PostPosted: Thu Apr 25, 2002 9:55 pm    Post subject: Reply with quote

In your screenshot the fonts up top look fine, why not use that font for the folders?
Back to top
View user's profile Send private message
DarrenM
l33t
l33t


Joined: 25 Apr 2002
Posts: 653
Location: Sydney, Australia

PostPosted: Thu Apr 25, 2002 11:23 pm    Post subject: Reply with quote

One possible cause for this problem is the default font resolution used by X. It's normally 75 but at higher screen resolutions I usually need to go to 100.

Find the config file for the font server. I don't have access to my Gentoo machine atm but on redhat it's /etc/X11/fs/config

In it you will see that the default font res is 75. Try changing it too 100 by changing the default-resolutions line to:

default-resolutions = 100,100,75,75

You may also need to change the catalog section to have the 100dpi lines above the 75dpi ones but I'm not certain about that.
Back to top
View user's profile Send private message
Daemon
n00b
n00b


Joined: 18 Apr 2002
Posts: 65

PostPosted: Thu Apr 25, 2002 11:55 pm    Post subject: Reply with quote

DarrenM wrote:

In it you will see that the default font res is 75. Try changing it too 100 by changing the default-resolutions line to:

default-resolutions = 100,100,75,75


i did that but it didn't help. i would really appreciate it if you help me with this cause my kde looks amazing except for that problem.
Back to top
View user's profile Send private message
DarrenM
l33t
l33t


Joined: 25 Apr 2002
Posts: 653
Location: Sydney, Australia

PostPosted: Fri Apr 26, 2002 12:23 am    Post subject: Reply with quote

This is from an older KDE FAQ covering XFree86 3.x.x hence the different config file for the font options. Looks like you do need to change the catalog section.

Quote:

I have played with the fonts section in the KDE Control Center but the fonts are still way too small. What can I do?

Many users use the 75 dpi fonts as the default. If you have installed the 100 dpi fonts, make sure your XF86Config file has those fonts in the path before the 75 dpi fonts. Here is a step-by-step procedure on how to do it:

1.

Open /etc/Xll/XF86Config using your favorite editor.
2.

Near the top of the file is a several-row listing of fonts: type1, speedo, etc., and at the bottom there are two entries: 75dpi and 100dpi. Reverse their order. And while you are at it, move the Type 1 fonts to the bottom of the list (or somewhere below the 75 and 100 dpi fonts). That makes an improvement too!
Back to top
View user's profile Send private message
Daemon
n00b
n00b


Joined: 18 Apr 2002
Posts: 65

PostPosted: Fri Apr 26, 2002 12:57 am    Post subject: Reply with quote

Quote:

1. Open /etc/Xll/XF86Config using your favorite editor.
2.

Near the top of the file is a several-row listing of fonts: type1, speedo, etc., and at the bottom there are two entries: 75dpi and 100dpi. Reverse their order. And while you are at it, move the Type 1 fonts to the bottom of the list (or somewhere below the 75 and 100 dpi fonts). That makes an improvement too!


no man that's not it. i tried all the posible orders with no success. thanks alot for the help tho:)
Back to top
View user's profile Send private message
Guest






PostPosted: Fri Apr 26, 2002 1:06 am    Post subject: Reply with quote

Are you restarting X (and thus the x font server) after changing the configuration? Are you sure you have the 100dpi fonts installed? What screen res are you using? 2048x1532 on a 19" monitor will look tiny no matter what :-)

I have no other ideas. That is what I use to fix my machines when I have this problem.
Back to top
justus
n00b
n00b


Joined: 16 Apr 2002
Posts: 48

PostPosted: Fri Apr 26, 2002 5:44 am    Post subject: Another try :) Reply with quote

Since you have decent fonts above, have you tried to update the desktop or filemanager fonts?

When you are in Konqueror go to the settings menu and then configure Konqueror. Under the top option (File Manager) you should see a tab with the option of Appearance. On there you can change the font to something different.

Sometimes it is also due to this not being set up and then X substitutes it's own font's for one that should be.

Try there and see if that helps... Same goes for desktop (right click on desktop, Configure Desktop option, Appearance Tab.)

If you try and it doesn't work, then go ahead and try another font...sometimes X is picky too :)

Justin T
Back to top
View user's profile Send private message
Daemon
n00b
n00b


Joined: 18 Apr 2002
Posts: 65

PostPosted: Fri Apr 26, 2002 10:29 pm    Post subject: Reply with quote

Anonymous wrote:
Are you restarting X (and thus the x font server) after changing the configuration? Are you sure you have the 100dpi fonts installed? What screen res are you using? 2048x1532 on a 19" monitor will look tiny no matter what :-)

I have no other ideas. That is what I use to fix my machines when I have this problem.


- sure im restarting X :)
- i did ls on my /usr/X1R6/lib/X11/fonts/100dpi and there are a lot of fonts there.. i don't know if they are installed or not
- im using 1024x768 on a 17" monitor

Quote:
If you try and it doesn't work, then go ahead and try another font...sometimes X is picky too


the file manager font im using is Helvetica-size 18 and that's the maximum size it can be set to. i tried with many other fonts -> same thing.


I really believe it's a font scale problem... some how some where some thing is set that makes 36 size fonts look like size 10... where is that done .. i dunno.
Back to top
View user's profile Send private message
Daemon
n00b
n00b


Joined: 18 Apr 2002
Posts: 65

PostPosted: Sun Apr 28, 2002 5:12 pm    Post subject: Reply with quote

guys i think i got it. i just need your help with this:

if you're running 1024x768 resolution please tell me the output of this command:

# xdpyinfo | grep dots

mine is 25x25,.. what's yours?
Back to top
View user's profile Send private message
maverick
n00b
n00b


Joined: 24 Apr 2002
Posts: 37
Location: IRC

PostPosted: Fri May 03, 2002 4:44 pm    Post subject: Reply with quote

yea that might be it :p

xdpyinfo | grep dots
resolution: 101x108 dots per inch
-(maverick@Dyne)(maverick)>


im using 1280x1024 on a 17" and my kde fonts look fine
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum